Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: [HELP!] Missing Drivers After Clean Windows 7 Installation.


07 Aug 2012   #1

Windows 7 Ultimate 64bit
 
 
[HELP!] Missing Drivers After Clean Windows 7 Installation.

Can someone please help? Ive upgraded from Windows 7 Home Premium to Ultimate(custom advance). And now my Ethernet Controller drivers and Video are missing.
I tried downloading it on my other laptop and putting in the USB to install , but it keep saying installing unsuccessful.

XPS 17 (L702X)




Attached Thumbnails
[HELP!] Missing Drivers After Clean Windows 7 Installation.-77.jpg   [HELP!] Missing Drivers After Clean Windows 7 Installation.-messed-up.jpg  
My System SpecsSystem Spec
.

07 Aug 2012   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi perryy, Welcome to the forums, Are you using this link for the drivers ? Drivers and Downloads | Dell [United States] Another thing to watch for is make sure when using a USB pendrive is that it is not trying to install to the pendrive instead of the C :/ drive ,Make certain you are installing the correct driver there are 8 network and 8 video drivers to chooise from
My System SpecsSystem Spec
07 Aug 2012   #3

Windows 7 Ultimate 64bit
 
 

Yes i've tried but after installing the drivers still no help.. it only say Installing Unsuccesful.
My System SpecsSystem Spec
.


08 Aug 2012   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi perryy, try reinstalling the chipset drivers then installing the missing device drivers
My System SpecsSystem Spec
08 Aug 2012   #5

Windows 7 Ultimate 64bit
 
 

Thank you ! also do you know where i can download the driver for my motherboard please?
My System SpecsSystem Spec
08 Aug 2012   #6

Windows 7 Home Premium x64 SP1
 
 

Perryy do you mean the BIOS ?
My System SpecsSystem Spec
09 Aug 2012   #7

Windows 7 Ultimate 64bit
 
 

Is that what is it? Cause i tried to look for my motherboard info, and it said its unkown.
My System SpecsSystem Spec
09 Aug 2012   #8

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by perryy View Post
Is that what is it? Cause i tried to look for my motherboard info, and it said its unkown.
Hi perryy, I have already posted the link to where you can get your drivers from Drivers and Downloads | Dell [United States] every driver for your laptop is there you can also let Dells website search your laptop to find the correct drivers for your lappy , just enter the service tag # (usually on the underside of the laptop) and Dell will work it's magic for you
My System SpecsSystem Spec
09 Aug 2012   #9

Windows 7 Ultimate 64bit
 
 

THank you!
My System SpecsSystem Spec
09 Aug 2012   #10

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by perryy View Post
THank you!
You're very welcome perryy, If you still have any problems ,let us know and we will do our best to help
My System SpecsSystem Spec
Reply

 [HELP!] Missing Drivers After Clean Windows 7 Installation.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33