Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help! Windows cannot detect the networking hardware.


18 Sep 2012   #1
XQMR

Windows 7 Home Premium 64 bit
 
 
Help! Windows cannot detect the networking hardware.

I have a Windows 7 Home Premium 64 bit laptop. The processor is Pentium (R) Dual-Core CPU T4400@2.2ghz with 4GB RAM. Since a forced abortion occurred when the system was doing its regular updates about a week ago, the laptop cannot be connected with the internet anymore. The message given by the Diagnosis is "Windows cannot detect the networking hardware". Other than the internet connection problem, the computer works as normal. Do I need to install a network driver? and where can I get the suitable driver? Any quick response on this topic would be appreciated!!!


My System SpecsSystem Spec
.

18 Sep 2012   #2
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

May be here?

How to Install a Driver in Device Manager

(at bottom of the page, there's "related tutorials" to help you either)

you can use it also to uninstall the device and reboot to see if windows reinstall it.

May this help:
network adapter missing from device manager
My System SpecsSystem Spec
18 Sep 2012   #3
karlsnooks

MS Windows 7 Ultimate SP1 64-bit
 
 

if the excellent advice from NoN doesn't resolve your problem, then:
System Restore
My System SpecsSystem Spec
.


19 Sep 2012   #4
XQMR

Windows 7 Home Premium 64 bit
 
 

Thanks for the advice. I reinstalled the network drivers and was able to regain the internet connection. However, yellow triangular marks with exclamation are still showing on a number of items under Network Adapter. A snapshot of the screen is attached here. Can you let me know if this indicates any problem? How to fix them? Thanks again!


Attached Images
 
My System SpecsSystem Spec
19 Sep 2012   #5
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by XQMR View Post
Thanks for the advice. I reinstalled the network drivers and was able to regain the internet connection. However, yellow triangular marks with exclamation are still showing on a number of items under Network Adapter. A snapshot of the screen is attached here. Can you let me know if this indicates any problem? How to fix them? Thanks again!
What's about right click on each and try update the pilotes?

If it doesn't make anything, You can try a CHDSK
My System SpecsSystem Spec
Reply

 Help! Windows cannot detect the networking hardware.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App