Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Printing Support driver - cannot install Canon MP470


07 Oct 2012   #1

Win 7 Professional, SP 1, x64
 
 
USB Printing Support driver - cannot install Canon MP470

I am at my last moment here. Spent 2 days working on this and like 3 hours with Canon support. I know I should stop and either reinstall the OS or get a new printer BUT I can't I have to find a solution to this. Maybe with the help of all of you techies out there I will... (I should be looking for a job right now, since I just lost mine, anybody knows of a sys admin opening?)

OS: Windows 7 Prof x64
MoBO: ASUS P8Z68-V
Printer / scanner with the issue: Canon MP 470

I am unable to install the printer portion of the driver on my newly built PC.
The scanner portion works shows up in Devices and Printers not the printer.
I downloaded and installed successfully the drivers from Canon.
When i turn on the printer Windows tries to install it but its says "it failed'

Device Manger pick up and recognizes my printer > It puts it under "Other Devices" > "MP 470 Series" with an exclamation mark > I double click and get this under "General":
"The drivers for this device are not installed. (Code 28)
The system cannot find the file specified.
To find a driver for this device, click Update Driver."

When I try to do an update on the driver automatically I receive the error (attached it with a screenshot):
"Windows encountered a problem installing the driver software for your device.
Windows found driver software for your device but encountered an error while attempting to install it.
USB Printing Support
The system cannot find the file specified.
"

I have checked and tried so many different things in the last two days it would take too long to list them all.
To name just a few:
  • checked with manufacturer of MOBO and downloaded all and most current drivers,
  • checked and confirmed that "usbprint.inf", 'ntprint.inf" files are where they should be,
  • Windows updates are current,
  • completely uninstalled my Antivirus (AVG),
  • performed a clean boot with just the printer connected in the back of my PC,
  • created new admin user and logged in with it to install the printer,
  • copied and replaced the above inf files with "healthy versions from other same OS installation,
  • tried different cables,
  • different USB ports,
  • removed the printer driver all together each time i tried something new,
  • removed it from the "Print Server Properties", under Devices and Printers and then reinstalled the download diver from Canon,
  • manually pointed the installation to "C:\Windows\winsxs",
  • also to "C:\Windows\System32\DriverStore\FileRepository"

and probably more that I can't remember right this second.

Oh and one more thing: I also have a dual boot XP / Win 7 x64 Dell Laptop, and the driver I downloaded from Canon I installed and worked like a champ and the printer / scanner capabilities are available without a glitch.

So driver and printer are obviously OK.


PLEEEEEASE help me setup this printer on my PC ( I needed to print my resume and other things; of course I could go to FedEx with a flash drive ant print the resume, but I just wanted to make a bit more dramatic)...

Thank you all in advance,




Attached Images
 
My System SpecsSystem Spec
.

07 Oct 2012   #2

Windows 7 Home Pre
 
 

To be honest sounds like your printer is buggered,

Test it these ways, Try installing on another PC. Use a different USB port.

Or Try this.

UN INSTALL all printer software and Drivers, Run CCleaner and fix registry, restart computer, GOGO services and CHECK that Spooler is running. Turn on printer and plug into computer. WAIT.
My System SpecsSystem Spec
07 Oct 2012   #3

Win 7 Professional, SP 1, x64
 
 

Already tried that:
like i said it already works on my Win 7 laptop.
it still doesn't work on my PC even if using a diff. USB port
I did have all printer stuff removed, ran the cleaner, spooler working > still won't finish the install.


I forgot to mention that i also did this:
Start menu, devices and printers, and click add printer.
1. Chose " Add a local printer" > "use an existing port" > chose "virtual USB port".
2. Click windows update which found the Canon Inkjet MP470 driver printer driver > it installs it but when I try to print the Canon is one of my options of printers to select from and then i get a "printer not Responding" message ( I attached a screen shot)

It will show in Devices and Printers, and if I try to print a test page same error.
... same exclamation mark and missing drivers details in Device Manager.


Attached Images
 
My System SpecsSystem Spec
.


07 Oct 2012   #4

Windows 7 Home Pre
 
 

Are you getting the standard Drivers or 64bit drivers?
My System SpecsSystem Spec
07 Oct 2012   #5

Windows 7 Home Pre
 
 

USB000 ??? Should be 001 or some other number?
My System SpecsSystem Spec
07 Oct 2012   #6

Windows 7 Home Pre
 
 

Name:  Capture.JPG
Views: 17
Size:  55.7 KB

Goto your Printer and Get the Propertys Up, Change your USB000 too USB001


My System SpecsSystem Spec
07 Oct 2012   #7

Windows 7 Home Pre
 
 

If you want me too Have a look into this Via remote Assistance I will be able too, add me to your msn or skype

roger.cornwell skype
roger.cornwell@blueyonder.co.uk for MSN.

Dinner here so I be 40 mins.
My System SpecsSystem Spec
07 Oct 2012   #8

Win 7 Professional, SP 1, x64
 
 

- it's x64 bit drivers.
- it's USB000...
- i can't change to USB001 because it is not available on the list of ports
- about connecting, I am on my way out anyway, but suggestions are more then welcomed and maybe we can do the remote session at a later time.
My System SpecsSystem Spec
08 Oct 2012   #9

Windows 7 Home Pre
 
 

Just Buzz me and I shall have a look for you.
My System SpecsSystem Spec
19 Oct 2012   #10

Windows 7 Home Premium 64bit
 
 

Just copy "usbprint.sys " and "usbscan.sys" respectively to %SystemRoot%\Windows\inf and also in %SystemRoot%\Windows\System32\driver.
I fight one week to find it out this solution with the same PC Asus as yours trying to install drivers for a printer Canon MP495.
All is gone well after this manipulations as incredible it was?!?...
Good luck !
My System SpecsSystem Spec
Reply

 USB Printing Support driver - cannot install Canon MP470




Thread Tools



Similar help and support threads for2: USB Printing Support driver - cannot install Canon MP470
Thread Forum
Canon MP780 driver install Drivers
Solved Canon driver only install in English? Drivers
Win7 and Canon iR C3220 printing issues Hardware & Devices
Printing to Canon pro9500 attached to Mac SL Network & Sharing
Solved Canon network printing driver problem Drivers
Canon 3010 duplex printing? Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33