Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After installing clean windows 7 usb ports doesn't work


19 Oct 2012   #1

Windows 7 home premium 64 bit
 
 
After installing clean windows 7 usb ports doesn't work

My problem began when someday i had issue in my windows which was usb was not recognized as i tried putting 3 usbs but all of them didn't work and i have 2 usb ports in my laptop which is dell xps 15z so i don't think it is a hardware issue
My problem continued and i searched and searched the internet for solutions but no one really worked so i decided to format the windows and installing new clean windows 7 one, and i did so and after installation i had too many more problems knowing that i installed all the required drivers needed for the laptop and checked them with driver genius, now any usb i plug in isn't even sensed by the lap or self installed like the usb ports have no drivers or anything.
I tried the wireless mouse which isn't sensed on another laptop and it installed and worked instantly, so where is driver software installation which should install the mouse automatic?
and what can i do to recognize the problem? and is there anything i can install or do?
Knowing that the usb ports aren't physically defect because when i plug an old usb mouse i lights up but doesn't work cause of the mouse
please please help me i don't know what to do

My System SpecsSystem Spec
.

19 Oct 2012   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi onoffonxhizors, Welcome to the forums , Did you install the Renesas usb host controller ? If not download from here Drivers and Downloads | Dell [United States] also make sure you have the correct chipset drivers installed,
If you input your service tag# on to Dells website it will find the correct downloads for you
My System SpecsSystem Spec
19 Oct 2012   #3

Windows 7 home premium 64 bit
 
 
Thanks this helped me a bit

Quote   Quote: Originally Posted by pebbly View Post
Hi onoffonxhizors, Welcome to the forums , Did you install the Renesas usb host controller ? If not download from here Drivers and Downloads | Dell [United States] also make sure you have the correct chipset drivers installed,
If you input your service tag# on to Dells website it will find the correct downloads for you
Thanks pebbly this helped me a bit and now after installing usb host controller it automaticly installs the driver as it didn't before,but now i ended as i began as whenever i enter any usb for mouse storage or anything it says that it didn't install correctly or sth and when i uninstall the driver and unplug it again it says that the usb wasn't recognized, i tried resetting the bios,uninstalling the driver and restarting the laptop but nothing worked, the only thing i didn't tried is removing the battery because in my model it isn't easy to remove it, i know that i will find the solution here because i searched the whole internet for the previous problem and found it here.
Please help me i can't believe that i formatted windows that came with my lap and discarded office 2010 and roxio that came with my computer to solve this problem and it didn't solve
My System SpecsSystem Spec
.


Reply

 After installing clean windows 7 usb ports doesn't work




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33