Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After installing clean windows 7 usb ports doesn't work

19 Oct 2012   #1
onoffonxhizors

Windows 7 home premium 64 bit
 
 
After installing clean windows 7 usb ports doesn't work

My problem began when someday i had issue in my windows which was usb was not recognized as i tried putting 3 usbs but all of them didn't work and i have 2 usb ports in my laptop which is dell xps 15z so i don't think it is a hardware issue
My problem continued and i searched and searched the internet for solutions but no one really worked so i decided to format the windows and installing new clean windows 7 one, and i did so and after installation i had too many more problems knowing that i installed all the required drivers needed for the laptop and checked them with driver genius, now any usb i plug in isn't even sensed by the lap or self installed like the usb ports have no drivers or anything.
I tried the wireless mouse which isn't sensed on another laptop and it installed and worked instantly, so where is driver software installation which should install the mouse automatic?
and what can i do to recognize the problem? and is there anything i can install or do?
Knowing that the usb ports aren't physically defect because when i plug an old usb mouse i lights up but doesn't work cause of the mouse
please please help me i don't know what to do


My System SpecsSystem Spec
.
19 Oct 2012   #2
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi onoffonxhizors, Welcome to the forums , Did you install the Renesas usb host controller ? If not download from here Drivers and Downloads | Dell [United States] also make sure you have the correct chipset drivers installed,
If you input your service tag# on to Dells website it will find the correct downloads for you
My System SpecsSystem Spec
19 Oct 2012   #3
onoffonxhizors

Windows 7 home premium 64 bit
 
 
Thanks this helped me a bit

Quote   Quote: Originally Posted by pebbly View Post
Hi onoffonxhizors, Welcome to the forums , Did you install the Renesas usb host controller ? If not download from here Drivers and Downloads | Dell [United States] also make sure you have the correct chipset drivers installed,
If you input your service tag# on to Dells website it will find the correct downloads for you
Thanks pebbly this helped me a bit and now after installing usb host controller it automaticly installs the driver as it didn't before,but now i ended as i began as whenever i enter any usb for mouse storage or anything it says that it didn't install correctly or sth and when i uninstall the driver and unplug it again it says that the usb wasn't recognized, i tried resetting the bios,uninstalling the driver and restarting the laptop but nothing worked, the only thing i didn't tried is removing the battery because in my model it isn't easy to remove it, i know that i will find the solution here because i searched the whole internet for the previous problem and found it here.
Please help me i can't believe that i formatted windows that came with my lap and discarded office 2010 and roxio that came with my computer to solve this problem and it didn't solve
My System SpecsSystem Spec
.

Reply

 After installing clean windows 7 usb ports doesn't work




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Keyboard for some reason doesn't work in rear ports.
My microsoft 600 usb mouse and keyboard suddenly do not work properly anymore. Whenever I plug them into the rear ports they disconnect and freeze(computer remains running). It sometimes requires a reboot for it to work again. This is really weird and frustrating as I can run my other devices out...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
Drivers
after clean install my pcs ethernet ports and wireless card wont work
i did a clean install on my pc useing my windows 7 retail disk and now i cant connect to the internet useing my laptops ethernet ports or the built in network card i just bought the pc yesterday and now the ethernet ports are not functioning neither is the wirelesscard before i did the clean...
Hardware & Devices
Installing icon pack doesn't work, please help???
Hi, I have restore my default icons, and now I have downloaded a icon pack from cretivX and it doesn't change my icons please help me.???
Customization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App