Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB3 not working on Gigabyte X79-UP4

10 Dec 2012   #1

Windows 7 (XP, by Virtualization)
 
 
USB3 not working on Gigabyte X79-UP4

Hi Everyone,

I have a nice new Gigabyte X79-UP4 motherboard, and it is behaving for the most part, however the USB3 ports are not working.

Drivers for the port installed fine (from the disk that came with the motherboard) however it is not recognizing either USB3 or USB2 peripherals.

Device Manager reports that the USB3 ports are fine -





I did download the newest Fresco Logic drivers from Gigabyte and the package failed on install with the message below -



Even though the installer failed I was able to go through Device Manager & update the drivers, but unfortunately there has been no improvement in functionality - USB3 and USB2 still do not work.

I have tried several installer packages, from different locations, and all have failed!

Any help will be greatly appreciated.

Kind Regards,

Davo


My System SpecsSystem Spec
.

11 Dec 2012   #2

Windows 7 (XP, by Virtualization)
 
 
More information about this fault condition...

Hi Everyone,

I have performed further testing and was surprised to find that my smartphone charges whilst connected to a USB3 port, both when the computer is turned on and when it is turned off. I thought that the Gigabyte On / Off Charge feature might be at fault so I uninstalled the driver related to this feature -



After uninstalling the driver my computer is still unable to register that a USB peripheral is connected to any of the USB3 ports.

Any help will be greatly appreciated.

Kind Regards,

Davo
My System SpecsSystem Spec
Reply

 USB3 not working on Gigabyte X79-UP4




Thread Tools



Similar help and support threads for2: USB3 not working on Gigabyte X79-UP4
Thread Forum
Solved ASUS M4A89GTD Pro/USB3: USB3 driver issues Drivers
USB3 2.5" not working on USB2 Hardware & Devices
USB3.0 Issue Hardware & Devices
USB 3.0 ports not working on Gigabyte GA-A75M-UD2H motherboard Hardware & Devices
USB2.0 HD Transfer over Gigabyte Network to Gigabyte NAS Network & Sharing
Gigabyte RAID not working. Hardware & Devices
Gigabyte ga-z68ma-d2h-b3 audio jacks not working. Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33