Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB problems

22 Jan 2009   #1

USB problems

I'm having some USB problems and hope someone can help. Initially due to some other issues I couldn't get Vistax64 to install so decided to see if my copy of Win7 would work.

After I updated the firmware for a seagate drive it installed just fine and I had bot front and back USB ports working.

Stupid me not leaving well enough alone I then decide hey I should install Vista x64 on a seperat partition whinch installed fine then it downloaded a bunch of updates and viola I lost most of my USB ports in both Vista and in my Win7 install. I really don't know what happened.

Anyway figured okay if I'm going to lose the ports lets just reformat and just install Win& 64 since it worked right. Did a fresh install and first deleted all the old partitions that had Win7 and Vista on then and reinstalled. Unfortunatly tho my USB ports didnt come back on the reinstall.

Does anyone have some suggestions as to what I could try. My last ditch effort is going to reset the MB bios to system default and then turn the box off for the night and see what happens in the AM but if someone has a better idea I'd appreciate it

My System SpecsSystem Spec
23 Jan 2009   #2

Windows 7 RC 7100 32bit/64bit

Chipset, chipset, chipset...

Download the latest chipset drivers for your motherboard.
If Windows Update didn't find any chipset drivers, download from your motherboard manufacturer's page the ones for Vista .

Also , check in BIOS settings for enabling USB ports , USB Legacy support and any other USB-enable stuff.
My System SpecsSystem Spec
23 Jan 2009   #3


well now I'm confused. Seems that maybe the front ports were okay. I only was trying to use one of my thumb drives and finally after being fustraited just switched back to my old computer for now. Anyway when I did I discoverd that apparently that particular drive seems to be dead and I can't recall if I ried any other items in the front USB ports so maybe the ports were okay. I was still having issues with my USB printer tho so decided best to just give myself some breathing room for a few days.
My System SpecsSystem Spec


 USB problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Many problems with video errors and somehow RAM problems
Okay so for a while now i have been having many problems. First off i had a PC with the video card i am using right now(Nvidia GTX 295), and it has been "losing signal" and just plain old crashing. So i bought a PC off my uncle. Its got reletivly good hardware, but i am still getting the same...
General Discussion
USB Problems, Errors and port problems!
I have a Dell Inspiron 1545 laptop, not to long ago I had to replace my hard drive. After that I reinstalled windows 7. Before this the usb devices would charge just not be recognized. Now only ONE port does everything (charge, sync, etc.) the other two just stopped working. I have no clue if its a...
Hardware & Devices
Can't start up my computer. (Driver problems, BSOD, other problems)
Hi I hope I'm placing this in the right section, if not, then could someone tell me where to put it and I'll post it again. I've got a Samsung RV510 laptop with Windows 7 HP 64 bit. About 2 weeks ago, I was watching a Youtube video, had Spotify and Facebook open too, and my computer...
BSOD Help and Support
extract problems, random BSOD errors all those problems
hi guys i dunno why i have many problems with win7 since installation and so far btw i wrote many topics before about my installation and eventually i didn't found any solution so i took my pc to computer shop and they solve the problem after that i installed win7 without any problems...
BSOD Help and Support
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance
Problems leading to problems...
Hello, I am new to the forum, and I am hoping someone can help me out. I am attempting to install Win 7RC 64 bit on my system and seem to run into another problem as soon as I solve one. I am now at a problem that has me at a loss. Bear with me as I outline what I have done so far. I had...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:00.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App