Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Old Laptop, Windows 7 x64, ATI Mobility X1400 driver problems

06 Feb 2013   #11
Broadtstar86

Windows 7 Ultimate x64
 
 

Thank you Mr Phelps! Thank you very much, its been doing my nut in for weeks! All is working and i have aero and my preferred 1920x1200 resolution, good times!


My System SpecsSystem Spec
.
07 Feb 2013   #12
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Quote   Quote: Originally Posted by Broadtstar86 View Post
Thank you Mr Phelps! Thank you very much, its been doing my nut in for weeks! All is working and i have aero and my preferred 1920x1200 resolution, good times!
Glad I could be of help. If it's not to much trouble, please click on the little "scales" symbol on the upper-right part of your post to add to my reps, thanks.
My System SpecsSystem Spec
08 Feb 2013   #13
Broadtstar86

Windows 7 Ultimate x64
 
 

Dont that no problem, thanks again.
My System SpecsSystem Spec
.

09 Sep 2013   #14
Maco88

Windows 7 Home Premium 64bit
 
 

Hi

I am in the exact position as the OP and thanks to Mark Phelps for his post. I managed to download that driver, but there is no executable file to install the driver. It comes with a bunch of file but none of them do anything.

Where exactly do I put these files or what do I do with them, sorry I am not 100%

Cheers
My System SpecsSystem Spec
10 Sep 2013   #15
Mr Davo

Windows 7 (XP, by Virtualization)
 
 
How to manually install drivers in Windows (through Device Manager)

Hi Maco88,

Check out the YouTube link below which explains how to manually install driver files in Windows -

How to install Windows Drivers Manually

Kind Regards,

Davo
My System SpecsSystem Spec
10 Sep 2013   #16
Maco88

Windows 7 Home Premium 64bit
 
 

cheers Davo, havent checked out that youtube yet, but I will just for reference..

Via a bit of Googling i was able to get a bit of a lead and tried a few things which eventually work.

Basically, had to expand the "CAB" file to a destination of my choice.

Then went into Device Manager, and updated my Graphics Driver and selected "Let me choose the software" option by directing it to the folder that held the expanded files.

The system did the rest and the driver was updated.

After a reboot, i was able to get the maximum 1920 x 1200 resolution, previously only able to get Windows 7 default settings max. 1600 x 1200.

Easy when you know how, as this is how we use to do update and adding drivers in days gone by, however these days everything virtually comes with an executable that does it all for you, and when you are faced with having to do it manually, you seem to momentarily forget how it was done.
My System SpecsSystem Spec
11 Sep 2013   #17
Mr Davo

Windows 7 (XP, by Virtualization)
 
 

Glad to hear that it worked out for you
My System SpecsSystem Spec
05 Apr 2014   #18
Haloman

Windows 7 Ultimate x64
 
 
64 bit

Hello guys, I have the same problem but this cabinet didn't work for me because it's for win 32 bit. Found some of them for 64 bit but won't work saying "can't find specified file". Any help wold be welcomed.
My System SpecsSystem Spec
05 Apr 2014   #19
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Quote   Quote: Originally Posted by Haloman View Post
Any help wold be welcomed.
I saw two Win7 drivers in Microsoft Update Catalog. If neither of them work, you should try the AMD driver website: Download Drivers
My System SpecsSystem Spec
23 Feb 2016   #20
sirnose

Ontario
 
 
Thank You

Quote   Quote: Originally Posted by Mark Phelps View Post
If you add Microsoft Update Catalog to your favorites and install the app, then do a search on "ATI X1400 driver".
Part way down the list of results, you will see driver version 7.14.10.8333. THAT is the version that the other thread said is the one that works.
Download and install that version (there are two entries, but I don't know which one you need).
This was really helpful one tip you need to use IE to use this site Microsoft Update Catalog
My System SpecsSystem Spec
Reply

 Old Laptop, Windows 7 x64, ATI Mobility X1400 driver problems




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 not detecting radeon mobility x1400
I just finished installing Windows 7 ultimate, 32x to a separate partition of my hard drive. When using Windows XP, I have a 1440x900 resolution, and windows says that my graphics adaptor is an ATI radeon mobility x1400. However, when I boot into Windows 7, I have a much smaller resolution, no...
Graphic Cards
ATi Mobility x1400 Build 7100 x64
I've tried installing the OS two times, both times my video card has not been recognized. It was properly recognized in the following builds: 7000, 7048, 7057, 7068, 7077. I've tried using ATi Catalyst and also used the following process suggested on techPowerUp! Forums - Powered by vBulletin with...
Drivers
ATI Mobility X1400 on Windows 7 64-bit
Hey all, first post here. I just updated to Windows 7 X64. I'm having trouble finding the right drivers for my video card. The computer is a Dell e1505, and Dell doesn't officially support Windows 7. And by the looks of it, neither goes ATI, for this particular model at least. I'd appreciate any...
Drivers
ATI Mobility Radeon x1400
So right now when I'm playing this game there are these weird black shadows that are like a fan appearing from the character. I'm wondering if I need a new update to my ATI Mobility Radeon X1400 for my Inspiron E1505 laptop by dell. If I do where would I find such an update I looked on the site but...
Gaming
ATI® Mobility Radeon™ X1400 Driver
does any1 have the latest driver for mobility radeon X1400? i cant find it anywhere yet. (d) post here it here, including the Catalyst Control Center! thanks very much. :thumbsup:
Drivers
X1400 (Laptop ATI card) problems
Every time I shut my laptop the screen stays on and then when I open it back up, it's stuck to dim. I haven't really been bothered by this until the last few days and it's time I figured out a solution other than never shutting my laptop when it's on.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App