Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ASUS HD5450 only works in PCIe 2.0 x1 slot, or driver install timeout

21 Feb 2013   #11
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Is this the first time you tried to use the pci express slot.

Now this is your board, correct ?

http://www.asus.com/Motherboard/P8H67M_PRO/

I have no idea why the card isn`t working in the blue slot.


My System SpecsSystem Spec
.
21 Feb 2013   #12
PianoGuy

Windows 7 Professional 64bit
 
 

Correct.
My System SpecsSystem Spec
21 Feb 2013   #13
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

As you stated, 1 slot is a x16 and 1 is a x4 according to theses specs.

ASUS P8H67-M PRO/CSM Micro ATX Intel Motherboard - Newegg.com

I don`t know, I would contact Asus.

http://www.asus.com/Graphics_Cards/E...ENTDI512MD3LP/

Also, the mb you have listed in your specs is different, unless we are working on another machine.
My System SpecsSystem Spec
.

21 Feb 2013   #14
PianoGuy

Windows 7 Professional 64bit
 
 

I solved it. This was the solution: how to properly uninstall ATI/AMD Software Drivers for Graphics Cards.

I then installed the latest driver, via Device Manager >> "Browse my computer for driver software" >> "Search for driver software in this location".
My System SpecsSystem Spec
22 Feb 2013   #15
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by PianoGuy View Post
The board has:
1 x PCIe 2.0 x16 (blue)
1 x PCIe 2.0 x16 (x4 mode, black)

The blue slot is closest to the CPU and is the one that does not work.
Clearly, the HD5450 is supposed to be installed in the PCIe 2.0 x16 slot and run in x16 mode. I've installed three HD5450's that way in three separate machines, and they all work fine.

I also have an ASUS P8Z77-V Pro board, which has THREE PCIe 2.0 x16 slots total. Two are x16 (but x8/x8 if both are used for video cards), and one is x16 but compatible with x1/x4 devices. However there is lots of complexity about bandwidth for two of the three x16 slots being shared with x1 slots and USB 3.0 ports, and lots of setup configuration options in the BIOS for how all of these slots will perform depending on what types of devices you have in which slots.

In other words you can't just put any PCIe x16 video card in any of these these PCIe x16 slots. As to whether the drivers would even install or not, I can't say.

But... for sure, your blue PCIe x16 slot is definitely where you HD5450 video card should go, not in the black x4 one.

And any partially successful (or started but failed) video driver installs should probably be "wiped clean" before trying again. Sound like from your latest post you've finally gotten things worked out. And I always get my ATI/AMD drivers for ATI/AMD video cards (including my HD5770 and HD6450 in other machines) from their web site, not from ASUS.

My own approach for removing/cleaning drivers is to use what used to be called "Driver Sweeper", now named "Driver Fusion". ATI/AMD says just install new updated drivers over old currently installed drivers and that should work, but more often than not it does not work for me. I then just use Driver Fusion to clean out the old ATI/AMD software (including Catalyst Control Center, Install Manager, etc.) completely, re-boot, and then run the new updated ATI/AMD driver installer.


As far as your Windows Experience Index 3.9 with the HD5450, that's "normal" for that card. It is NOT a high-performance card, although it does have 512MB or 1GB of memory and is part of the HD5xxx family of ATI/AMD products. So it performs perfectly fine for non-gaming applications and Win7 and HDTV viewing via WMC, etc., and that 3.9 allows Win7 Aero desktop. The newer HD6450 is somewhat better, but not much.

Don't know what onboard graphics chip is in your mobo that provides WEI of 6.5, but it probably doesn't have much/any dedicated memory. It may take memory from your PC's to support itself. That's why the external video card with 1GB of its own memory supports higher resolutions for your monitor. As long as you're not a gamer the HD5450 should be perfect (as it is for my own machines on which I've installed it for the same reason). The HD5450 is a low-priced video card that uses very little power, making it great for machines that don't need much more (e.g. HTPC).
My System SpecsSystem Spec
22 Feb 2013   #16
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

PanoGuy: Did not this Asus motherboard come with a manual? Mind did and it gives the exact locations required for the video card and or cards if using more than one.
My System SpecsSystem Spec
Reply

 ASUS HD5450 only works in PCIe 2.0 x1 slot, or driver install timeout




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Extra Pcie slot
does my laptop have extra pci e slot that is free my laptop hp pavilion g6 1242se
Hardware & Devices
USB 3.0 PCIe card in x16 slot?
Hello all, I searched but did not find any threads on a USB 3.0 card. So if I missed one just hit me over the head okay. Now for the question, I see lots of back panel USB 3.0 cards for PCIe slots. But can you plug that card into a PCI-Ex16 slot AND have it work? Or will they only work...
Hardware & Devices
what will decrease if a pcie 2.0 gpu is placed in a 1.0a slot
i know their backwards compatible. but what will decrease in its performance memory bandwith?, clock speed?, memory speed?, shader cores? i have a palit geforce 210 pcie 2.0 TO BE placed in a 1.0a pcie slot mobo
Graphic Cards
Install GTX780 in Other PCIE Slot, Card not found??
HI, I'm having problems after moving my GC to a higher slot on my Asus z87 sabertooth motherboard You might know the card is quite big ,when i built it i installed it in the slot which was just above the PSU. So, to give the fans more breathing space i move it. now when it boots theres no card...
Graphic Cards
pcie 2.0 video card on pcie 1.1 slot
I am planning to upgrade my video card. I saw this one from Nvidia. Geforce GTS 450. I checked the specs and i saw the "bus" and it says PCI-E 2.0 x 16. My motherboard(Asus P5G41T-MLX3) has PCIe x16. I also have researched that the PCIE is backward compatible meaning the GTS 450 is compatible with...
Graphic Cards
pcie 2.1 gpu in 1.0 slot?
well, i got Asus M4N68T M LE V2 mobo and i THINK it has pcie 1.x(tried asus site dowsnt tell which pcie it is) and im building my rig atm with this mobo came with joblot(phenom II x2 550). so what it is, is that i want to buy good gpu for it and i wanted to buy a sapphire radeon HD 5830 extreme...
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App