Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Have i5 but device manager is displaying a Xeon in system devices?

12 Mar 2013   #1

Windows 7 Home Premium x64 OEM
 
 
Have i5 but device manager is displaying a Xeon in system devices?

I have just installed my new Intel i5 3570K, and everything was running great until I reformatted my hard drive. When I first booted up I turned off the option to auto download drivers because I wanted to instal my INF before my GPU auto installed. Worked fine until I restarted and then the windows update was saying that it had successfully installed some drivers along with the Xeon Processor
I've also noticed that my WEI went from a 7.6 to a 6.9 for the CPU score, if that means anything. Sorry if this is very vague and doesn't make much sense; I am very tired. Any help with deleting and re-installing the right drivers would be greatly appreciated. Thank you.

MOBO is a ASRock h77M

EDIT: Just talked to a friend the driver is correct, but that doesn't explain my poor performance in games, and my WEI going from the 7.6 to an 6.9. performance in games is significantly lower than before I reformatted.

My System SpecsSystem Spec
12 Mar 2013   #2

Windows 7 Home Premium x64
 
 

Xeon processers are basically the same as the i5 and i7 except they support ECC memory. Xeon = server, i5 = Desktop/Laptop. Xeon's have many threads as opposed to i5's core speed.How that relates to your problem I don't know unfortunately.
My System SpecsSystem Spec
12 Mar 2013   #3

Windows 7 Home Premium x64 OEM
 
 

Could I safely just uninstall the drivers from device manager and then reinstall the INF?
EDIT: I have updated the BIOS and I will see if that fixes the problem. Will also run a CHKDSK.
My System SpecsSystem Spec
.


Reply

 Have i5 but device manager is displaying a Xeon in system devices?





Thread Tools



Similar help and support threads for2: Have i5 but device manager is displaying a Xeon in system devices?
Thread Forum
Unknown Device in Device Manager/Show Hidden Devices Drivers
Solved Device manager suddenly scanning for new devices constantly General Discussion
Device Manager - Finding Unknown Devices Tutorials
Disconnected devices in Device Manager Hardware & Devices
Device Manager : Hidden Devices Tutorials
No devices in device manager. Hardware & Devices
Device Manager - smart devices Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:43 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33