Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need drivers for recent install of Win7 SP1.

23 Mar 2013   #1

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1
 
 
Need drivers for recent install of Win7 SP1.

I just did a clean install of windows 7, 32bit on my Acer aspire 5336-2524. I was surprised to find it couldn't connect to the internet via cable modem nor Wi-Fi! I can access the web from my vista desktop to down load drivers. what drivers will i need and where can i find them?

My System SpecsSystem Spec
.

23 Mar 2013   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi mawil1013, Go here for the drivers Acer | Download you need the lan drivers and the wireless lan drivers
My System SpecsSystem Spec
23 Mar 2013   #3

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by pebbly View Post
Hi mawil1013, Go here for the drivers Acer | Download you need the lan drivers and the wireless lan drivers
that looks promising, a second question to anyone, I have recovery disks from the original install, I assume that every thing I would need is contained on those four disks, but when I insert the DVD in they can't be found. is it that the driver for the DVD must be installed? I has similar issue when I did my clean install andc was forced to make a bootable usb because it wouldn't work with the DVD!

update 1: got ethernet going! have to go back for wireless driver next.
update 2: got wireless going!

all seems well, I'm holding off on doing more Acer drivers unless I run across a problem.
My System SpecsSystem Spec
.


23 Mar 2013   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi mawil1013, you may need to download and install the chipset drivers and the sata AHCI drivers , These should get the CD/DVD drive working correctly, If possible check in the bios that the drive has'nt been disabled ,
My System SpecsSystem Spec
24 Mar 2013   #5

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by pebbly View Post
Hi mawil1013, you may need to download and install the chipset drivers and the sata AHCI drivers , These should get the CD/DVD drive working correctly, If possible check in the bios that the drive has'nt been disabled ,
I'm guessing that because I'm able to view files that are on DVDs and move files on and off the DVD/CD drive works. It may be a bad set of recovery disks? Anyway, I prefer the Clean Install scenario and not have anything extra on the laptop. So I'll put those aside.

Thank you!
My System SpecsSystem Spec
24 Mar 2013   #6

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Glad you got sorted out mawil1013, Enjoy your stay on the forums
My System SpecsSystem Spec
Reply

 Need drivers for recent install of Win7 SP1.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33