Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: C-Media AC97 Audio Device. This device cannot start.


19 Oct 2009   #11

Windows 7
 
 

For those interested, it was impossible for my AC97 Realtek card to work with Windows 7 even after driver updates. I had to go out and spend hard earned money on a sound card and only now will my pc work with Windows 7...not very convenient I think for all those future users who might be thinking about using Windows 7.
I would personally be very disappointed if Windows 7 turned into a Windows Vista disaster, as the graphics and user friendliness seems good so far, but these dirty tricks to force people to spend money on hardware is a big thumbs down for me.


My System SpecsSystem Spec
.

20 Oct 2009   #12

64-Bit W7 Ult_sp1
 
 

- the installed card should make your PC run more efficiently
- which soundcard did you buy, eiger..?
My System SpecsSystem Spec
21 Oct 2009   #13

Windows 7
 
 

Creatvie Soundblaster 5.1.
My System SpecsSystem Spec
.


26 Oct 2009   #14

Windows 7 & OS X Snow Leopard
 
 

Quote   Quote: Originally Posted by eiger3970 View Post
For those interested, it was impossible for my AC97 Realtek card to work with Windows 7 even after driver updates
I had exactly the same problem as you - have the C-Media AC97 High Definition Audio Device and installed Windows 7. Everything went fine except no sound - tried installing latest update via Windows Update and various sources on the web. Tried everything. Mustv'e spent nearly 8 hours fiddling with drivers and reading forums and was beginning to give up when I found the solution.

Downloaded these WinXP drivers from Medion's website - http://download1.medion.de/downloads...mazawin9xp.exe
Ran the installation in XP Compatibility mode and boomshanka - got sound back!!

I know it's a bit late to help you but hopefully it might help someone else with the same problem!
My System SpecsSystem Spec
29 Oct 2009   #15

win 7
 
 
C-Media AC97 on Win 7

C-Media AC97 built-in on Chaintech Mobo

Struggled with various drivers from the various suspicious sites pushing adware

Solved the problem with the driver from the link posted by Peter Board

Thanks!
My System SpecsSystem Spec
05 Nov 2009   #16

Windows 7 Ultimate
 
 

My C-Media card works perfectly under Windows 7.

All I had to do is download the XP drivers from the motherboard manufacturer's website, and run setup in compatibility mode for Windows XP. It worked like a charm.
My System SpecsSystem Spec
21 Nov 2009   #17

Windows 7
 
 

I have tried the download link and the C-Media download for Windows 7. Still fails. When the zip file is opened and the Setup.exe file run, the error comes:
Cannot Install: SETUP or INSTALL program filename contains folder information. Use Actions/CheckOut instead.

This is the second Windows 7 I'm installing now, and the exact same problem with sound!
AC97 or the Creative sound blaster will not work.
My System SpecsSystem Spec
21 Nov 2009   #18

Windows 7
 
 

Well, I figured out the 'Use Actions/CheckOut' is an option in WinZip. Ran those commands and it did open up the C-Media setup.exe. Now the problem is that the setup.exe file gives error:
Please plug-in C-Media PCI Audio Device device! Ha, haaa..it is plugged in. How the hell does Windows 7 mess this up so good???
My System SpecsSystem Spec
21 Dec 2009   #19

Windows 7
 
 

The post by member Peter Board worked for me!
http URL - fichiers.touslesdrivers.com/c-media/UDA051_build01_Logo51.3_Standard_.rar
http://fichiers.touslesdrivers.com/c..._Standard_.rar

Thanks
My System SpecsSystem Spec
15 Mar 2010   #20

Wimdows 7 Ultimate
 
 
hi.I´m new here

También tengo el problema de sonido, antes de que yo tenía XP, pero ahora con Win 7 ya no se oye nada. De instalar el controlador 5.12.01.0051 y no ayuda. Por favor, ayúdame. Tengo 3 meses, de modo.
My System SpecsSystem Spec
Reply

 C-Media AC97 Audio Device. This device cannot start.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33