Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB drivers keep going bad a minute after restart

07 Apr 2013   #1
prerunner97

windows 7 32 bit
 
 
USB drivers keep going bad a minute after restart

Ok peeps, here"s the rundown. None of my USB devices work. Keyboard does work in BIOS and i found a mouse with a PS2 plug so that works in windows. I have to use the on screen keyboard to type. I noticed that under USB Root Hubs in the device manager all have the yellow caution sign. I tried to update , but windows says driver is up to date. So i uninstall all the USB Root Hub drivers and restart the computer. The keyboard works fine for about a minute or two after windows starts, but after windows finishes installing the usb drivers, key keyboard doesn"t work anymore. Any suggestions?


My System SpecsSystem Spec
.

07 Apr 2013   #2
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Hum strange mate as I have a card reader that has the yellow symbols yet still work though I suppose they do come off a board header. Just where are you downloading the drivers from I like to go to the manufacturers site ie the board and it's driver list rather than just do the Windows thing.

Pity you didn't have the pS/2 KB mate as mine have got me out of many a fix.

So some specs eh? and oh and welcome!!

Forgot what is the keyboard brand they usually have their own software too.
My System SpecsSystem Spec
07 Apr 2013   #3
prerunner97

windows 7 32 bit
 
 

I've tried from the windows update and from the asus website as well. I'm running windows 7 32bit. Any other suggestions out there?
My System SpecsSystem Spec
.


07 Apr 2013   #4
ICIT2LOL

Desk1 8 Pro / Desk2 7 Home Prem / Main lap Asus ROG 7 Pro
 
 

Yep what board is it first up my friend some specs are handy prerunner and what do you see in the BIOS for the ports?

Speccy - Download
My System SpecsSystem Spec
07 Apr 2013   #5
prerunner97

windows 7 32 bit
 
 

All USB ports are turned on and enabled. Motherboard is a Asus M4A785TD-M EVO. I think its a software issue because if I delete all USB root hub drivers, USB keyboard works for a minute until windows installs the drivers the it doesn't work any more
My System SpecsSystem Spec
07 Apr 2013   #6
TheCyberMan

Windows 7 Ultimate x64
 
 

Download the latest chipset drivers from the motherboard manufacturers site link below see if the issue clears up.

ASUS - M4A785TD-M EVO
My System SpecsSystem Spec
07 Apr 2013   #7
prerunner97

windows 7 32 bit
 
 

This may sound like a stupid question, but how do i install the beta version? I have the asus update software, but I cant update the beta update ?
My System SpecsSystem Spec
07 Apr 2013   #8
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Hello prerunner97.
In post #2 by ICit2lol

Forgot what is the keyboard brand they usually have their own software too.

We will need that information for sure.
------------
We also need your system specs filled in completely so we know what we are trying to help you fix.
My System SpecsSystem Spec
07 Apr 2013   #9
prerunner97

windows 7 32 bit
 
 

keyboard brand is xgene. its a cheap one, but it used to work and it works on my laptop. p/n 01021
My System SpecsSystem Spec
07 Apr 2013   #10
prerunner97

windows 7 32 bit
 
 

I updated my system specs as much as possible too on my profile
My System SpecsSystem Spec
Reply

 USB drivers keep going bad a minute after restart




Thread Tools





Similar help and support threads
Thread Forum
Uninstalled ATI drivers + Used Driver Sweeper = no USB on Restart
So I've been messing around with varrious driversdrivers to try and get the game "RAGE" working. Which is an exercise in futility but to make this tumultuous process more agravating I've somehow inadvertently uninstalled my USB drivers drivers as well. This wouldn't be an issue, except that...
Drivers
Drivers only detected after restart
My account system specs are up to date, so please look there if you require that information. For a year or two now, some of the devices I use, like my webcam (HUE HD webcam), will only work if my computer has been restarted. This does not effect any mouse or keyboard, however, only some...
Drivers
Restart / Reinstall drivers?
Hello. I just installed windows 7 the other day. When I restart my computer the sound won't work unless I reinstall my audio drivers, but when I restart next I will have to reinstall again. It's not that it doesn't have a driver at all, device manager shows that one is installed, it just doesnt...
Sound & Audio
Restart from Safe Mode and computer dies in a minute
my computer will stay on for days, in safe mode. restart it dies in about a minute. whether or not i do anything. this problem has been intermittent, then went away for a few days after a adware scan (?) no idea why. now it is back. can't do anything. this computer was basically new at...
BSOD Help and Support
critical error 1 minute pc will restart due to network prob!
first off I appreciate sevenforums allowing me to post here..please excuse any typos b/c of my pc problem Im forced to type from my ppc. Whenever I boot up in normal mode or safe with networking I get an error that says windows critical error. your computer will restart in 1 minute. I know its...
BSOD Help and Support
Sound blaster drivers after restart
This is my orginal problem: my soundcard is the SB audigy 2. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. It seems in windows 7 to only produce sound at the 40%-60% levels compared to XP. i know this for a fact since i've done testing. So people...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App