Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB ports have power, but send no data

31 Jul 2013   #1

Windows 7
 
 
USB ports have power, but send no data

Hi, I recently installed a fresh copy of windows 7 onto my new laptop and ran through the usual routine, the first thing I did of course was plug in my mouse as I can't stand to use a track pad. It works fine and dandy but after I instal my drivers using driver pack solution, which has worked for my desktop, the USB ports cease to transmit data. The optical mouse still glows a bright red so I know that it at least supplying power. After trying all the ports with a mouse and then a USB drive, which was working in the same computer earlier, I have concluded that no data is being transmitted through them. To my surprise the bios correctly detects my USB drive and identifies it with it's product name "SanDisk Cruzer Edge".. Now that the problem has been narrowed down to the software, I assume it has something to do with the drivers. What can I do now? Laptop is an Acer Aspire V3-772g, sorry for now posting specs, for I am on mobile right now.


Many thanks,


Moonrobin

My System SpecsSystem Spec
.

31 Jul 2013   #2
Microsoft MVP

Windows 8.1 Pro with Media Center 64 bit
 
 

Download and install the proper driver for your model laptop from the Acer site.
My System SpecsSystem Spec
31 Jul 2013   #3

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by moonrobin View Post
Hi, I recently installed a fresh copy of windows 7 onto my new laptop and ran through the usual routine, the first thing I did of course was plug in my mouse as I can't stand to use a track pad. It works fine and dandy but after I instal my drivers using driver pack solution, which has worked for my desktop, the USB ports cease to transmit data. The optical mouse still glows a bright red so I know that it at least supplying power. After trying all the ports with a mouse and then a USB drive, which was working in the same computer earlier, I have concluded that no data is being transmitted through them. To my surprise the bios correctly detects my USB drive and identifies it with it's product name "SanDisk Cruzer Edge".. Now that the problem has been narrowed down to the software, I assume it has something to do with the drivers. What can I do now? Laptop is an Acer Aspire V3-722g, sorry for now posting specs, for I am on mobile right now.


Many thanks,


Moonrobin
Hi moonrobin,

You need to update all the drivers for your system. You can find the drivers at your manufacturer website by selecting your model number.

If you are unable to find the correct drivers then let us know the make and model number.

Please update your system specs here and if need help in finding then follow this.

Keep us posted with the results so we can advise you further.
My System SpecsSystem Spec
.


31 Jul 2013   #4

Windows 7
 
 

Which driver is the USB driver?
My System SpecsSystem Spec
31 Jul 2013   #5
Microsoft MVP

Windows 8.1 Pro with Media Center 64 bit
 
 

It's likely part of the chip-set drivers. I'd install them anyway as they are the foundation of your system.

EDIT: The USB drivers should be part of the Windows default drivers that are installed when Windows is installed. You broke something when you used your driver program so starting over and installing the manufacturers drivers should fix it. Another option might be to try using system restore and go back to before you used that driver program.
My System SpecsSystem Spec
01 Aug 2013   #6

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by moonrobin View Post
Which driver is the USB driver?
Hi moonrobin,


Its rightly suggested by "alphanumeric" you need to install chipset driver for your system. Please check the link below for downloading drivers for your system:

Acer | Driver Download

You may have provided the incorrect model as I am unable to find the supplied model number.

Keep us posted with the results so we can advise you further.
My System SpecsSystem Spec
02 Aug 2013   #7

Windows 7
 
 

Thanks for your help guys, but I have resolved the issue on my own. Acer does not provide windows 7 driver support and thus I had to look for drivers by myself. I ended up downloading a USB 3.0 driver from another company's website (Asus) as it was the two laptops were both running basically the same specs and chipset. The driver resolved the issue entirely. Below is a link to the driver that worked for me:


Hub de raiz Intel(R) USB 3.0 Driver Download for WIN7/64bits - ASUSTeK COMPUTER INC. K45A (K/1.0- SKU:ASUS-NotebookSKU)
My System SpecsSystem Spec
03 Aug 2013   #8

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by moonrobin View Post
Thanks for your help guys, but I have resolved the issue on my own. Acer does not provide windows 7 driver support and thus I had to look for drivers by myself. I ended up downloading a USB 3.0 driver from another company's website (Asus) as it was the two laptops were both running basically the same specs and chipset. The driver resolved the issue entirely. Below is a link to the driver that worked for me:


Hub de raiz Intel(R) USB 3.0 Driver Download for WIN7/64bits - ASUSTeK COMPUTER INC. K45A (K/1.0- SKU:ASUS-NotebookSKU)
Hi moonrobin,

Its great to hear that issue with the system has been resolved to your satisfaction. We appreciate the efforts taken by you to share the resolution as I am sure many other users would benefit from it.

If you have any queries in future feel free to contacts us.
My System SpecsSystem Spec
Reply

 USB ports have power, but send no data




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33