Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 2 out of 3 USB Ports not working

05 Aug 2013   #1
snakeyes37

Windows 7 Home Premium 64bit
 
 
2 out of 3 USB Ports not working

Hello,

I recently installed a new hard drive and re-installed Windows 7 Home Premium 64bit (FYI this is a retail version) on my laptop.

Now it seems that two out of the three USB ports on my computer aren't working. The ones next to the CD drive are unresponsive. The lone USB port on the other side of the computer works fine.

I've tried looking at the device manager but the USB drivers seem to be working fine, I didn't see any errors.

The only drivers that show up in device manger as not being installed are, PCI Simple Communications Controller, Fingerprint Sensor, Ethernet Controller, and Unknown Device.

The computer came integrated with a webcam so that may be the unknown device showing up in the device manager.


The laptop is a Toshiba Tecra A11-S3530 running Windows 7 64bit Home Premium


Thanks
Nick


My System SpecsSystem Spec
.

06 Aug 2013   #2
maxie

windows 7 home 64bit
 
 

Hi Nick Welcome to Seven Forums .. More than likely you need a USB 3 Driver .. Card Reader for that pci Device .. All the Drivers you need can be found in the Link below

Drivers & Software Support | Toshiba
My System SpecsSystem Spec
06 Aug 2013   #3
snakeyes37

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi Nick Welcome to Seven Forums .. More than likely you need USB 3 Driver .. Card Reader for that pci Device .. All the Drivers you need can be found in the Link below

Drivers & Software Support | Toshiba
Thanks! I already installed the driver for the PCI but the two USB ports still dont work. I'm now leaning more towards the ports being fried on the motherboard. It's the only answer that makes sense.
My System SpecsSystem Spec
.


06 Aug 2013   #4
maxie

windows 7 home 64bit
 
 

Hi Nick .. Yes they could be dead .. Going by your first post though they worked before you had to Reinstall .. If that is the case .. Just wonder why they dont work now
My System SpecsSystem Spec
07 Aug 2013   #5
herqulees

Windows 7 Home Premium 64bit
 
 

If the motherboard does not have all its drivers installed then parts of its features will not work, or even show up in device manager. If the USB ports were working before, and you haven't plugged anything into them and reinstalled the OS and now they don't work, there's no doubt they are not fried. Go to the driver webpage maxie posted, type in your model "Tecra A11-S3530", then select Chipset and Windows 7 (64 bit) on the left of the screen and download the first file listed "Intel Chipset SW Installation Utility".
My System SpecsSystem Spec
Reply

 2 out of 3 USB Ports not working




Thread Tools





Similar help and support threads
Thread Forum
USB Ports Not Working
Last night I was transferring some files from my laptop to my external hard drive and everything was working fine but then a couple hours later, I went to plug in some rechargeable USB batteries that I have and noticed that they weren't lighting up. I then tried plugging in several of my other USB...
Hardware & Devices
USB 3.0 Ports Not Working
I just bought a new Kingston Ultimate 32 GB USB 3.0 flash drive. It works fine in my 2.0 ports but will only light up in the 3.0 ports and Windows 7 64 bit does not see it. I have enabled the USB 3.0 ports in my BIOS and I have got the latest NEC USB 3.0 driver for my MSI P55-GD85 motherboard. ...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Two USB ports not working
Hello! I have a bit of a problem. I have an Acer Aspire 5733Z-4633 and upon receiving it, I reinstalled Windows 7 to get rid of all the bloatware and useless things that were taking up space on the hard drive. Upon doing this, two out of three of my USB ports stopped working for some reason. When I...
Hardware & Devices
Not all USB ports are working
Hello guys, I have just got my motherboard replaced by a PC World Techguy and I got it back last week. Because the BIOS on the new motherboard has not be altered to the same has the old one. The front 2 usb ports are not being recongized, but the one that my usb hub is plugged into is working...
Hardware & Devices
none of my USB ports are working
none of my USB ports are working, can some one please help me????????????
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:27.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App