Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 2 out of 3 USB Ports not working

05 Aug 2013   #1

Windows 7 Home Premium 64bit
 
 
2 out of 3 USB Ports not working

Hello,

I recently installed a new hard drive and re-installed Windows 7 Home Premium 64bit (FYI this is a retail version) on my laptop.

Now it seems that two out of the three USB ports on my computer aren't working. The ones next to the CD drive are unresponsive. The lone USB port on the other side of the computer works fine.

I've tried looking at the device manager but the USB drivers seem to be working fine, I didn't see any errors.

The only drivers that show up in device manger as not being installed are, PCI Simple Communications Controller, Fingerprint Sensor, Ethernet Controller, and Unknown Device.

The computer came integrated with a webcam so that may be the unknown device showing up in the device manager.


The laptop is a Toshiba Tecra A11-S3530 running Windows 7 64bit Home Premium


Thanks
Nick


My System SpecsSystem Spec
.

06 Aug 2013   #2

windows 7 home 64bit
 
 

Hi Nick Welcome to Seven Forums .. More than likely you need a USB 3 Driver .. Card Reader for that pci Device .. All the Drivers you need can be found in the Link below

Drivers & Software Support | Toshiba
My System SpecsSystem Spec
06 Aug 2013   #3

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by maxie View Post
Hi Nick Welcome to Seven Forums .. More than likely you need USB 3 Driver .. Card Reader for that pci Device .. All the Drivers you need can be found in the Link below

Drivers & Software Support | Toshiba
Thanks! I already installed the driver for the PCI but the two USB ports still dont work. I'm now leaning more towards the ports being fried on the motherboard. It's the only answer that makes sense.
My System SpecsSystem Spec
.


06 Aug 2013   #4

windows 7 home 64bit
 
 

Hi Nick .. Yes they could be dead .. Going by your first post though they worked before you had to Reinstall .. If that is the case .. Just wonder why they dont work now
My System SpecsSystem Spec
07 Aug 2013   #5

Windows 7 Home Premium 64bit
 
 

If the motherboard does not have all its drivers installed then parts of its features will not work, or even show up in device manager. If the USB ports were working before, and you haven't plugged anything into them and reinstalled the OS and now they don't work, there's no doubt they are not fried. Go to the driver webpage maxie posted, type in your model "Tecra A11-S3530", then select Chipset and Windows 7 (64 bit) on the left of the screen and download the first file listed "Intel Chipset SW Installation Utility".
My System SpecsSystem Spec
Reply

 2 out of 3 USB Ports not working




Thread Tools



Similar help and support threads for2: 2 out of 3 USB Ports not working
Thread Forum
Solved USB ports not working Hardware & Devices
Solved Front USB ports not working, but rear USB ports work… Hardware & Devices
USB ports are not working Hardware & Devices
Not all USB ports are working Hardware & Devices
none of my USB ports are working Hardware & Devices
USB ports not working...PLEASE help! Hardware & Devices
USB ports not working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33