Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to install mouse drivers


07 Aug 2013   #1

Windows 7 Ultimate x64
 
 
Unable to install mouse drivers

So yesterday I got a new Deathadder 2013, and when I plugged it in, windows tried to find the drivers, blah blah blah, and then it said that it was unable to find the drivers. So, being as it is the solution to everything, I just restart my computer and boom; the mouse worked after.

But today, when I start my computer, the mouse was once again, not working. After checking device manager, it told me that the drivers were missing. I've tried uninstalling the mouse via the device manager and plugging it back in, and restarting my computer to no avail. I tried the solution posted here Unable to install any USB devices as well.

I have however, tried to use the mouse on my other computers and that has proved successful. So, I was wondering if anyone knew where the mouse drivers are stored, if it works that way.

and I do have razer synapse installed.

My System SpecsSystem Spec
.

07 Aug 2013   #2

Windows 7 Professional 64 bit
 
 

Maybe Razer Synapse is conflicting with the Windows drivers, you could try un-installing Razer Synapse and then seeing if Windows recognizes and installs the drivers.

Paul.
My System SpecsSystem Spec
07 Aug 2013   #3

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Maybe Razer Synapse is conflicting with the Windows drivers, you could try un-installing Razer Synapse and then seeing if Windows recognizes and installs the drivers.

Paul.
I have already tried that. I also tried reinstalling synapse too.
My System SpecsSystem Spec
.


07 Aug 2013   #4

Windows 7 Professional 64 bit
 
 

Ok, have you tried the mouse in a different USB port?
My System SpecsSystem Spec
07 Aug 2013   #5

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Ok, have you tried the mouse in a different USB port?
Yessir
My System SpecsSystem Spec
07 Aug 2013   #6

Windows 7 Professional 64 bit
 
 

Darn, usually it will try re-installing if you change the port.

How about a system restore to a point just before you got the mouse?
My System SpecsSystem Spec
07 Aug 2013   #7

Windows 7 Professional 64 bit
 
 

Also did you install the Razer Synapse before or after you connected the mouse for the first time?
My System SpecsSystem Spec
07 Aug 2013   #8

Windows 7 Ultimate x64
 
 

I just got it yesterday, and somehow I got it to work for the whole day.
when I started my computer this morning, it just stopped working even though I didnt change the USB slot that it was plugged into.
My System SpecsSystem Spec
07 Aug 2013   #9

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by paulpicks21 View Post
Also did you install the Razer Synapse before or after you connected the mouse for the first time?
before, because I have a blackwidow as well
My System SpecsSystem Spec
07 Aug 2013   #10

Windows 7 Professional 64 bit
 
 

If it was me, I would try a system restore to 2 days ago, then un-install Razer Synapse reboot and try connecting it again. If it works then consider installing Razer Synapse again.
My System SpecsSystem Spec
Reply

 Unable to install mouse drivers




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:59 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33