Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Ati driver troubles


21 Aug 2013   #1

Win 7 Pro x64
 
 
Ati driver troubles

I made another post in graphics but I need help bad!

I can't get my ati driver to function. Install goes great then I restart. Every time I restart I get to the windows loading screen perfectly fine, then when the log-on screen should display my monitor crashes and goes black, like it reset but still has a connection because it doesn't the light doesn't turn orange but stays blue. I can hear the windows sound play as the black hits so I know it's not a full crash.


I am now on a fresh reformat and the driver has done the same thing.

Any input would be greatly appreciated.

Mobo : Asus Sabertooth 990fx

Gfx : Xfx Radeon Hd 6870

Chip : Amd 4170-fx quad

Ram : corsair xm3 4gb 4 sticks. 1600mhz ( currently running 2 in case this was the issue )

Bios 1208

Catalyst version 13.4

Win 7 pro x64

My System SpecsSystem Spec
.

21 Aug 2013   #2

Windows 7 Professional 64 bit
 
 

Hello Bestdetested, welcome to the forums.

How are you installing the drivers in the first place? Is it working fine with the GPU drivers Windows loads and then having issues if you try to update them to the new AMD ones?

Paul.
My System SpecsSystem Spec
21 Aug 2013   #3

Win 7 Pro x64
 
 

Both the windows update version and the latest from the amd / ati website are not functioning.

I believe the last version I was running before my initial issue was 12.8.
My System SpecsSystem Spec
.


21 Aug 2013   #4

Windows 7 Professional 64 bit
 
 

And have your tried running 12.8 again to see if it will run ok?

How are you getting back into Windows to try again each time? Safe mode?
My System SpecsSystem Spec
21 Aug 2013   #5

Win 7 Pro x64
 
 

Yeah I go into safe mode and uninstall through device manager, then I use a driver cleaning software after a full uninstall through catalyst just to be sure all registry entries are clean.

I have not tried 12.8 yet. Currently trying to get my windows back up to date.

I am going to try a second monitor as well to see if it could be that.
My System SpecsSystem Spec
21 Aug 2013   #6

Windows 7 Professional 64 bit
 
 

I doubt very much it will be the monitor. Yes certainly try the drivers/CCC that it worked fine with last. If you are still getting issues then, I would suggest maybe the GPU has decided to throw in the towel You can of course test this by trying it in another PC if you can or taking it to a PC shop to get it tested.

Best of luck

Paul.
My System SpecsSystem Spec
21 Aug 2013   #7

Win 7 Pro x64
 
 

Yeah, wasn't the monitor. This card is hardly even 2 years old! I can't imagine it being done already, especially since I can recall having this problem before and I haven't put that much use into it.

Could it be that it isn't working well with my other components, psu or ram ?
My System SpecsSystem Spec
Reply

 Ati driver troubles




Thread Tools



Similar help and support threads for2: Ati driver troubles
Thread Forum
SSD Troubles Hardware & Devices
TrendNet TEW-423pi Windows 7 Driver Troubles Drivers
VPN troubles Network & Sharing
Ram Troubles Hardware & Devices
Log on troubles General Discussion
Mic troubles? help? Sound & Audio
So W7 troubles... Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33