Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ASUS M4A89GTD Pro/USB3: USB3 driver issues

06 Sep 2013   #1
PossibleJew

window 7 x64
 
 
ASUS M4A89GTD Pro/USB3: USB3 driver issues

Hello and thanks for any help you can provide.

I have been having issues with my ASUS motherbord, I recently cleaned and re-formatted my main HDD, after doing this i re installed windows and all my normal drivers, motherboard, cpu, gpu, etc. But for some reason every time I install my USB3 drivers for my motherboard I get a driver failed to install and the little yellow indicator next to the driver in device manager. I am still running on the same HDD I was before with the same Windows and all the same hardware. I dont know what else to try I have tried getting the drivers off the internet instead of the disc that came with my motherboard as well as installing and re installing multiple times. And after being sufficiently frustrated I clean and re-formatted again to see if that would help. All other ports and software is functioning as it did before, this is the only issue I have had.

P.S. I did, yesterday, remove 2 of my ram sticks (they were slower speed, than my other ram) but this hardware change was well after I had given up on fixing the USB3 ports/drivers. All of my system specs are in my profile.

Any Ideas?


My System SpecsSystem Spec
.

06 Sep 2013   #2
brreaker

Windows 7 ultimate x64
 
 

Can you please right click my computer, go to properties, then to Device manager, choose the troubled driver, right click it, hit properties, then go to the Details tab, then in the Drop-down menu select "Hardware IDs" and post the info here?
My System SpecsSystem Spec
07 Sep 2013   #3
maxie

windows 7 home 64bit
 
 

Hi Welcome to Seven Forums .. There seems to be a lot of Drivers on your Motherboards website .. I would try the Nec Driver also some Updates

ASUSTeK Computer Inc. -Support- Drivers and Download M4A89GTD PRO/USB3
My System SpecsSystem Spec
.


07 Sep 2013   #4
PossibleJew

window 7 x64
 
 

Pci\ven_1b21&dev_1042&subsys_84881043&rev_00
pci\ven_1b21&dev_1042&subsys_84881043
pci\ven_1b21&dev_1042&cc_0c0330
pci\ven_1b21&dev_1042&cc_0c03
My System SpecsSystem Spec
07 Sep 2013   #5
PossibleJew

window 7 x64
 
 

Maxie,

The error i got when trying to install the driver from that site is no driver found in the windows installer.
My System SpecsSystem Spec
07 Sep 2013   #6
PossibleJew

window 7 x64
 
 

the wizard for the drivers says it installed successfully, but the Windows device installation window, shows no driver found. Idk if it help but it says "The model name of your USB controller is ASMedia XHCI Controller."It tells me " Your USB controller is missing a driver." In the action center, but the steps it gives me are just to re download and extract the driver files and re install. Which i have done several times.
My System SpecsSystem Spec
07 Sep 2013   #7
maxie

windows 7 home 64bit
 
 

Hi there .. Is the Driver you are trying to Install a INF file ?
My System SpecsSystem Spec
07 Sep 2013   #8
maxie

windows 7 home 64bit
 
 

Check the Link below for your PCI/VEN ...

Drivers Lookup
My System SpecsSystem Spec
07 Sep 2013   #9
PossibleJew

window 7 x64
 
 

Once the drivers say they installed successfully( setup wizard, not windows device installer) I went into the NEC Electronics folder > USB 3.0 Host controller Driver> Driver> these are the files in that folder. So the one file is a INF

nusb3drv.cat
nusb3drv.inf
nusb3hub.sys
nub3xhc.sys

Also i was not able to locate my PCI/VEN through that link there were ones that were close:
PCI\VEN_1B21&DEV_1042&REV_00 PCI\VEN_1B21&DEV_1042&REV_01 PCI\VEN_1B21&DEV_1042&REV_02 But none of them had downloadable files listed once i clicked them. I assume the REV_00 would be the one that is mine.
My System SpecsSystem Spec
07 Sep 2013   #10
brreaker

Windows 7 ultimate x64
 
 

Chip Number: 1
Chip Description: Asmedia ASM104x USB 3.0 Host Controller
Notes: ASMedia Technology Inc. ????
My System SpecsSystem Spec
Reply

 ASUS M4A89GTD Pro/USB3: USB3 driver issues




Thread Tools





Similar help and support threads
Thread Forum
Updating USB3 controller driver
I tried to update my USB3 controller to the latest level of driver, using the update from the ASUS site for my motherboard (as recommended by the supplier of my PC). The install was an Intel program, which left me without a driver for my mouse/keyboard, requiring a System Restore... Is it a good...
Drivers
BSOD 0x00000124 on Asus M5A78L-M/USB3 & AMD FX-4170
Hi all, I am having random BSOD's on the above combo, not heat/CPU load related, they are all the same report (below). My system is: Motherboard : Asus M5A78L-M/USB3 CPU : AMD FX-4170 Memory : 8GB (1x 4GB and 2x 2GB) OS : Windows 7 Professional x64
BSOD Help and Support
RAM Compatibilty on Asus M5A78L-M/USB3 Motherboard
Hi, I am wondering if anyone can help tell me if this ram: Crucial CT25664BA1339 2GB 240-PIN PC3-10600 DIMM DDR3 Memory Module Amazon.com: Crucial CT25664BA1339 2GB 240-PIN PC3-10600 DIMM DDR3 Memory Module: Electronics Is compatible with this motherboard: Asus M5A78L-M/USB3
Hardware & Devices
Bsod caused by USB3 driver
I have a weird problem with USB 3 drivers I think. This is my configuration: Motherboard: Gigabyte GA-B75M-D3V Cpu : Intel Core i5 3470 Ram : 8 Gb Corsair 1333 Mhz Video: Gigabyte GeForce GTX 660 2048MB DDR5 OC version Hdd : Western Digital 640 GB 7200 Rpm Case: Segotep SG-Z2
BSOD Help and Support
ASUS M4A89GTD/PRO USB3.0 motherboard reboots randomly.
Hi, Specs: Windows 7 Pro x64 ASUS M4A89GTD/PRO USB3.0 AMD PhenomII x6 1075T 2x WD Caviar blue 250Gg HDD in RAID 0 EVGA NVIDIA GTS 450 8Gb DDR3 1600 G.Skill Ripjaws (4x 2Gb sticks) My ASUS motherboard will just reboot, or freeze. It happens during BIOS, Booting/installing windows, and when...
Hardware & Devices
ASUS M5A78L-M/USB3 compability with Corsair XMS3 2x2GB 1600MHz 1.65V
Helle everyone. I have a problem with the sound on my board "popping / clicking sound" like when you power on your speakers but it's constantly does that and even when on standby...I will start from the very first day when I built my PC. Well I built my PC from following parts : Motherboard: ASUS...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App