Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: The following system start driver(s) failed to load: mbmiodrvr

25 Sep 2013   #1
deepblue13

Windows 7 Home Premium 64bit.
 
 
The following system start driver(s) failed to load: mbmiodrvr

Hi all.

My pc has been hanging randomly and I have to use the power button to shut down/restart.

I've checked in events and there is this error which seems to be causing the problem as the time matches with the hang time.

I posted another topic with another bsod issue in the bsod section, and I was told to run some tests.

A day or so ago, I tried and changed Driver Verifier settings as were instructed in one of the threads here which also mentions that it is an iffy thing to do.

Anyway, I lost windows and could not start again, luckily I had a backup made, and after formatting my HD, loaded it on to it. This error seems to be a driver issue (Screenshot).

Should I go down the Driver Verifier route again ? To be honest I don't want to. If I lose windows again it would be very frustrating.

I've run the following tests so far here

I have no driver issues showing up in Device Manager, so that looks ok.

Please advise. Thank you.




Attached Thumbnails
-mbmiodrvrscreenshot1.jpg  
My System SpecsSystem Spec
.

26 Sep 2013   #2
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

I looked around and found a reference to Mother Board Monitor which at least sounds like it might be the culprit.

Do you have that application installed, or some other temperature / fan speed monitoring sw?

Alex Van Kaam, the author of Mother Board Monitor, stopped development in 2004 citing his frustration getting technical information from mfgrs.

Anyway, if you have Mother Board Monitor installed, remove it. If you have other monitoring sw, post what you have and someone might know more about that sw (MBM source used?)

If you haven't tried a Clean Boot, here's a tutorial you can follow:
Troubleshoot Application Conflicts by Performing a Clean Startup

Bill
My System SpecsSystem Spec
26 Sep 2013   #3
deepblue13

Windows 7 Home Premium 64bit.
 
 

Thanks Slartybart.

Ok, wow I didn't know I had it installed but yes 'Motherboard monitor 5' is showing up in programs. I guess it's been sitting there very long & I maybe only hardly ever used it. I just did a Total Uninstall of it.

Other than that I have SpeedFan and HWiNFO64 installed both of which monitor temp/speed.

I think I'll run and test for a while after removing and will get back and report.

Thanks again.
My System SpecsSystem Spec
.


26 Sep 2013   #4
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

I think speed fan and HWinfo are stable applications. I have used them without issue.

I hope that MBM was causing the issue and removing it solves it. If not, you know members on sevenforums will try to help

If you're machine is running well please do post an update and mark this thread as solved
if you think it worthy of thier effort, tip the scales on posts by members who provided assistance on this and your other thread
My System SpecsSystem Spec
29 Sep 2013   #5
deepblue13

Windows 7 Home Premium 64bit.
 
 

All working well. Thanks again!
My System SpecsSystem Spec
29 Sep 2013   #6
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

You're welcome, glad to hear the machine is behaving
My System SpecsSystem Spec
Reply

 The following system start driver(s) failed to load: mbmiodrvr




Thread Tools





Similar help and support threads
Thread Forum
The driver \Driver\WUDFRd failed to load for the device... error
Hi, Since the 11/18/2012 event viewer (Event ID 219, Task Category 212) has been posting a warning: The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN (followed by name of USB device) It only occurs on start up if I...
Drivers
The driver \Driver\WUDFRd failed to load for the device error
Hi i have a couple of weeks ago installed windows and i just got bsod crash and this was the only error in the event viewer The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_GENERIC&PROD_USB_CF_READER&REV_1. ...
BSOD Help and Support
Out of ideas - The driver \Driver\kbdhid failed to load for the device
This has been a problem for over a year now. 140+ identical PCs running identical images, with identical keyboards. Some have the problem, some do not, and it's incredibly unpredictable. PCs are HP Compaq Elite 8300 SFF running Windows 7 x64 Professional. People will be working at their PC,...
Hardware & Devices
The driver \Driver\WUDFRd failed to load
I get this message often and whenever I do, my Windows runs in slow motion The driver \Driver\WUDFRd failed to load for the device HID\VID_1B96&PID_0006&MI_01&Col02\8&1c39cefe&0&0001. What should I do?
Hardware & Devices
the following boot start or system start drivers failed to load
I'm not sure where to even begin to fix these problems. Some online searches suggested doing a system repair but I want to get some more feedback here before proceeding. Here is the message from the event log: The following boot-start or system-start driver(s) failed to load: AFD cmdGuard...
BSOD Help and Support
Cant load windows:Win failed to start ---->bsod bad_sys_config_info
Hi. My Dell Studio 17 shut down yesterday after sitting idle. Now i cannot boot windows. I get this endless loop that ultimately leads me to startup repair which either hangs or errors out. Attempting to start in safe mode takes me to same place. I know the root of the problem is bsod as I see it...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:22.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App