Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After updating Asmedia drivers, my external HDD isn't working

09 Oct 2013   #1
Gil

Windows 7 x64
 
 
After updating Asmedia drivers, my external HDD isn't working

Hi all,

I run Win7 64 bit.
MB: Asus P8Z77-V-Deluxe
External HDD:
Seagate Expansion Desktop STAY2000102 2TB USB 3.0

The HDD is connected to the Asmedia USB port.
I made sure to install the drivers when no device is connected to the USB and restart the PC. It worked fine after initial reboot. But after the 2nd reboot, the PC doesn't recognize the external HDD anymore.

If I connect the HDD to the intel usb port, it's bad as well.


I attached a screenshot that shows it's connected but not identified.
Please help!

P.S. - Now the PC calls my Seagate external drive "External"... (2nd screenshot) after following this:
Missing USB Mass Storage Device driver




Attached Thumbnails
-gil.png  
Attached Images
 
My System SpecsSystem Spec
.
10 Oct 2013   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Gil mate have you tried the drive on another machine?
My System SpecsSystem Spec
10 Oct 2013   #3
Gil

Windows 7 x64
 
 

I don't have any other machine with USB 3.0.
But I did try on USB 2 and it works without an issue.
Since it's a USB 3 drive and it used to work... I can't settle
My System SpecsSystem Spec
.

10 Oct 2013   #4
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

I presume this is happening with your front USB ports? I'd suggest making a backup of the latest driver, remove all USB 3.0 devices and uninstall the Extensible Host Controller (expand the Universal Serial Bus Controllers tree in Device Manager). This is the mid board header controller for the front USB 3.0 ports. Reboot and Windows should recognise the device and reinstall it, then install the backed up latest drivers again and give it a whirl.
My System SpecsSystem Spec
10 Oct 2013   #5
Gil

Windows 7 x64
 
 

No, I actually connect it to the rear USB ports since it's not a portable HDD, it's an external desktop HDD and It's always connected to my PC
My System SpecsSystem Spec
10 Oct 2013   #6
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 


As Boozad says mate you need to look again at he drivers for thatboard which I see is a DDR2 driven one are you sure of the board number?? as Ididn't think USB3.0 came out until after DDR3 was the standard RAM I stand tobe corrected of course.
Now looking at the specs for that board it only has 12 x 2.0 USB port there are no 3.0 USB ports on it. Doesn't matter cos the 3.0 is back compatible.

GIGABYTE - Motherboard - Socket 775 - GA-EX38-DS4 (rev. 1.1)
My System SpecsSystem Spec
10 Oct 2013   #7
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

We need some clarification here Gil as your OP says an ASUS P8Z77-V deluxe motherboard whereas your system specs say you have a Gigabyte motherboard which John has referred to.

If it is the ASUS board you're having problems with then please follow the steps in post #4 regardless of the position of the USB ports. ASMedia controllers are normally controlling mid board headers on AMD systems, the fact you have an Intel system with the ASMedia controller controlling the rear ports doesn't really make any difference.
Did you download the drivers from the ASUS website? You may have to download ASMedia drivers from elsewhere as it's been a known issue in the past that manufacturers don't carry the latest ASMedia drivers on their websites, I had the same problem with my backup AMD rig.
My System SpecsSystem Spec
10 Oct 2013   #8
Gil

Windows 7 x64
 
 

Ddues how did you get that I have Gigabyte mobo?

I have Asus P8Z77-V-Deluxe. In the first screenshot you can see that I'm running Core i7 3770K. The gigabyte model can't run core i7

Ok... writing these lines I think this mobo is in my profile... that's the old mobo I had... I'll update that
My System SpecsSystem Spec
10 Oct 2013   #9
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Quote   Quote: Originally Posted by Gil View Post
Ddues how did you get that I have Gigabyte mobo?

Ok... writing these lines I think this mobo is in my profile... that's the old mobo I had... I'll update that
I did explain that in my last post.
My System SpecsSystem Spec
10 Oct 2013   #10
Gil

Windows 7 x64
 
 

yeah I got stuck on "where did they get that from" that I didn't read all the way through... sorry mate

As for your question, I downloaded the latest Asmedia driver 1.16.10 and also did firmware upgrade.
So I'm carrying the latest when it comes to Asmedia drivers...

P.S. - Now my PC will wake up right after sleep mode is on... something got really messed up here
My System SpecsSystem Spec
Reply

 After updating Asmedia drivers, my external HDD isn't working




Thread Tools




Similar help and support threads
Thread Forum
Need help with updating drivers
Recently bought a refurbished laptop Its a HP pavilion G7 Notebook PC. I've attached system specs for information on to update all drivers.
Drivers
Updating Drivers
Another forum I go to posted this program. I tried it and unlike all the other programs that tell you that you have 400 drivers out of date and want you to pay, this one only found 3 and immediately updated them. Completely free. Using IObit Driver Booster by Majorgeeks.com - MajorGeeks...
Software
Updating Drivers Help
Please can anyone tell me why Catalyst Control Center isn't appearing in Catalyst Install Manager? I have uninstalled all ATI stuff from my laptop and CCC simply won't appear, I have been having this Driver problems for months and my blood is really boiling right now so I apologize if I happen to...
Drivers
Windows 7 not updating, Indexing not working, search not working, FYI
I had been working an issue where the search function was not working correctly, I then noticed that Indexing was not working and I could not update windows. I wanted to post this in case someone had similar issues, it took me a while to figure this one out... The problem likely started when I...
Windows Updates & Activation
Updating drivers
I want to update my drivers. I already have all the latest drivers from the HP support page for my computer, but I think a few of them may be out of date. Problem is that I cannot find the exact model number of my installed hardware. For example, my Intel display chip just lists as "Mobile Intel(R)...
Drivers
Drivers Not Updating
I need to update all my drivers. I have tried to do it the traditional way through the control panel but my drivers claim to not need updating. Is there another fix? I would prefer not to download driver update software that requires me to pay them for updating my drivers. Thanks in advance....
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App