Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Front USB ports not working, driver problem

18 Oct 2013   #11
bob12345

Windows 7 Home Premium 64-bit SP1
 
 

I don't see where the software checks for installed drivers. It looks like the CD is only used to install drivers that the owner selects.




Attached Thumbnails
Front USB ports not working, driver problem-cd.jpg  
My System SpecsSystem Spec
.
18 Oct 2013   #12
bob12345

Windows 7 Home Premium 64-bit SP1
 
 

After looking around the CD files, "Asus InstAll" does check drivers if you click custom install.

They crazy thing is some how my chipset driver was not installed. I have been using this computer for months with no issues with the 3.0 ports, but something deleted my chipset driver.

Thank you for your help.
My System SpecsSystem Spec
18 Oct 2013   #13
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Brilliant, glad you got it working mate. I'm pretty embarassed that I didn't think of the chipset driver though, schoolboy error on my part there. At least you're up and running though, that's the main thing. Thanks for marking the thread as solved and enjoy you USB 3.0 speeds!
My System SpecsSystem Spec
.

19 Oct 2013   #14
bob12345

Windows 7 Home Premium 64-bit SP1
 
 

Maybe the chipset driver got uninstalled when I updated the graphics driver to ccc 13.9. I just hope no one else will have this problem.
My System SpecsSystem Spec
19 Oct 2013   #15
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

It was probably when you uninstalled the USB driver.
My System SpecsSystem Spec
08 Aug 2015   #16
nounours18200

Windows 7 Professional 64 bits
 
 

Quote:
After looking around the CD files, "Asus InstAll" does check drivers if you click custom install.
My Asus CD is no longer readable, so I cannot run Asus Install in custom mode to chek if a driver is missing..., can anyone provide me with a link to an ISO image ?

But more interesting: I have the same problem than you, BUT the Asmedia XHCI controller does NOT appear in the Device Manager, it is not detected by Windows, as shown in the picture below:



If I try to install the ASMedia driver, the installation program terminates before the end, saying that there is no Asmedia controller on my PC...

Could it be a motherboard failure, meaning that the ASMedia controller is out of order ??
My System SpecsSystem Spec
16 Sep 2015   #17
nounours18200

Windows 7 Professional 64 bits
 
 

Provided that THOUSANDS of people have this problem, and that there is no clear solution, I have decided to stop searching for a solution (that I am sure to not find...).

I have bought a $30 PCI-Express card offering 4 USB-3 ports and 2 internal USB-3 ports (to connect the chasis front USB ports) : it has the appropriate drivers for W7, W8 and is immediately recognized by W10.

No more problem : 100% perfect !

As long as the manufacturers, Asus, W$ or Intel (who is responsible ????) will not commit to fix it, this is for me the best approach .
My System SpecsSystem Spec
Reply

 Front USB ports not working, driver problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
USB 3.0 Ports stop working after installing Intel Driver
Hi, I have Windows 7 Home Premium, and whenever I install the Intel USB 3.0 eXtensible Host Controller, my USB 3.0 ports cease to function. I want to have them installed because my OCD tells me, because of the "Unknown Device" in device manager that I'm fairly certain goes away after installing it....
Drivers
Problem with USB ports working
I am new to this site so I may not ask the right questions. Basically I have a Compaq Presario CQ62 Laptop. I've had it for probably 4-5 years. I have put various softwares on it. At some point, I don't know when, all 3 USB ports started screwing up. The two on the left side don't work. The...
Hardware & Devices
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Multiple driver errors and keyboard not working on 90% of ports
Hello, just joined and I need some help. Troubleshooter says there's driver problems with 2 of my programmable root enumeraters(What hell is that for?), UMBus Enumerator, and there's a unknown device without a driver, but I'm 99% sure that's Intel smart connect and I'm gonna remove that from bios...
Drivers
Front Panel USB Ports
Hello everyone. The USB Ports on the front panel of my desktop connect to my motherboard using a wire. Now thats all fine and dandy but I do not know which to plug it into. The pin layout for the following (which match with the USB's cord) is this. . . . . . . . . . Now I have 3 of...
Hardware & Devices
sound/front panel ports
After my build, firs build btw, I have front panel mic/headphone ports. Also on my AC powered Altec Lansing speakers there is a headphone port. If I plug in my headphones into speaker port it mutes speaker and sound comes through headphones. When I plug in headphones into front paned ports I get...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App