Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Front USB ports not working, driver problem


15 Oct 2013   #1

Windows 7 Home Premium 64-bit SP1
 
 
Front USB ports not working, driver problem

I noticed these past few days that my front USB 3.0 ports are not working. Whenever I plug a USB 2.0 flash drive into the front ports, the activity light on the flash drive itself does not turn on.

I did clean all old Windows updates using disk cleanup which may have caused the problem.

So far, I uninstalled the USB driver and tried to reinstall the software with no success.
I have attached a picture of a screenshot after the driver installation failed.
Thank you



Attached Thumbnails
Front USB ports not working, driver problem-usb.jpg  
My System SpecsSystem Spec
.

15 Oct 2013   #2

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

Just a couple of questions, how did you reinstall the drivers? Through Device Manager or running from the motherboard disc utility? And did you have any USB devices plugged in when installed it?
Usually if you run the software from the motherboard disc and choose drivers you'll get a list of drivers with check boxes next to them, and any that aren't installed will be unchecked. Those would be the ones you need. The ASMedia XHCI controller is the driver for your mid board header which controls the front USB 3.0 ports and that look as if it's installed fine, so I'd run that motherboard utility and see what it shows up.
Also could you post a screenshot of Device Manager with the USB controllers section expanded.

For what it's worth I have a very similar set up in my back up rig (A10-5800k on an ASUS F2A85-V Pro) and have never got the front USB 3.0 ports working on the BitFenix front panel I added. Not saying we won't get yours working, just that you're certainly not alone with this issue.
My System SpecsSystem Spec
15 Oct 2013   #3

Windows 7 Home Premium 64-bit SP1
 
 

I downloaded the USB driver from Asus site. Using the provided software, the driver was removed then reinstalled using the downloaded files.
During initial setup of this computer back in May, I downloaded and installed all drivers without a CD-Rom with success.
I believe the USB flash drive was not plugged in at the time.

My front USB ports were working good for months, but just recently this problem arose.


Attached Thumbnails
Front USB ports not working, driver problem-usb2.jpg  
My System SpecsSystem Spec
.


16 Oct 2013   #4

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

I'm pretty sure this is a replica of the problem I had when I uninstalled my USB 3.0 drivers and hardware when I couldn't get it working, I got round it by running the motherboard utility from disc. It will scan your system and highlight any drivers that aren't installed, I remember installing mine through Device Manager but there were two or three I just couldn't pick up and the disc utility did it. It will show the ones that aren't installed through the boxes being unchecked, that's the route I'd go down first assuming you have the disc that came with the motherboard.
It is easy enough to miss drivers when collecting them or not pick up the right ones. If you could humour me and give that a try and we'll take it from there.
My System SpecsSystem Spec
16 Oct 2013   #5

Windows 7 Home Premium 64-bit SP1
 
 

Thanks, do you know the name of the utility? Again, I don't have a CD reader so I cannot run the CD. On their site, there is a PC diagnostic utility I'm going to try.
My System SpecsSystem Spec
16 Oct 2013   #6

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

The utility is basically the driver installer for the motherboard, that's going to be a problem if you don't have an optical drive. I don't know if it's possible to download an ISO and mount that to a USB stick, I'll have to have a look into that. Could you get your hands on an external CD/DVD drive temporarily to run the motherboard disc?
The long winded way would be to work through your drivers and compare them to what's available on the ASUS website page for your motherboard and see which ones are missing.
My System SpecsSystem Spec
16 Oct 2013   #7

Windows 7 Home Premium 64-bit SP1
 
 

Since I don't have access to a CD drive, I decided to call Asus about the problem. After describing the problem and my failed attempts to the tech, they issued me a RMA number to repair the motherboard. However, the person I spoken with did not try to resolve the issue over the phone which troubles me. Do you think this is a hardware issue or software? Since you managed to get yours to work, I do not want to go through the trouble of an RMA if this is only a software issue.

For now I removed the usb 3.0 connection to the MB and using the usb 2.0 header instead. So far the motherboard is reading my flash drive.
My System SpecsSystem Spec
16 Oct 2013   #8

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

It's just missing drivers, I'm 99% certain this isn't a hardware problem and that running the motherboard disc would resolve the issue. I had a quick look at the driver download page for your motherboard but, like when I had the same problem, nothing's jumping out at me. My recommendation would be to pick up an external CD drive for around $15 and run the motherboard disc.
My System SpecsSystem Spec
17 Oct 2013   #9

Windows 7 Home Premium 64-bit SP1
 
 

Thank you for your advice. It may be a while before I get my hands on a CD drive. However, I am happy the front USB ports are working in the 2.0 version.
My System SpecsSystem Spec
17 Oct 2013   #10

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

Sorry I couldn't get your problem sorted at the moment, I'm just wondering if it would be possible to rip your motherboard disc and mount it to a USB stick on another PC. I'll look into it.
My System SpecsSystem Spec
Reply

 Front USB ports not working, driver problem




Thread Tools



Similar help and support threads for2: Front USB ports not working, driver problem
Thread Forum
Usb front ports, dust, maintenance ? PC Custom Builds and Overclocking
Solved Front USB ports not working, but rear USB ports work… Hardware & Devices
Multiple driver errors and keyboard not working on 90% of ports Drivers
Front USB ports wont work? Hardware & Devices
Front Panel USB Ports Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:45 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33