Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Linksys WMP54G not showing up after new install of Win7Ultimate 64bit

04 Nov 2013   #1
PremiuMsam

Windows 7 Ultimate 64bit
 
 
Linksys WMP54G not showing up after new install of Win7Ultimate 64bit

Hey,

I just upgraded from Windows 7 32 bit to 64 bit and I am having trouble getting my wireless adapter to show. I've got no internet at all at the moment. In Device Manager, there's no mention of any Linksys at all, just the standard 'wireless adapter' and so on.

I had a google and read several threads about how apparently Linksys doesn't do 64 bit Win7 drivers, but that there is a fix for it. I tried this fix (How to install WMP54G Drivers on Windows 7 Beta 64 bit (or Vista 64 bit) | PhishThis!), which involved going to Ralink's website and downloading some of their drivers, but following the process specified gave me an Error 10 message.

Any thoughts on what I can do? I can't for the life of me remember how I got it working when I first installed Win7 32 bit. If worse comes to worse and I need a new adapter, what should I look at that is cheap? I'd much prefer however to fix this one though.

Thanks!


My System SpecsSystem Spec
.

04 Nov 2013   #2
PremiuMsam

Windows 7 Ultimate 64bit
 
 

I'll paypal $20 to anyone who can help me solve this. This is absolutely killing me. I even tried rolling back to 32 bit and that isn't working either. I connected an ethernet cable and that isn't getting me internet either. I called my local ISP, who are usually very helpful, and they were quite lost. I've tried different Linksys and Ralink drivers, no luck. I'll either install them and nothing will happen, or i'll install then restart and it will say driver installation not successful.
My System SpecsSystem Spec
05 Nov 2013   #3
PremiuMsam

Windows 7 Ultimate 64bit
 
 

Never mind! Just went and bought a new adapter, fixed the problem
My System SpecsSystem Spec
.


Reply

 Linksys WMP54G not showing up after new install of Win7Ultimate 64bit




Thread Tools





Similar help and support threads
Thread Forum
Linksys WMP54G Driver. Is there one?? I need it!
I have Linksys WMP54G wireless PCI adapter. When I bought it I was told there was Windows 7 support. I cannot find any win7 drivers for it. Their site only has vista 32bit drivers. Tried them and it causes BSOD on my pc. Is there any other way to find drivers for this? I talked with linksys and...
Drivers
Linksys WMP54G Wireless Card
I just upgraded my friend's desktop to Windows 7, and everything works fine, except for one thing: the wireless card. I've tried searching around for solutions getting the drivers to work for it, but everything I found hasn't helped, so I thought I would try here. Thank you. =)
Drivers
drivers not working on linksys wmp54g 4.5
tried a handful of different driver sets that seemed to work ok for people with earlier versions of the card that i found on here. nothing works for mine! am i gonna have to wait for linksys to come out with proper win7 drivers or are there vista driver sets or something i can use on mine?
Network & Sharing
linksys wmp54g wireless adapter not working
Hi. I recently upgraded to windows 7 professional, and now my network adapter does not work. I have a Linksys WMP54Gv4 wireless network adapter. I checked with Linksys and apparently they don't have windows 7 drivers yet. If anyone knows of any fixes or ways to get around this problem I would...
Drivers
Spotty connection with Linksys WMP54G
I just upgraded to Windows 7 a couple days ago, am using the x64 RC 7600 version. Anyhow, My linksys wifi card has been having troubles and I can't seem to find a good driver for it and to be honest I'm not even sure what the issues is. All I know is that my connection will randomly drop every 30...
Network & Sharing
x32 and Linksys wmp54g
Hey guys, this seems to be a common problem. Windows 7 wont recognize my wireless card (wmp54g). I've seen fixes for x64, but am wondering about x32. Any help is appreciated!
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App