Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Aiptek camcorder missing a Win7 driver

16 Nov 2013   #1
Handelo

Win 7 Pro 64-bit
 
 
Aiptek camcorder missing a Win7 driver

Hey all,

I've recently purchased a small handheld camcorder from Aiptek - namely the Aiptek High Speed HD 720p Camcorder, model number V2T6. It's a nifty little device with 2GB internal memory and the option of recording 720p video at 60 fps. Problem is, I just found out that Aiptek never issued a driver for it. It just seemed to automagically work when connected to a machine running Windows XP, but not for Win 7.

When I connect it to my PC, Windows detects it as an "Amba Simple Class" device, but naturally fails to find any drivers for it automatically. I've tried everything from installing other Aiptek camera drivers (which are mostly just programs, not drivers) to trying to connect it while running an XP virtual machine, but to no avail.
"Amba Simple Class" probably means it's running an Ambarella chip, but I couldn't find any drivers for those either. I don't have any XP machines available to me... pretty much anywhere.

I've contacted Aiptek support 3 days ago, but with how broken their website is I doubt their mailbox is even attended to. So now I'm fishing for ideas. Can anyone help? Please?


My System SpecsSystem Spec
.

18 Nov 2013   #2
SandeepP

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by Handelo View Post
Hey all,

I've recently purchased a small handheld camcorder from Aiptek - namely the Aiptek High Speed HD 720p Camcorder, model number V2T6. It's a nifty little device with 2GB internal memory and the option of recording 720p video at 60 fps. Problem is, I just found out that Aiptek never issued a driver for it. It just seemed to automagically work when connected to a machine running Windows XP, but not for Win 7.

When I connect it to my PC, Windows detects it as an "Amba Simple Class" device, but naturally fails to find any drivers for it automatically. I've tried everything from installing other Aiptek camera drivers (which are mostly just programs, not drivers) to trying to connect it while running an XP virtual machine, but to no avail.
"Amba Simple Class" probably means it's running an Ambarella chip, but I couldn't find any drivers for those either. I don't have any XP machines available to me... pretty much anywhere.

I've contacted Aiptek support 3 days ago, but with how broken their website is I doubt their mailbox is even attended to. So now I'm fishing for ideas. Can anyone help? Please?
Hi Handelo,

Welcome to Seven forums.

Please check if this device is compatible with Windows 7 as well. Have you checked this device on a different system and does it works correctly there.

Please post a screenshot of the device manager and my computer so we can check the same:

Screenshots and Files - Upload and Post in Seven Forums

We would also need the hardware id for the device so we can try and find some information:

Hardware Identification

Kindly update your system specs here by following this.


Keep us posted with the results so we can advise you further.
My System SpecsSystem Spec
Reply

 Aiptek camcorder missing a Win7 driver




Thread Tools





Similar help and support threads
Thread Forum
Missing Driver in Win7 x64? (Texas Instruments PCIxx12)
I have Win7 x64 built 7600 on my Vaio laptop (VGN-AR890U) In my Device Manager there is a device that I've not found its driver yet! :cry: Mass Storage Controller http://www7.picfront.org/picture/XWzPLmYoxt/thb/Mass-Storage-Controller.jpg I've followed Update Driver button's instructions...
Drivers
Win7 x64bit - Required CD/DVD drive device driver is missing. UGH!!
Hey Everyone, I have tried everything suggested. I starting to wonder if it's just not meant to be. Let me first start out with my specs. Motherboard: GIGABYTE GA-78LMT-USB3 Processor: AMD FX-4100 Memory: 8GB DDR3
Installation & Setup
Missing driver for SM Bus Controller on new SSD Win7 installation
I recently bought a samsung 840 series 250 gb ssd (not showing on my system specs yet) and after installing windows fresh and downloading drivers from asus and nvidia, i looked in device manager and cleared up some missing drivers, but i can't seem to fix this missing sm bus controller. I tried...
Drivers
Panasonic NV-GS75 Camcorder driver
Hi Everyone, I have just tried to upload some video from my gs75 camcorder to my computer. The computer shows that the camera is connected but only for webcam. I tried installing the software but it is not comaptible. Is there a driver out there that I can get to make this camera work with win7? ...
Drivers
Missing CD/DVD Driver when installing Win7
Hi Everyone, I've been searching forums for over 3 days looking for something that works... so far nothing. I have an HP Pavillion DV6500 laptop with CD drive model: HL-DT-ST DVDRAM GSA-T20L ATA Device. I had Windows 7 64bit installed on it before and it worked great.. I wanted to do a...
Drivers
Camcorder Not Loading Driver after SP1
Hi, I have Win7 x64 Pro. Well I have been going fine with my Sony DCR -PD170 firewired to my PC. I plug it in and she pops up asking me if I want to the whole or part of the video and so on. Then I let Windows Update load the SP1 service pack and she will not load. So I go to my laptop...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App