Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Leadtek Winfast TV2000XP RM Drivers ?

09 Aug 2010   #71

Windows 7 Ultimate 64 bit

Quote   Quote: Originally Posted by murka3000 View Post
Emm, anyone?
Sorry murka3000!
I didn't mean to leave you hanging, I was in Cambodia and unable to get on the internet.

RE: SOUND I posted this previously in another thread, so it may not all apply to you.

1. DRIVERS: Go to your manufacturers website (not MS update) and download the latest drivers for your card. It's common that the standard Windows Installed ones don't work with our old TV card.

Right click on the volume icon in the Windows 7 taskbar
First lets check the playback device without PVR.
Open 'Playback Devices' right click on the 'default device' and click test, if it works go
to the next step, if not change your default device or speakers and troubleshoot until this works.
Click on the 'Recording' tab, if PVR is on, you should see movement in the default device sound-bar. If not change this until you see movement in the default device sound-bar.

Ensure that the same devices as selected in your Windows 7 sound settings are the devices in your PVR settings, or that sound is forwarded correctly through your system is alternate devices are selected.

Here's my configuration....
PLAYBACK = Speakers
RECORDING = Line In (High Def)

=MY Windows 7=
Playback = SPeakers
Recording = Line in (High Def)
* Make sure on the Recording tab that you tick the 'Listen to this device' check box otherwise you won't get any audible output.

4. Check Physical connections and hardware
A fault here is unlikely if your sound works for everything else but....Just to be safe, if you have spare hardware, replace each cable/device one at a time (an isolation test) to verify that there is no fault here.

RE: Descaler - If it's not needed than uninstall it; I didn't need it for mine (it depends on the chip). If you need it because of your chip then let me know and I'll request help from 2 of our peers here that I know use it and the TV2000XP card.

Good Luck


My System SpecsSystem Spec
26 May 2011   #72

64bit Ultimate

Quote   Quote: Originally Posted by murka3000 View Post
So here is a simple algorithm for TV2000 XP RM (I think RM):
1) Download these drivers and install it in Device Manager (Update driver).
2) Install ReadyDriverPlus or smth else to solve a problem with Win7 driver blocking.

Now it works great with WinFastPVR2 and WinFastPVR (DScaler v4.1.15 shows me an error)

BUT... there is a problem with sound now.
In WinFastPVR2 and PVR there's a loud noise (spitting) but I can hear the channel sound too but really weakly.
I thought the problem is a cabel and I decided to install Win XP... But in XP it works perfectly! Although I get an error in DScaler in XP (it's doesn't matter cuz I don't like this program).

So I think the problem is in a driver.
And today I've happened to see that I can choose TV2000 as a video source in webcam 7 (webcamXP). I can choose a sound source too.
In this program I choose channel like on a radio - I move the slider frequency. So interesting that if I can see video then I hear a loud noise (like in WinFastPVRx) but after I continue to move the slider till I can't see the picture, here the sound from this channel appears clean as it should be.
So the problem is video and audio frequency discrepancy. Any ideas what to do?

PS webcam 7 works also without installing ReadyDriverPlus (with unsigned drivers).
Got the exact card, Tried your method at windows 7 64 bit, The drivers won't install with the only two files drivers... and the pvr2 won't work with the drivers that i think are similar to yours :/
My System SpecsSystem Spec
07 Oct 2011   #73

Windows 7 Ultimate x64

Hi ,i installed the driver and the software for WinFast Tv2000 xp for Windows7 x64 and i have a problem such as it didn't installed in device manager "multimedia controller" and "multimedia video controlller" and it gives me an error when i starting the program PVR2: "Cannot find any available BDA device". I don't know what is the problem and i need some help
I want to mention that I downloaded the driver and software from the official site for my tv tunner board recommended to Winfast Tv2000 xp Expert because Windows will not let me install them automatically
My System SpecsSystem Spec

10 Oct 2011   #74

Windows 7 Ultimate x64

My System SpecsSystem Spec
18 Oct 2011   #75


Sorry for getting back so late, had problems getting onto the site again...

If you are using the method I posted, then PVR2 will not work with these drivers.

You WILL need to use Dscaler to run your TV...
My System SpecsSystem Spec
18 Oct 2011   #76

Windows 7 Ultimate x64

and where i can find it?

Before W7x64 i had x86 and it worked with driver and software from the official site Leadtek and now i had this problem with driver
My System SpecsSystem Spec
19 Oct 2011   #77


Yes, it used to work.

If you want it to work now with Win 7 X64, then all you need to do is read this thread from the start, it will guide you through the whole process...

If you still struggle, then I would suggest you get a new TV card that supports Windows 7.
My System SpecsSystem Spec

 Leadtek Winfast TV2000XP RM Drivers ?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Leadtek WinFast TV 2000 XP (Deluxe), Windows 7 Pro 64 B
Hello everyone and thanks to take a little of your time ;) First, please excuse for my english i'm french but i will try to explain the best i can. I know there are already few subjects on this problem and i read them all in fact i read dozen of pages (on this forum and on others) since 2...
Leadtek Winfast PVR2000 rtm driver
Hi all I have the Leadtek winfast pvr2000 tv card and it works under vista 32b without problems. I installed the seven rtm 32b and I met problems with this card.:cry: Windows 7 freezes with a black screen during channel scan. All is locked, no mouse, and keyboard led doesn't work respond...
Leadtek Winfast DTV2000H, works in 7100 but not 7201
Hi folks. Great forum! Been reading for a while; first post now. Just upgraded from 7100 to 7201 (x64) and was informed by setup that my Leadtek Winfast DTV2000H TV tuner driver was not compatible. So I moved cxavsvid.sys (CX2388x X64 v5.0.18.6420) to allow setup to proceed. The upgrade process...
Leadtek DTV 2000 H, incompatible with Win7! Solutions?
Hello, I recive this reply from Leadtek at my question regarding a Win 7 32 bit driver for DTV 2000 H: Thanks for your contact. Unfortunately, the chipset of it has already phased out. So the chip of it might not be supported to Windows 7. But you can try to use the driver for Vista to...
Leadtek winfast a280
anyway I can get my old graphic card to work on windows 7? Ive tried the search and nothing is really showing up. thanks
Graphic Cards
Overclocking Leadtek PX8600GTS
i have a couple of things to ask about overclocking. 1.How to overclock a nvidia graphic card with riva tuner if you have a double boot.example.if i overclock a GPU on one OS,will it be overclocked on the other OS or i have to overclock the same value of everything i have overclocked on the other...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:14.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App