Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Removed device from computer, Windows keeps trying to install drivers

25 Dec 2013   #11
C5Longhorn

Win 7 64-bit
 
 

Quote   Quote: Originally Posted by matts6887 View Post
Quote   Quote: Originally Posted by C5Longhorn View Post
Yeah, I loaded my pristine image and moved on. I know what it thought was there. It thought the BT speaker I tried to connect was still present even though I removed it from devices and it wasn't physically around.
So are you basically saying you had no choice but to load the "working" image of the hard drive where everything was working properly? What about the system restore; did that do anything?
Well, most folks wouldn't have done anything because the computer functioned fine in general but it bugged me and I want it to run the best it can. I had a brain fart and thought by system restore you meant backup. My backups did not go far enough back. At this point I made the decision to just load my base system image. I figured it had been two years and I had the time with the holidays.

Everything is now back up and running and I've taken a new pristine image. I would be interested in reading about tips on maintenance, setup, etc. I use two utilities: cc cleaner and Glary utilities but am not sure if there are better ones out there.

Is the tutorial section the best place to go? Also, Santa brought a brand new laptop for my wife that i'm going to set up so i'm looking to find tips on new computer setup beyond the obvious remove bloatware, create pristine image, etc.

Appreciate all the help from everyone.

Rick


My System SpecsSystem Spec
.
25 Dec 2013   #12
matts6887

Windows 7 ultimate 64-bit
 
 

Quote   Quote: Originally Posted by C5Longhorn View Post
Quote   Quote: Originally Posted by matts6887 View Post
Quote   Quote: Originally Posted by C5Longhorn View Post
Yeah, I loaded my pristine image and moved on. I know what it thought was there. It thought the BT speaker I tried to connect was still present even though I removed it from devices and it wasn't physically around.
So are you basically saying you had no choice but to load the "working" image of the hard drive where everything was working properly? What about the system restore; did that do anything?
Well, most folks wouldn't have done anything because the computer functioned fine in general but it bugged me and I want it to run the best it can. I had a brain fart and thought by system restore you meant backup. My backups did not go far enough back. At this point I made the decision to just load my base system image. I figured it had been two years and I had the time with the holidays.

Everything is now back up and running and I've taken a new pristine image. I would be interested in reading about tips on maintenance, setup, etc. I use two utilities: cc cleaner and Glary utilities but am not sure if there are better ones out there.

Is the tutorial section the best place to go? Also, Santa brought a brand new laptop for my wife that i'm going to set up so i'm looking to find tips on new computer setup beyond the obvious remove bloatware, create pristine image, etc.

Appreciate all the help from everyone.

Rick
No; by system restore i mean clicking start; going to accessories, then to system tools and then to system restore. There you should be able to restore the system to before the problem happened(hopefully)
My System SpecsSystem Spec
25 Dec 2013   #13
C5Longhorn

Win 7 64-bit
 
 

Yeah, that may have worked, issue happened around August but I ignored it for a while until now when it was bugging me that I couldn't get them to stay off for good.
My System SpecsSystem Spec
.

25 Dec 2013   #14
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Yeah, waiting that long usually rules out System Restore. Making regular system images is the way to go. A Guy
My System SpecsSystem Spec
25 Dec 2013   #15
C5Longhorn

Win 7 64-bit
 
 

Yep, will have a few more on hand from now on. I had an image from Oct. but it had the problem also.
My System SpecsSystem Spec
Reply

 Removed device from computer, Windows keeps trying to install drivers




Thread Tools





Similar help and support threads
Thread Forum
How to install device drivers during Windows7 install
During the installation process of W7 it is possible to load drivers, e.g. the downloaded SATA, LAN and Graphics drivers for a specific motherboard (MoBo ASUS P7P55D). However, these files are compressed zip files and Unzipping delivers a set of folders with in each a number of files. Which are...
Hardware & Devices
USB device not removed from Device Manager after being unplugged
I have a USB device that is not removed from the Device Manager after I unplug it. The laptop is a Samsung 700Z5B, win7 x64, updated with all MS patches, I'm not 100% sure if the BIOS is up to date, having trouble finding that info. If I have just restarted the computer I can use my USB device...
Hardware & Devices
Windows install : device drivers needed
I'm having some issue with my computer, and to solve that I'm trying to install Windows 7 again. I've yet NOT managed to do that ever on this computer, which is about 1 year old. There's no multiboot or whatever, BUT, there is a RAID controller active, and RAID is actually enabled. Actually, now...
Installation & Setup
Cant install windows 7 (no device drivers)
Hi, im really hoping someone can help, ive been trying to fix this for hours, spec:- Seagate Barracuda 1TB 64MB Cache Hard Drive SATA 6GB/s 8.5ms 7200rpm - OEM | ST1000DM003 Novatech Barebone Bundle - Intel Core i7 3770K - Corsair 8GB DDR3 1333Mhz - Intel Z77 Chipset Motherboard - Novatech...
Installation & Setup
How does Windows 7 Install Device Drivers
During W7 installation does setup perform a brute force scan of all .inf files to find proper devices or does the device provide info that is used to determine the name of the .inf file to be used?
Drivers
Windows 7 Custom Install Issue-No Device Drivers
Hello, I downloaded the student edition of windows 7 Home Premium, I am currently running Vista Ultimate so cannot do an upgrade and have to do a custom install. I downloaded it fine, ran it, it opens up fine with the blue windows 7 opening screen, I select install, then select custom...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App