Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New x64 drivers for ALC 888

28 Dec 2013   #1
Durion

Windows 10 Home x64
 
 
New x64 drivers for ALC 888

Hello, I've just done a clean install of windows 7 Ultimate x64, alongside my old windows XP Pro 32 bit. Everything works fine except the fact that i can't get any sound from my computer, with the error "No audio output device is installed" when i mouse over the volume icon with the red x. I've tried going to the HP's website and they don't have any drivers for 7. I've also tried Realtek's Audio codecs but they don't seem to do anything. In device manager it says multimedia audio controller with a yellow icon next to it. I've tried uninstalling then reinstalling but to no success. My old XP pro says that my sound drivers are ESS 1969 drivers so I got some online and tried to install them but windows said that I need x64 drivers instead when i try to install the inf file. I've done a search for my motherboard online hoping the maker will have the drivers but, but i find out that the sound card that my PC has is actually ALC 888 drivers. If you're trying to help bear in mind that I still have my Xp installed along side with working sound drivers.
Full CPU report below;
PS-It only looks like xp because of my theme

Computer_ HP Pavilion a1600n media center edition.
4 GB Ram

System Info;
CPU-Z TXT Report
-------------------------------------------------------------------------

Description Audio device
Location bus 3 (0x03), device 9 (0x09), function 0 (0x00)
Common header
Vendor ID 0x125D
Model ID 0x1969
Revision ID 0x01
PI 0x00
SubClass 0x01
BaseClass 0x04
Cache Line 0x00
Latency 0x20
Header 0x00
PCI header
Address 0 (port) 0x0000A800
Address 1 (port) 0x0000A400
Address 2 (port) 0x0000A000
Address 3 (port) 0x00009C00
Address 4 (port) 0x00009800
Subvendor ID 0x125D
Subsystem ID 0x8888
Int. Line 0x0A
Int. Pin 0x01
PCI capability
Caps class Power Management
Caps offset 0xC0
Caps version 1.0
PCI registers
00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
00 5D 12 69 19 05 00 90 02 01 00 01 04 00 20 00 00
10 01 A8 00 00 01 A4 00 00 01 A0 00 00 01 9C 00 00
20 01 98 00 00 00 00 00 00 00 00 00 00 5D 12 88 88
30 00 00 00 00 C0 00 00 00 00 00 00 00 0A 01 02 18
40 7F 90 00 00 00 00 00 00 00 00 00 00 00 00 00 00
50 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
90 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
A0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
B0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
C0 01 00 21 06 00 00 00 00 00 00 00 00 00 00 00 00
D0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
E0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
F0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00




Attached Images
New x64 drivers for ALC 888-1.png New x64 drivers for ALC 888-2.png New x64 drivers for ALC 888-3.png New x64 drivers for ALC 888-4.png New x64 drivers for ALC 888-capture-5.png 
Attached Files
File Type: txt PC-Report.txt (82.5 KB, 2 views)
My System SpecsSystem Spec
.
28 Dec 2013   #2
maxie

windows 7 home 64bit
 
 

Hi there .. Might be worth try the Driver in the Link below .. Its not unusual for Drivers from another Manufacturer to work ...

Driver Details | Dell US
My System SpecsSystem Spec
28 Dec 2013   #3
Durion

Windows 10 Home x64
 
 
Ill try

thx ill try installing those, btw my motherboard was made by dell even though the pc is HP
My System SpecsSystem Spec
.

28 Dec 2013   #4
Durion

Windows 10 Home x64
 
 
:( Didn't work.

It installed restarted, but nothing happened.
My System SpecsSystem Spec
28 Dec 2013   #5
maxie

windows 7 home 64bit
 
 

There is an older Version in the Link .. Maybe that might work
My System SpecsSystem Spec
28 Dec 2013   #6
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Quote   Quote: Originally Posted by wede197 View Post
<snip> i find out that the sound card that my PC has is actually ALC 888 drivers.
I'm not sure why you thought you had ALC 888 audio chip. The PC data for your audio chip indicates your audio chip is from ESS Technologies.

It's an old chip. I don't think you'll find any x64 drivers. Even ESS own site says
And their note refers to their NEW chips

IMHO I don't think you'll find an x64 driver. (and no point in chasing after realtek)

Your best solution will be a USB audio adapter

p.s. ALC 888 is a High Definition audio chip. Yours isn't hi def, it's AC'97 audio
My System SpecsSystem Spec
29 Dec 2013   #7
Durion

Windows 10 Home x64
 
 
Ac'97?

I looked online for ac 97 and found something... downloading now. Hopefully it works! if not, US adapter it is
My System SpecsSystem Spec
29 Dec 2013   #8
Durion

Windows 10 Home x64
 
 
Yayyyy!

Hi guys! I found a solution! reading around I the bios I found an entry called "enable on-board audio" and it was set to auto, so i decided to set it instead to enable. After booting to windows it started installing a driver for "PCI Device" I waited, it went to windows update downloaded it then installed, then another driver came up of "unidentified device" it installed then I got sound But the funny thing though is that in device manager Realtek High definition audio came up, but Multimedia audio controller stayed. Thx for ur help guys!


Attached Images
New x64 drivers for ALC 888-capture-done-.png 
My System SpecsSystem Spec
30 Dec 2013   #9
maxie

windows 7 home 64bit
 
 

Great news glad you got it sorted
My System SpecsSystem Spec
30 Dec 2013   #10
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Bravo!

You must have two sound cards on your machine. Only the ESS off-board audio appeared in your data until you enabled on-board sound as well.

Good work
My System SpecsSystem Spec
Reply

 New x64 drivers for ALC 888




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Should I update my stock Dell Drivers to Intel Drivers.
My Dell XPS L502x is 14 months old (i7, 8GB, 689GB HDD, HM77, Nvidia 540M GT). I have installed all latest drivers for my laptop from Dell website. But those are still more than 6 months old. When I use Intel Driver update utility, it shows new version of drivers available. Even my nvidia control...
Drivers
General Question - Windows Installed Drivers Vs OEM Website Drivers
Greetings, This is a general question for a fresh install of Windows on a computer. Let's say we just completed the installation and we open up Device Manager (we haven't used Windows Update yet). Device Manager shows us that there are - let's say "3" - devices that do not have drivers installed...
Drivers
Replacing SCSI storage drivers with IDE or SATA drivers
Having issues with RAID0 array being detected by Windows7 Ultimate x64 as SCSI. Apparently these drivers are the 'default' drivers that install when the RAID array is initialized. There is no option at this point to install other drivers instead. Using DeviceManager, there is an option to...
Drivers
Base System Device drivers error - unable to find drivers
Hi there, I have an HP Pavilion DV7 2185dx laptop running a freshly installed windows 7 upgrade from windows Vista. Ever since the upgrade my CPU is constantly running at 98-100% all the time meaning I cannot do anything on my PC. After researching a bit online it could possibly be the driver...
Drivers
display drivers stop responding on ati 5870 10.11 drivers
Hello all! I'll try to explain my problem. Last week I tried to update my ati 5870 drivers with the latest 10.11. I had 10.9 so far so good. My problem is that with these drivers I got this message from windows : display drivers have stop responding and they've been recoveres (or something...
Graphic Cards
NVIDIA drivers - Vista drivers or 7 drivers?
Which version should I use for the NVIDIA drivers, the Vista version or the 7 version?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App