Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IDE Controller Driver Problems

26 Oct 2009   #1
rich101682

Windows 7
 
 
IDE Controller Driver Problems

Please forgive me if this is an obvious fix and I'm just not getting it. I searched all over the net to figure out this problem and I still can't find it.

I have a Gateway P-7811fx laptop. I did a fresh install of Windows 7 (64 bit) and now I can't seem to get my SD Card reader to work. I know that the laptop knows there's a SD card in there because when I plug it in, it pops up as "O2Micro SD Disk Device" under Disk Drives in Device Manager. But for some reason, it won't show the SD card in My Computer.

The only problem I can see is that under Storage Controllers in the Device Manager, there's a yellow exclamation point next to "AILXT4UC IDE Controller" that I cannot seem to fix.

All of my drivers seem to be updated and I cannot get any answers from Troubleshooting the problem. Anyone know what I'm experiencing and how to fix it?


My System SpecsSystem Spec
.
26 Oct 2009   #2
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Have you tried to click on that device and let windows try and update the driver?
My System SpecsSystem Spec
26 Oct 2009   #3
rich101682

Windows 7
 
 

Yeah I tried that and Windows said it couldn't update the driver.
My System SpecsSystem Spec
.

26 Oct 2009   #4
rich101682

Windows 7
 
 

Do these screenshots help?


Attached Images
  
My System SpecsSystem Spec
26 Oct 2009   #5
whest

XP, Vista, W7 64bit Home Premium
 
 

Gateway Support Drivers & Downloads

There is a media card reader driver there - try installing - its maybe the correct driver. They are vista drivers if they wont install because of a OS mismatch error do the following -

To install a driver OR program in compatibility mode - right click the setup.exe file - click properties - click compatibility - check run in compatibility with vista/xp etc - check run as administrator - leave the rest blank. Start setup.exe and install.
My System SpecsSystem Spec
26 Oct 2009   #6
rich101682

Windows 7
 
 

I read that on another post. Tried that and it didn't work either.
My System SpecsSystem Spec
26 Oct 2009   #7
whest

XP, Vista, W7 64bit Home Premium
 
 

My System SpecsSystem Spec
26 Oct 2009   #8
rich101682

Windows 7
 
 

How do I know whether any of my hardware is Texas Instruments?
My System SpecsSystem Spec
26 Oct 2009   #9
whest

XP, Vista, W7 64bit Home Premium
 
 

YOUR laptop would probably have other texas instrument controllers in device manager - another suggestion would be to try, and search your recovery disc - right click on device in device manager click update driver then let it search your dvd drive - it would be on it, but whether it will find it I dont know - you could email gateway support - you have enough info, and see if they have somewhere you can download it - try to avoid for w7 though as they may try to brush you off using that as an excuse.
My System SpecsSystem Spec
27 Oct 2009   #10
whest

XP, Vista, W7 64bit Home Premium
 
 

I noticed there was the intel matrix storage manager driver on the gateway site - if you have raid or AHCI enabled in the bios it needs to be installed and could be the cause of the problem. Check under sata configuration in the bios to see what the settings is - if its there - if it says sata as IDE you dont need to worry about installing the matrix driver if its says AHCI or Raid you do. I wouldnt think you have raid but AHCI is a strong possibility. Its an enhanced storage controller, but wouldnt hold my hopes on this one - sort of worth mentioning, as you might need to install it in any case, as its listed, and applicable to your laptop.
My System SpecsSystem Spec
Reply

 IDE Controller Driver Problems




Thread Tools




Similar help and support threads
Thread Forum
Missing some driver: SM Bus Controller, PCI Device, Network Controller
Hey I just recently switch my hard drive ( 320gb HDD 5400 rpm ) to a Samsung 840 EVO 250 Gb. I'm currently missing some files and I can't seem to find those drivers help? Btw it's a laptop here the model if you wanted to know : Asus X401A Network Controller ...
Drivers
USB and SM Controller Problems
In my Device Management, there is a yellow warning about these 2 devices, I don't know what could have caused this or nothing, if a driver update is needed or anything and have a feeling it may be a cause of the slow performance issues that has been happing recently. I tried Updating Driver...
Hardware & Devices
SM bus Controller driver problems with samsung
Basically i have a samsung NP305v5a AD04x model and i upgraded from windows 7 home basic premium to proffesional but i had to install some drivers again. the only driver i cant find is the driver for my SM Bus controller. I have went to the samsung website but nothing is available (unless i have...
Drivers
network controller driver accidently removed can't find driver
So the story goes like this I like updating drivers and i thought i found a new chipset. I was wrong I was uninstalling devices i didn't have. i restarted my computer and i couldn't get on the web network controller missing and unknown device which is under adapters. i have a m2n-e sli mobo with...
Drivers
USB controller problems
Ok, this annoying message appeared recently: "Your USB mass storage device can perform faster if it is plugged into a hi-speed port". It seems like all transfers to my external drives have been capped to less than 1 MB/s. I have a Dell Studio 17 laptop, running Win 7 RC1. Also, when checking device...
Hardware & Devices
Network Controller Driver–not Adapter Driver
A few days ago I did a clean install of Windows 7. Now I have a problem. The computer is a wireless 'client'. It has a Realtek RTL8168D/8111D PCI-E Gigabit Ethernet NIC (NDIS 6.20). When I bring up Device Manager and expand 'Network adapters' I see "Realtek PCIe GBE Family Controller". When I...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App