Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing drivers


24 Feb 2014   #1
debdedoos

WINDOWS 7 HOME PREMIUM 32 bit
 
 
Missing drivers

I have just put a new hard drive in my laptop and re installed windows 7 32 bit, I cannot get it to find the router and when I troubleshooted it said that the network controller driver and the pci simple communications controller driver were missing, I downloaded the network drivers from intel onto a usb from my other computer and tried to instal it but it came up with a message that said there were no intel adapters present in the computer at all. Please help and tell me exactly what I need. The laptop is a Toshiba L500 Satellite, intel core (R) (TM) i3 cpu 2.13gh


My System SpecsSystem Spec
.

24 Feb 2014   #2
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Can you be more specific on the model?
Satellite L500-ST2521
Satellite L500-ST2522
Satellite L500-ST5505
Satellite L500D-ST2531
Satellite L500D-ST2532
Satellite L500D-ST5501
Satellite L500D-ST5506
Satellite L500D-ST5600

Thanks, members need that information to help locate the correct drivers.
My System SpecsSystem Spec
24 Feb 2014   #3
debdedoos

WINDOWS 7 HOME PREMIUM 32 bit
 
 

there is only a number on the back that says model PSLS9A-01U012
My System SpecsSystem Spec
.


25 Feb 2014   #4
ComputerGeek

Desk 1: Win 7 Pro 32bit; Desk 2: Server 2012 R2 & Win 8.1 64bit
 
 

My System SpecsSystem Spec
25 Feb 2014   #5
debdedoos

WINDOWS 7 HOME PREMIUM 32 bit
 
 

Hi again,I down loaded those drivers and it is still saying there are no network connections, and no intel adapters on this computer
My System SpecsSystem Spec
25 Feb 2014   #6
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Found your machine (I think), and there are a few possible drivers

Please follow this tutorial to update your system specs on SF: System Info - See Your System Specs
  • In the System Manufacturer/Model Number field, manually type Desktop or Laptop adding it to the information already in the field.
  • Specify Custom Build as the manufacturer if it is not an OEM machine.
  • The tool does not fill in this information but it is very important if someone has to research drivers or hardware for your machine.
Log on to Sevenforums (SF) and let the tool fill in you System specs on your SF profile.
To see what is in your System Specs -Click here.

It's a simple process and it makes that information readily available on your posts. You don't have to retype the information in any thread.

Click on My System Specs in the lower left of this post to see what is presented about my machine.

Full instructions are in the tutorial.


Toshiba download site: Toshiba satellite l500 [/psls9a-01u012] downloads

Thanks
My System SpecsSystem Spec
25 Feb 2014   #7
debdedoos

WINDOWS 7 HOME PREMIUM 32 bit
 
 

I put all the specs in manually from another computer as I cannot connect to the internet, how do I post them? there was only an option to save the changes.
My System SpecsSystem Spec
25 Feb 2014   #8
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Good question, there must be a file - let me look.

I'm looking for the Ethernet LAN driver, it's easier. Once you get the correct driver, you can use Windows Update to get any other missing drivers. Do you have an Ethernet cable and can you connect the machine to the Cable modem or router?

Thanks, I'm just about to hit the sack. If you don't want to wait, you could examine the information in the local system specs or look in Device manager to try and determine the device and down;load the correct driver.

All are Win7 32 bit drivers - it looks as though you have a Realtek NIC according to the page I found, the system specs or Device manager might verify that.

Wireless is a different story, but if your get wired up, WU will help you find the correct drivers.

Realtek LAN Driver Wired LAN | 7.003.0522.2009 | 7.26 MB


Realtek Wireless LAN Driver (for Realtek model only) Wireless LAN | 2.00.0006 | 20.39 MB
Atheros Wireless LAN Driver (for Atheros model only) Wireless LAN | 9.2.0.500.0.s3264 | 27.1 M
Intel Wireless LAN Driver (For Supported Model Only) Wireless LAN | 12.4.1.11.0.s32 | 4.43 MB
My System SpecsSystem Spec
25 Feb 2014   #9
debdedoos

WINDOWS 7 HOME PREMIUM 32 bit
 
 

I connected the laptop straight through the router and got an internet connection and have managed to fix all the problems, thankyou so much for all your help! you all do an amazing job in this forum.
My System SpecsSystem Spec
25 Feb 2014   #10
Slartybart

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

You're most welcome.

Glad you got it sorted and thank you for marking the thread solved.

Bill
.
My System SpecsSystem Spec
Reply

 Missing drivers




Thread Tools



Similar help and support threads for2: Missing drivers
Thread Forum
I have a ton of missing drivers? Drivers
Missing USB Drivers??? Drivers
Missing CD/DVD Drivers Installation & Setup
Missing drivers Drivers
Drivers missing and not available! Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App