Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New install of Win 7 Home Prem. 64, driver ?'s

19 Mar 2014   #11
JoeN

win. 7 64 bit Home Premium
 
 

Hi Maxie

I really do appreciate your help here, I am still trying to get a grip on what is going on in Device Mgr. with "chipset drivers" -

Am I correct in that the items listed under "system devices" that have the "X58" designation are the only "chipset drivers" all other Intel ICH10 items are as you said " management engine " items ?


Joe


My System SpecsSystem Spec
.
19 Mar 2014   #12
maxie

windows 7 home 64bit
 
 

Hi Joe ... That is correct your Computer should be working perfectly ..
My System SpecsSystem Spec
19 Mar 2014   #13
JoeN

win. 7 64 bit Home Premium
 
 

Thanks Maxie

I decided to leave the LAN driver as is, seeing as it is already a Realtek driver, I updated the Audio driver from the default M$ one to Realtek w/Realtek Control Panel - no problems there.

I still have to give the Chipset drivers some attention, everything seems to be working fine, but I don't like seeing under the "general tab" "no driver installed" then for the same driver under the "driver" tab it shows a Intel or M$ driver is installed, I see this scenario for both the "chipset drivers -x58" and the "management engine" items - stilled confused on this

If you have any thoughts on correcting this - I will try them

Thanks again for all your help

Joe
My System SpecsSystem Spec
.

19 Mar 2014   #14
JoeN

win. 7 64 bit Home Premium
 
 

Update:

I found this information here on the Win. 7 forums - followed it exactly and now ALL the Intel Drivers in Device Mgr. - System Devices read Intel Drivers - How to Install Intel INF Drivers | Windows 7 Forums


Thanks again Maxie for all your help -

The more I get into this OS the more ?'s I'll have - GREAT FORUM

Joe
My System SpecsSystem Spec
20 Mar 2014   #15
maxie

windows 7 home 64bit
 
 

Hi Joe ... If you have any more questions i will do my best to answer them .. Your Computer is working great just remember if it is not broke does not need fixing ...
My System SpecsSystem Spec
20 Mar 2014   #16
user31

Windows 7 Ultimate x64
 
 

If I'm missing a driver after a clean install, first thing I do is check the device properties. Then, Google any missing drivers. Another thing you can do is update them from the update panel. Hopefully all is good .
My System SpecsSystem Spec
21 Mar 2014   #17
JoeN

win. 7 64 bit Home Premium
 
 

Thank you both for the help


Joe
My System SpecsSystem Spec
21 Mar 2014   #18
maxie

windows 7 home 64bit
 
 

Most welcome Joe
My System SpecsSystem Spec
Reply

 New install of Win 7 Home Prem. 64, driver ?'s




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Install sys image Win7 home prem 64bit in Dell Inspiron 5748
I have a Dell Inspiron 5721 running Win7 home premium 64bit SP1 - 3rd Gen i7-3537U proc I'm trying to save a System Image and transfer it to a Dell Inspiron 5748 that is running Win 8.1 - 4th Gen i7-4510U proc. The 5748 had Win7 HP64bit SP1 loaded on it, but I lost it due to an...
Installation & Setup
BSOD - Fresh Install of Win7 Home Prem 64bit - While playing cod4
Fresh install of Windows 7 Home Premium x64, I have 5 other hard drives, the only thing I did was reinstalled win7 on my SSD (my main drive) due to I have receiving to many BSODS before for things I didn't understand so I figured might as well reinstall all seemed well until I was: playing cod4,...
BSOD Help and Support
New Home Prem. install. - constantly crashing
Just installed WIN7HP on new HDD on PC#2. Keeps crashing. first time was during initializing. WELCOME > preparing desktop > start to show w7 desktop > crash Reinstalled from scratch. now > open browser > crashes within a minute (both FF & IE)
Installation & Setup
Need network driver for HP g6-2250sa lap top using Windows 7 Home Prem
I have a HP g6-2250sa 960/6/750 Laptop, it came with Windows 8 64 bit but I didn't like it so I installed Windows 7 Home premium 64 bit on it. I completely took out windows 8 (deleted all partitions and created new ones). But now I have no network drivers so there for can not connect to any...
Drivers
Laptop Install stalls part way. W7 home prem 32bit
Soo its an Acer travelmate 4000 laptop, 1.6Ghz, 2gig ram, clean hard drive with two partitions , primary is 30 gig , secondary 120 gig. Windows 7 home prem OEM 32 bit It gets through the first part of the install (up to the first restart) then goes on to the screen shown in part 9 of the...
Installation & Setup
New build, fresh install of Win7 home prem. Issues
Ok, so I built a new PC lastnight and proceeded to install what I thought to be Windows 7 Home Premium 64bit. After the installation was done, I checked system properties and it's showing as a 32bit OS. Here are my system specs: AMD Phenom II x6 1055T Thuban 2.8Ghz Processor 4Gb of G.Skill...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App