Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New install of Win 7 Home Prem. 64, driver ?'s

17 Mar 2014   #1
JoeN

win. 7 64 bit Home Premium
 
 
New install of Win 7 Home Prem. 64, driver ?'s

The install went fine, from XP Pro 32 to Win. 7 64 Home Prem.. I have noticed that MOST drivers (Device Mgr.) are from M$, they are all working fine, NO problems.

I have a Asus P6T motherboard which came w/an Intel X58 / ICH10R chipset, onboard LAN Realtek 8111c and onboard Audio Realtek ACL1200.

In Device Mgr.:
The onboard Audio shows as - High Definition Audio Device, M$ Driver from 2010

The onboard LAN shows as - Realtek PCIe GBE Family Controller, Realtek Driver, ver. 7.46.610.2011

The Intel Chipset shows up under "System Devices" along with many other Intel(R) items, all have M$ drivers from 2006, ver. 6.1.7601.17514

Win 7 seems to work differently than XP pro and I am still getting used to Win 7, even though everything works I would like to install a Realtek driver for the Audio, updated Intel Chipset drivers and possibly updated LAN driver, if possible.

I have found drivers from the Realtek site for Win.7 64 audio and LAN, also from the ASUS site.

The Intel Chipset driver is another story, not sure if I am looking in the right place on the Intel site for the X58

I know "if it ain't broke - don't fix it" this is a computer, you have to "mess" with it :-)

Some help will be appreciated

Joe


My System SpecsSystem Spec
.
17 Mar 2014   #2
maxie

windows 7 home 64bit
 
 

Hi Joe ... Try the Driver in the Link below ...

https://downloadcenter.intel.com/Det...ipset&lang=eng
My System SpecsSystem Spec
17 Mar 2014   #3
JoeN

win. 7 64 bit Home Premium
 
 

Thanks Maxie, I downloaded the .exe file - can I just run the file or is there more to it ??? Joe
My System SpecsSystem Spec
.

17 Mar 2014   #4
maxie

windows 7 home 64bit
 
 

You should be able to just Run it as normal
My System SpecsSystem Spec
17 Mar 2014   #5
JoeN

win. 7 64 bit Home Premium
 
 

Please bare with me here, I am trying to grasp what will happen with this update -

If I just "run" the .exe file will ALL the Intel drivers in "system devices" be changed and updated to Intel ?

or

Do I have to go to the Asus site for my MB Chipset driver 1st, save that driver and use "device mgr" to update all 17 Intel entries, and would I have to do each entry or could I delete all 17, reboot and then install the Asus chipset driver, reboot and then use the link that Maxie referred to ?

I know when I did this with my XP OS I already had the Intel drivers from the beginning

These 2 attachments may help

Thanks again


Joe


Attached Thumbnails
-device-mgr..gif   -intel-driver.gif  
My System SpecsSystem Spec
17 Mar 2014   #6
maxie

windows 7 home 64bit
 
 

Hi there .. Just run the exe file it will update the Chipset Drivers .. All the Devices you have listed are controlled by the Chipset Driver ...
My System SpecsSystem Spec
19 Mar 2014   #7
JoeN

win. 7 64 bit Home Premium
 
 

OK, I ran the .exe file from Intel, now in Device Mgr. some of the items I have circled in the above attachment show as Intel drivers and some do not (still M$), also some items under "general" tab show "no drivers installed"

Device Mgr. is clean - nothing red or yellow showing

Could you explain what is going on ?

Sorry if I am being a PITA

Joe
My System SpecsSystem Spec
19 Mar 2014   #8
maxie

windows 7 home 64bit
 
 

Hi Joe .. I am not sure what you mean .. Please post a screenshot of the problem
My System SpecsSystem Spec
19 Mar 2014   #9
JoeN

win. 7 64 bit Home Premium
 
 

Here are some screenshots, random, from the 17 items circled in device mgr.


Attached Thumbnails
-untitled-2.gif   -untitled-3.gif   -untitled.gif  
My System SpecsSystem Spec
19 Mar 2014   #10
maxie

windows 7 home 64bit
 
 

Hi again .. Those Devices are linked to the intel management engine .. It is different to Chipset Driver .. There is no point really trying to run an update as it will not improve any thing
My System SpecsSystem Spec
Reply

 New install of Win 7 Home Prem. 64, driver ?'s




Thread Tools




Similar help and support threads
Thread Forum
Install sys image Win7 home prem 64bit in Dell Inspiron 5748
I have a Dell Inspiron 5721 running Win7 home premium 64bit SP1 - 3rd Gen i7-3537U proc I'm trying to save a System Image and transfer it to a Dell Inspiron 5748 that is running Win 8.1 - 4th Gen i7-4510U proc. The 5748 had Win7 HP64bit SP1 loaded on it, but I lost it due to an...
Installation & Setup
BSOD - Fresh Install of Win7 Home Prem 64bit - While playing cod4
Fresh install of Windows 7 Home Premium x64, I have 5 other hard drives, the only thing I did was reinstalled win7 on my SSD (my main drive) due to I have receiving to many BSODS before for things I didn't understand so I figured might as well reinstall all seemed well until I was: playing cod4,...
BSOD Help and Support
New Home Prem. install. - constantly crashing
Just installed WIN7HP on new HDD on PC#2. Keeps crashing. first time was during initializing. WELCOME > preparing desktop > start to show w7 desktop > crash Reinstalled from scratch. now > open browser > crashes within a minute (both FF & IE)
Installation & Setup
Need network driver for HP g6-2250sa lap top using Windows 7 Home Prem
I have a HP g6-2250sa 960/6/750 Laptop, it came with Windows 8 64 bit but I didn't like it so I installed Windows 7 Home premium 64 bit on it. I completely took out windows 8 (deleted all partitions and created new ones). But now I have no network drivers so there for can not connect to any...
Drivers
Laptop Install stalls part way. W7 home prem 32bit
Soo its an Acer travelmate 4000 laptop, 1.6Ghz, 2gig ram, clean hard drive with two partitions , primary is 30 gig , secondary 120 gig. Windows 7 home prem OEM 32 bit It gets through the first part of the install (up to the first restart) then goes on to the screen shown in part 9 of the...
Installation & Setup
New build, fresh install of Win7 home prem. Issues
Ok, so I built a new PC lastnight and proceeded to install what I thought to be Windows 7 Home Premium 64bit. After the installation was done, I checked system properties and it's showing as a 32bit OS. Here are my system specs: AMD Phenom II x6 1055T Thuban 2.8Ghz Processor 4Gb of G.Skill...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App