Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Canon LiDE 50 Scanner won't install


27 Oct 2009   #1

Windows 7 64bit
 
 
Canon LiDE 50 Scanner won't install

I have just installed Windows 7 64 bit dual booting with Windows Vista 32 bit.

I can't get drivers for my Canon CanoScan LiDE 50 Scanner to install on Windows 7 (works fine on Vista)

See on the Canon Website that they are not showing any Windows 7 drivers for this scanner which I can't get to work.

Tried LiDE 60 drivers but could not get these to install with my scanner.

Is there anything I can do to get this working. Or do I have to reboot Vista if I want to continue using this scanner?


My System SpecsSystem Spec
.

27 Oct 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by arrow View Post
I have just installed Windows 7 64 bit dual booting with Windows Vista 32 bit.

I can't get drivers for my Canon CanoScan LiDE 50 Scanner to install on Windows 7 (works fine on Vista)

See on the Canon Website that they are not showing any Windows 7 drivers for this scanner which I can't get to work.

Tried LiDE 60 drivers but could not get these to install with my scanner.

Is there anything I can do to get this working. Or do I have to reboot Vista if I want to continue using this scanner?
win 7 can run vista drivers. They just need to be installed in the compatibility mode. get the relevant driver, right click>properties>compatibility mode. set to XP and install.

Goodluck and let us know if you need help

Ken
My System SpecsSystem Spec
27 Oct 2009   #3

Windows 7 Ultimate x64
 
 

Looks really bad, there is no 64 bit driver. But you can use it in XP Mode or in a VM.
My System SpecsSystem Spec
.


27 Oct 2009   #4

Windows 7 64bit
 
 

Do you mean download the driver from Canon site lide50vst7133a_xpen the right mouse click and Restore Previous Version.

Still does not work. When I look in Control Panel against CanoScan "The drivers for this device are not installed"
My System SpecsSystem Spec
27 Oct 2009   #5

Windows 7 Ultimate x64
 
 

You cannot install a 32 bit driver in a 64 bit OS! Never!
My System SpecsSystem Spec
27 Oct 2009   #6

Windows 7 64bit
 
 

So I wont be able to use it on Windows 7 64 bit?
My System SpecsSystem Spec
27 Oct 2009   #7

win7 ultimate / virtual box
 
 

Quote   Quote: Originally Posted by arrow View Post
So I wont be able to use it on Windows 7 64 bit?
you can only use 64 bit drivers ........

the drivers for my lide 600f where only just posted on canons site on 19/10/09 so let's hope it's just a game of catchup at the moment and your drivers might be posted sometime soon

It's not a good sign however that they don't offer 64 bit drivers in any flavour
My System SpecsSystem Spec
27 Oct 2009   #8

Windows 7 Ultimate
 
 

A modified set of LiDE 60 drivers will do the trick for the LiDE 50.
http://www.webwhitenoise.com/item/20...50-x64-drivers
My System SpecsSystem Spec
27 Oct 2009   #9
aem

Windows 7 Ultimate 64Bit
 
 

If the website don't have Windows 7 drives and nothing else works. Ring them up and tell them to get with it.
My System SpecsSystem Spec
28 Oct 2009   #10

Windows 7 Ultimate x64
 
 

My System SpecsSystem Spec
Reply

 Canon LiDE 50 Scanner won't install




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:04 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33