Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with my card driver and some USB drivers, unable to fix!

25 Apr 2014   #11
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

It's the same as my 'problem', the device shows as a portable device but whenever I plug a flash drive in it works fine. You can ignore the portable devices for your cards as they will work fine, if you can put up with the annoyance of them showing like that in Device Manager that is. It won't stop anything working properly. I've included a screenshot of my Device Manager below so you can see the same problem.

As for your phone, I'm a bit stumped. What make/model do you have? And what happens when you plug it in?

Problems with my card driver and some USB drivers, unable to fix!-capture.jpg




My System SpecsSystem Spec
.
26 Apr 2014   #12
sundevilrach

Windows 7
 
 

It happens with both phones I have handy - The Sony Xperia Z1 shows up under portable devices with the exclamation mark as you have there too. When I plug it in a prompt comes up saying your Sony Xperia has been detected launch the PC companion (their version of Itunes) but it won't detect the phone at all. All their assistance says it is a driver issue and to uninstall and reinstall but it won't work.

However my PC also won't detect my old Iphone through itunes and it comes up with the exclamation mark too but this time under USB's.

I am out the house most of the day as have a visitor but I will try and get shots of what is happening. It seems strange it is happening with both!

Thanks so much for your help so far.
My System SpecsSystem Spec
26 Apr 2014   #13
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

When I was using an Xperia T I removed the PC Companion virtually straight away, I hated it. I used Windows Explorer to navigate the phone and copy and move files. Does the phone show up in Computer when you connect it?
My System SpecsSystem Spec
.

27 Apr 2014   #14
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

If I might also try to assist.

Disconnect any USB Mass Storage device (flash, USB CD/DVD, USB Hard Disk). OK to leave in your speakers, web cam, wifi booster (they're USB but not USB storage). Disconnect allphones.
> In post #4, there were 4 Portable devices. How many right now?
> For each portable device still there with a yellow icon, right click Properties->Details. Use the pull down tab to select Hardware IDs. Copy/paste the IDs you see into your next post

/* EDIT */
One more thing, for each portable still there with a yellow icon, right click Properties. Look for the device status code under Device Status? If yes, is it code=10? If not, what code #

/* EDIT2 */
Insert a memory card, does one of the Portable devices w/yellow icon go away? Does anything different appear in its place? If the device still shows an error, click and open Computer. Does it display a new device with a drive letter assigned? If no, go to Disk Management, look at the disks
> Are all the disks formatted? Give a screen shot
My System SpecsSystem Spec
27 Apr 2014   #15
sundevilrach

Windows 7
 
 

Quote   Quote: Originally Posted by Boozad View Post
When I was using an Xperia T I removed the PC Companion virtually straight away, I hated it. I used Windows Explorer to navigate the phone and copy and move files. Does the phone show up in Computer when you connect it?
Yes it shows up in Computer but with the yellow exclamation mark next to it.

Today I tried to use a USB stick (different to the one that worked yesterday) and it won't read hat USB. When I tried to install the driver for it through device manage it does the same as it does with the phone, it detects a driver, goes to install it and then says 'access denied'!

Both are classified as mass storage devices - could this be part of the problem?
My System SpecsSystem Spec
27 Apr 2014   #16
sundevilrach

Windows 7
 
 

[QUOTE=ComputerGeek;2760235]If I might also try to assist.

Disconnect any USB Mass Storage device (flash, USB CD/DVD, USB Hard Disk). OK to leave in your speakers, web cam, wifi booster (they're USB but USB storage). Disconnect allphones.
> In post #4, there were 4 Portable devices. How many right now?

There are still 4 devices. I have nothing plugged in other than my speakers and wifi booster, nothing at all.

Still says 4!!
My System SpecsSystem Spec
27 Apr 2014   #17
sundevilrach

Windows 7
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
If I might also try to assist.

> For each portable device still there with a yellow icon, right click Properties->Details. Use the pull down tab to select Hardware IDs. Copy/paste the IDs you see into your next post

Ok bizarely none of them have any description in the Hardware Id's - it is just blank.

This is what it looks like

Problems with my card driver and some USB drivers, unable to fix!-capture3.png


Problems with my card driver and some USB drivers, unable to fix!-capture4.png


My System SpecsSystem Spec
27 Apr 2014   #18
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Re: Access denied

As luck would have it, i was just recently in a thread with a user who had a similar "access denied" problem when connecting on USB Mass Storage devices. Another member suggested it could be malware. His advice worked! both for the original poster and a couple others too who posted to say it also worked for them.!

Try the scans posted HERE Windows 7: "Device driver software was not successfully installed"

Then try your flash drive again. And we'll take it from there
My System SpecsSystem Spec
27 Apr 2014   #19
sundevilrach

Windows 7
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
If I might also try to assist.

/* EDIT */
One more thing, for each portable still there with a yellow icon, right click Properties. Look for the device status code under Device Status? If yes, is it code=10? If not, what code #

/* EDIT2 */
Insert a memory card, does one of the Portable devices w/yellow icon go away? Does anything different appear in its place? If the device still shows an error, click and open Computer. Does it display a new device with a drive letter assigned? If no, go to Disk Management, look at the disks
> Are all the disks formatted? Give a screen shot
sorry to have broken it down so much with my replies but easier to keep track of what you suggested.

Ok for the device status code number it is 31 for them all as per my last screen shot - all four of them are 31 and when I connect my phone it is also code 31 but it has details under the hardware ID


Problems with my card driver and some USB drivers, unable to fix!-capture5.png


For Edit 2 when I insert the memory card, nothing changes and all the icons are still with exclamation marks. It shows under my Computer as Disc I. Works fine from there.


My System SpecsSystem Spec
27 Apr 2014   #20
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

OK. Good info.

1. We posted about the same time. So, in case you missed it, note my last post and run the malware scans listed. I think your flash drive issue may be separate from 4 devices you keep seeing. But in any case, run the scans, report back on both problems and can go from there

2. Also, tell me exact make/model of your computer.
My System SpecsSystem Spec
Reply

 Problems with my card driver and some USB drivers, unable to fix!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Problems installing Realtek RTL8188CE Card Reader Drivers
Hi, I have recently re-installed windows 7, and lost my Ethernet and wifi drivers. I have successfully installed my Ethernet driver and it works with my media server, but the driver I downloaded for my laptop from Realtek RTL8188CE 802.11b/g/n Wireless LAN Driver for Microsoft Windows | HP® Support...
Drivers
Unable to install new video card driver on W7 64 bit
So My new W7 Home Premium 64 bit PC doesnt seem to want to sleep. I'm away to work for a day at a time and when I get home the PC is up and running. I found this article:Windows 7 will not sleep or not sleeping which indicates to update driver, particularly the video card driver. I go to the...
Drivers
Unable to update my ATI Video Card Driver
EVERY TIME THERE IS AN UPDATE FOR A NEW VIDEO CARD DRIVER FROM THE AMD.COM WEBSITE. I TRY TO DOWNLOAD IT AND NOTHING HAPPENS. MY LAPTOP HAS BEEN SENT BACK FOR REPAIR TWICE TO ASUS FOR THE SAME ISSUE. THE SECOND TIME MY LAPTOP WAS SENT BACK FOR REPAIR THE MOTHERBOARD WAS REPLACED, BUT I AM STILL...
Drivers
Unable to locate Nvidia GFX Card Driver
Hello everyone, This evening I have been making some modifications to several computers. I have just installed a new graphics card into my computer, however I'm not sure if it's working properly. It could be the driver, however "Driver Genius" claims that it is up to date. I open Speccy and it...
Drivers
Problems with Sound card Driver.
Hi all! :-) Im currently running the Windows 7 RTM, and im having a little problem with my sound driver! it keeps installing a standard driver that comes with W7, and i keep getting this message "This device cannot start. (Code 10)" I have managed to download the latest driver for it, but...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App