Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI card works fine in Win7 Ult RC, not in Win7 Prof

28 Oct 2009   #1
jrem

windows 7 professional
 
 
ATI card works fine in Win7 Ult RC, not in Win7 Prof

I've been using the Windows 7 Ultimate release candidate as an evaluation copy for a while now with no problems. I have an ATI radeon mobility X1600 graphics card in my laptop and I'm using an external monitor through my laptop's DVI port. I bought a product key for Windows 7 professional and therefore had to reinstall that version because I'm using Ultimate as the evaluation copy. I have each version on its own partition so I can switch back and forth between the two.

The problem is that the newly installed windows professional copy will not recognize my ATI graphics card and I can't use my external monitor. It has the standard windows VGA adapter drivers installed. I've installed and run the ATI file i downloaded off their site, '9-9_beta_win7_32_dd_CC', and this accomplishes nothing. I looked in device manager on the working ultimate version and the card is installed correctly so I copied all of the drivers and files it says its using and then tried to update the driver for the standard windows VGA adapter and it says it can't find any better drivers than the current ones.

I remember initially having this same problem when I first installed the Win7 Ultimate RC several months ago but I have no clue how I was able to get it to work... Any ideas?


My System SpecsSystem Spec
.
28 Oct 2009   #2
kegobeer

Windows 7 Ultimate x64 SP1
 
 

There's a thread on the MS social forum about the X1600. Have you read it?

I need working driver for my ati radeon x1600 (windows 7)
My System SpecsSystem Spec
Reply

 ATI card works fine in Win7 Ult RC, not in Win7 Prof




Thread Tools




Similar help and support threads
Thread Forum
Win7 will not complete install on SSD - works fine on HDD
New gaming PC project: Asus Rampage Extreme IV I7 3960x 32gb Gskill 2133 mhz Sound Blaster Recon 3D 2 Corsair Force GT 60gb sata3 2 Corsair Force GT 120gb sata3 Win7 home 64bit w/anytime upgrade to Professional (Didn't know about the 16gb ram cap...) 9800 GTX video (ran outta money...)
Installation & Setup
No 32 bit browser does NOT work. 64 bit works fine. Win7-64
Hi All, Windows IExplored(9)-32 & Crome-32 do not work. (Error 105 (net::ERR_NAME_NOT_RESOLVED): Unable to resolve the server's DNS address.) IExplorer(9)-64 works just fine. I've been researching my issue for a few days now and have no success inplementing the recommended fixes I've found,...
Browsers & Mail
BSOD win7 prof 64bit
Hi I have windows 7 professional 64bit. It is reinstalled maybe 2 weeks ago. Bought a new drive (SSD) and some new RAM sticks a month or so ago but other then that I haven't made any hardware changes. I had some BSOD a few days ago and I have no idea why. Reinstalled the OS maybe 2 weeks ago...
BSOD Help and Support
Link me a PCI ATI card that works with Win7 64 and available on amazon
Could anyone please link me a PCI only (no express, no x1 or any of that) ATI card that works with Win7 64 and available on amazon.co.uk? Whenever i do searches for cards I keep getting pci-e instead of just pci and the pci cards dont seem to work too well with windows 7. Im not looking to speed...
Graphic Cards
Are my specs good enough for Win7 Prof 64bit?
I am going to do the student windows 7 upgrade from my current vista. I only have 2.5gb of ram right now and was wondering if I should upgrade to 32 or 64. I am probably going to be upgrading to 4gb of ram in the next month or so, but in the meantime would my system suffer from only having 2.5gb...
Installation & Setup
My LAN card in XP(fine), but win7(Not Detected)
my lan card is Realtek RT8029AS i have Win XP and Win 7 in my PC in xp, the driver detected automatically without install any driver, and works fine but when in Win 7, the driver is not detected and in "Device Manager" found Unknown device for Ethernet controller i can't find correct driver...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App