Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Problems: "Can't install driver, access denied"

08 Jun 2014   #1

windows 7 professional
 
 
USB Problems: "Can't install driver, access denied"

Okay so i recently bought myself a lovely new camera and i was eager to upload my pictures to the computer.

Upon installing (correctly) the software that came with the camera on CD, i plugged it in and ofcourse, my computer doesn't recognise it.

Its a Canon EOS 700D, and after googling things for a few hours i've came across the fact that canon doesn't communicate with windows 7 very well and there is NO specific drivers that i can download.

When i try to fix this problem by finding my camera in device manager and doing the automatic search for drvers, my computer appears to be downloading a driver and then i am met by that error message " Access denied"

So i accepted defeat and went to a local tech shop and reluctantly bought myself a SD card reader as i'd been told thats the easiest way to get my pictures across.

So i get home and plug it in and again, the same process takes place:

I plug it in, it tries to install the device and prompts me with that typical error saying that installation has failed. So i go to device manager, find my device and try the same thing again and it begins downloading a driver then gives me access denied.

I'm lost and frustrated and refuse to believe that BOTH my camera and SD card reader are at fault here, there MUST be a fix, but i am yet to find one on my own

Thanks in advance for any help.


My System SpecsSystem Spec
.

08 Jun 2014   #2

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8.1 Pro all 64bit
 
 

My System SpecsSystem Spec
15 Jun 2014   #3

windows 7 professional
 
 

hello thanks for your response. i did both of those and they came back clear with no problems at all. any other suggestions?
My System SpecsSystem Spec
.


15 Jun 2014   #4

W7 Pro x64 SP1 / W8.1 Pro x64
 
 

Can you elaborate on the 'Access Denied' message, or better still post a screenshot.

Use the Snipping Tool How to Use the Snipping Tool in Vista and upload the screenshot of the message. Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
15 Jun 2014   #5

windows 7 home 64bit
 
 

Hi there .. Read the Link below and follow the Instructions ..


FIX: Access is denied error while installing software on Windows 8 | 7
My System SpecsSystem Spec
15 Jun 2014   #6

windows 7 home 64bit
 
 

If the above Solution does not work try this one ...

"Access Denied" Message During USB Device Installation - National Instruments
My System SpecsSystem Spec
15 Jun 2014   #7

Desk 1: Win 7 Pro 32bit; Desk 2: Win 8.1 64b / Win 7 Pro 64b
 
 

I'll add one more possible solution as i've seen malware also cause Access Denied in a few different recent threads. Try running the 3 malware tools listed in post #2
USB not installing, not possible to uninstall code 28
My System SpecsSystem Spec
15 Jun 2014   #8

Windows 7 Professional x64 Sp1
 
 

You might also want to try this as well:

Try this:

USB drive or flash problems? How to cleanup and remove old USB storage drivers - TechSpot Forums


That should resolve any issues you have with usb devices unless it is hardware related.

EDIT: Make sure to run this bat file as an admin. Right click the bat file, run as administrator. Code used for the bat is on the website, and verified by me as being the same when editing the bat file.
My System SpecsSystem Spec
17 Jun 2014   #9

gauteng
 
 
solved

download avira from filehippo install it and than go to device manager right click on your driver than click on update driver software this helped me hope it helps you to
My System SpecsSystem Spec
3 Weeks Ago   #10

W8x64Pro
 
 
is the problem SOLVED ?

To whomever noted this "problem" as solved, are you sure the problem posted by the original poster is solved?
it does not appear to be solved to me.
I have the same 'access denied' problem with W8x62 and a USB2 HP printer driver. I have used about 8 hours of my time, and have yet to find a solution.....
My System SpecsSystem Spec
Reply

 USB Problems: "Can't install driver, access denied"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33