Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sony Vaio wont charge battery after clean windows 7 install

12 Sep 2014   #1
Daniel6792

64 bit Windows 7 Ultimate
 
 
Sony Vaio wont charge battery after clean windows 7 install

Hello all,

I hope someone here can help since i have searched the web far and wide for a solution but nothing seems to work.

Okay so i will tell you what led up to this problem:

I had a friend with an Sony Vaio SVF15A1C5E who from when he bought it had windows 8.1 installed. So he came to me with windows 7 and asked if i could make a clean install with. So i did without any big problems, he had it for like 2 months and everything worked. Then he installed some shitty programs on and it went slow on him. So we had to reinstall windows just to make sure everything was gone.
So i reinstalled Windows 7 without any problems every driver seemed to work but suddenly i noticed that the battery would not charge which i found odd, so i fumbled around with the AC but nothing seemed to work. Then i tried to reinstall the driver for the AC management that was on it. Still nothing seemed to change it. Then i thought okay, i will just reinstall windows 7 once again and it should work. But sure enough it did not work. So i am stuck now and i do not know what to do.

Notice this is a laptop only 1 year old and the battery cannot be taken out so i can try those options people have come up with on other threads. Also i tried to update bios but it says that bios is fully updated. SP1 is also installed.

I really hope someone can help here. Thanks.


My System SpecsSystem Spec
.
12 Sep 2014   #2
Daniel6792

64 bit Windows 7 Ultimate
 
 

Okay so now i have installed windows 8.1 on it and it does charge with it. So it is without a doubt a software problem. im still not having windows 8 on this laptop. since my friend wants windows 7 on it.
My System SpecsSystem Spec
12 Sep 2014   #3
maxie

windows 7 home 64bit
 
 

Hi Welcome to Seven Forums ... As you state this is Software related ..

You would need to compare the Drivers and Software from both OS ..

See what is missing from Windows 8 ..


Could it be the Vaio Power management ..
My System SpecsSystem Spec
.

12 Sep 2014   #4
Daniel6792

64 bit Windows 7 Ultimate
 
 

Hello Maxie, And thanks a lot.

I have all drivers downloaded from Sony's site also Power management, but nothing seems to be happening when i try to install it. I know most of sony's Drivers install in the background. ( there is no installer) Wifi drivers and so on install in the background but i can see that it actually have been installed.
Not with power management, it extracts and it seems after this that nothing happens.

do you know of any way to install these sony driver updates manually going around the "sony packaging manager"?? Maybe in this way i can install it since it won't install the other way.
My System SpecsSystem Spec
12 Sep 2014   #5
Daniel6792

64 bit Windows 7 Ultimate
 
 

Also note that Vaio Control Center only brings up System Information and Display on which i can't change anything.
Tried the last hour different options on how to install this Power Management utility but i have no luck. I really hope there is a way to install it manually. Its an exe file so i can't even extract the files inside it.
My System SpecsSystem Spec
12 Sep 2014   #6
maxie

windows 7 home 64bit
 
 

See if the Driver in the Link below works ..

Sony : SVF15A1C5E : VAIO Power Management


I am checking your Drivers and comparing them at the moment ...
My System SpecsSystem Spec
12 Sep 2014   #7
Daniel6792

64 bit Windows 7 Ultimate
 
 

Okay so i tried your link, and i got the installer up and everything. But it seemed to want to uninstall power management which indicates that it had been installed when i previous tried the original file. But i uninstalled the driver and tried yours. Restarted but i still get "consider change battery" And it still wont charge. This makes me wonder if it is somewhere else there is a problem?
im running out of options here. But thanks again for the help maxie.
My System SpecsSystem Spec
12 Sep 2014   #8
maxie

windows 7 home 64bit
 
 

It could be that the Battery needs replaced ..

Where did your friend get the Windows Disc from ? ...
My System SpecsSystem Spec
12 Sep 2014   #9
Daniel6792

64 bit Windows 7 Ultimate
 
 

Well since the battery works fine on windows 8.1 when i installed that i doubt it is the battery.
The windows dvd is legit if thats what you are wondering. And since we have installed it once before where it worked fine i am totally lost here.
My System SpecsSystem Spec
12 Sep 2014   #10
maxie

windows 7 home 64bit
 
 

A year is quite a long time for a Battery .. But i do agree with you if it charges in Windows 8..


Should also do in Windows 7 ..


I will continue to check the Drivers and get back to you as soon as i can ..
My System SpecsSystem Spec
Reply

 Sony Vaio wont charge battery after clean windows 7 install




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
HELP Windows 7 clean install on Sony Vaio laptop w/o recovery discs
I hope this is the correct Forum subsection to post this. So I made a mistake while taking on a friend's problematic sony vaio laptop. They were wanting to install a newly purchased Kaspersky av, but after uninstalling the old version of Kaspersky there was a problem with an unresponsive usb...
Backup and Restore
Clean Install on my Sony VAIO Laptop
I noted earlier that gregrocker mentioned tech savy members tend to do clean installs of their systems. I am having some difficulty doing a clean install of my Sony VAIO due to a backlit keyboard issue and was wondering if someone might be able to help. I tried to do a clean install when I...
Installation & Setup
After Clean Install: Battery Charge Issues
Hello! I recently did a clean install of Win7 with help from advice I got here. Thanks again. Now, I seem to be having battery issues. I changed my settings to where I thought I had them before (made a power plan, chose lowest screen brightness for unplugged). But when I unplug the power...
General Discussion
Clean install Sony Vaio
I have done a clean install on my Sony VAIO (windows 7 Ultimate) and now my wireless doesn't work no more. In my device manager I had an Intel Chipset not working and managed to update the driver through the automated process. However, in the device manager I have two "other devices" not...
Drivers
Clean Install - VAIO Driver = Problem with battery
I made a clean install for VAIO (with a lot of problems) but everything seemed to be working fine and dandy. I was happy but then the screens' brighter and darker switches weren't working, so I decided to download some Utilities drivers from the Sony VAIO official website. I downloaded a couple...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App