Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 trying to install new usb3.0 hub

28 Nov 2014   #1
meebers

Windows 7 Professional X64 Service Pack 1
 
 
Win7 trying to install new usb3.0 hub

I got a 4 port usb 3.0 hub which plugs into a pci-e slot. Win7 reports back that the device did not install correctly. It came with no instruction manual, but did come with a mini cd with "drivers on it" The drivers are marked: JMB363 Driver, USB 3.0 NEC72020x Driver, USB 3.0 VL8xx Driver, WCH382 Driver
There is a chip on the board that is marked VL805-Q6 so I assumed that I would use the VL8xx driver. It is a 65 Mb file. I run it and nothing happens, just the blue spinning circle. I am just surprised that Win7 cannot find anything to load from that file or from an internet search.
Currently downloading a later driver version from VIA (via google search) but is taking forever,

Does this sound like a hardware problem? (tried two different pci-e slots)? Stuff like this reminds me of back in the win98 days.


My System SpecsSystem Spec
.
29 Nov 2014   #2
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by meebers View Post
I got a 4 port usb 3.0 hub which plugs into a pci-e slot. Win7 reports back that the device did not install correctly. It came with no instruction manual, but did come with a mini cd with "drivers on it" The drivers are marked: JMB363 Driver, USB 3.0 NEC72020x Driver, USB 3.0 VL8xx Driver, WCH382 Driver
There is a chip on the board that is marked VL805-Q6 so I assumed that I would use the VL8xx driver. It is a 65 Mb file. I run it and nothing happens, just the blue spinning circle. I am just surprised that Win7 cannot find anything to load from that file or from an internet search.
Currently downloading a later driver version from VIA (via google search) but is taking forever,

Does this sound like a hardware problem? (tried two different pci-e slots)? Stuff like this reminds me of back in the win98 days.
Can you please provide a screenshot of the "Hardware ID" of the unknown and probably "other device" as shown in Device Manager. Presumably the SETUP.EXE on your driver disk should have worked, but if we know the true Hardware ID of the device we might be able to find the right driver on the web.

Device Manager -> expand the "other device", right-click -> properties, select "details" tab -> click on Property dropdown and select the second item, "Hardware ID". Screenshot of the values shown.


NOTE: driver installs can typically either be (a) SETUP.EXE to be run, or (b) INF files down in a folder structure.

If you've got a driver CD included, chances are there is already an expanded folder structure on it. So if you right-click on the "other device" in Device Manager and select the "update driver automatically" option, and then navigate to the top-level folder on the CD and be sure you check the "look through sub-folders", Windows will automatically find the proper INF file wherever down-level it is in the folder structure, to match the "Hardware ID" it's looking for.

At least that's how it SHOULD run, if the drivers were distributed as already-expanded folders with the INF files.

Otherwise, if you run a SETUP.EXE and it's the wrong one, that might explain why the required hardware ID for that particular driver installer EXE is not found.

Anyway, please show us that Hardware ID first, and we can then take it from there.
My System SpecsSystem Spec
30 Nov 2014   #3
meebers

Windows 7 Professional X64 Service Pack 1
 
 

Thanks for your detailed response, appreciate it very much. The file I downloaded from VIA v4.7 seemed to make the hub install. Don't know if it was the correct file, but seems to work. I have attached the hardware id for review. (the four driver's that were on the supplied CD, 2 had their own setup up file, while the other 2 seemed to have a file similar to the one down loaded. 65mb) The CD driver for VL805 I decoded as v4.1


Attached Images
Win7 trying to install new usb3.0 hub-usb3hubid.jpg Win7 trying to install new usb3.0 hub-usb3hub2.jpg 
My System SpecsSystem Spec
.

30 Nov 2014   #4
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by meebers View Post
Thanks for your detailed response, appreciate it very much. The file I downloaded from VIA v4.7 seemed to make the hub install. Don't know if it was the correct file, but seems to work. I have attached the hardware id for review.
I believe you definitely got the correct driver package, from down at the bottom of this Via Download page.

Proof is in the pudding, so if your USB 3.0 ports are working correctly and you have no yellow exclamation marks on "other devices", then you should be home free.
My System SpecsSystem Spec
02 Dec 2014   #5
meebers

Windows 7 Professional X64 Service Pack 1
 
 

Is there a program that will allow me to monitor the new usb 3.0 speed (transfer rate) tx
My System SpecsSystem Spec
02 Dec 2014   #6
Wandering one

Win7 sp1 Pro 64bit / XP sp2 Pro (games only)
 
 

Quickest way unless you are trying to benchmark is to take a USB3 stick and copy a 1Gb or better file to it. After you clear the file use the same stick in a USB2 port with the same file. If all is correct the will be a big difference in time. Art.
My System SpecsSystem Spec
Reply

 Win7 trying to install new usb3.0 hub




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Reinstalled Win7 but now PC doesn't 'see' my USB3 stick
Hi. I built my PC a few months ago, all was working fine but, for reasons I won't bore you with, I had to reinstall Win7. The PC case has 2 USB3 slots (the blue ones) on the front but when I insert my USB3 memory stick, nothing happens. Yet the old card reader which I took off my old PC case (USB2)...
Hardware & Devices
ASUS M4A89GTD Pro/USB3: USB3 driver issues
Hello and thanks for any help you can provide. I have been having issues with my ASUS motherbord, I recently cleaned and re-formatted my main HDD, after doing this i re installed windows and all my normal drivers, motherboard, cpu, gpu, etc. But for some reason every time I install my USB3...
Drivers
USB3.0 Renesas Drivers for install
I do hope this is the right place to put this? I built an install for Win7 Ultimate so that I could have all my drivers and latest updates on it and I wanted to have the USB3.0 drivers loaded at start up BUT, the latest package, 2.1.39 only comes in an .EXE and I couldn't extract anything from...
Drivers
Installed USB3 driver on Win7 - monitor goes blank
I installed a Sabrent 2-port PCIX-USB3 "black" card into my HP P6228 desktop PC running Win7 Home Premium 64bit. I installed a driver from their web site, and everything continued to work OK, except the USB3 appeared to run only a bit faster than USB2. I opened a problem case with Sabrent and they...
Drivers
CMOS Checksum Error Defaults Loaded: Post Transcend TS-USB3 Install
Hi there, I was hoping someone may be able to shed some light on this as it's got me completely stumped, and pretty down at the same time if the truth be told. I'll outline the problem below although the title of the thread may actually be slightly misleading. My system is as follows: ASUS...
Hardware & Devices
USB3 install fail: feature transfer error: 2
I tried installing my NEC USB3 3.0 Host Controller File after a repair/upgrade install. Now, I get the above error during the driver setup. I downloaded the driver directly from Asus. Any ideas on the workaround? Thanks
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App