Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Updating USB3 controller driver

09 Jan 2015   #11
doctore

Windows 7 Pro
 
 

[QUOTE=swiftie;2979351]
Quote   Quote: Originally Posted by maxie View Post

I get very tense updating drivers, having had many disasters doing this to OS/2 systems in the past.
Restore points are your friend Always make one before installing drivers, then it's an easy reverse should things go wrong...


My System SpecsSystem Spec
.
10 Jan 2015   #12
swiftie

Windows 7 Ultimate x64
 
 

Well, I installed the 1.0.10 USB 3 driver update, and now I seem to have no working USB2 ports. That has taken out my keyboard/mouse (I'm connected remotely, via my Proliant server). Also, the Drobo dashboard can't find the Drobo 5D, although its virtual drive (my N drive) seems to be working. I'm about to rollback the USB3 driver update...
My System SpecsSystem Spec
10 Jan 2015   #13
maxie

windows 7 home 64bit
 
 

I am beginning to think that Motherboard must be faulty ...
My System SpecsSystem Spec
.

10 Jan 2015   #14
swiftie

Windows 7 Ultimate x64
 
 

Having installed, the 1.0.10 USB3 drivers, I lost all my USB2 ports. And the Drobo dashboard couldn't find either of my drobos.
Having rolled back the USB3 driver, I'm now back on 1.0.1 but USb2 is still not working. Device manager shows all hubs as simple USB devices...
So, system Rstore next... wish me luck.
My System SpecsSystem Spec
10 Jan 2015   #15
maxie

windows 7 home 64bit
 
 

Well if the Restore does not work try the Chipset Driver ....
My System SpecsSystem Spec
10 Jan 2015   #16
swiftie

Windows 7 Ultimate x64
 
 

Oh, belay that System Restore, I have partial USB2 now. I don't know what did that, but Device Manager is still showing my USB hubs as USB devices (i.e. no "+" signs)

So, my system is mostly working, but I'm back on the ancient USB3 drivers and none of my USB2 hubs are recognised as such (although they are named as USB hubs)

HWiNFO32 doesn't start. I get a "Do you want to run this", as usual, but then nothing. The System Restore that I started is still saying "Please wait while System Resore starts".

I'm perplexed how to proceed. Should I try fixing my USB2 problems by updating the USB2 drivers? The only way I know of doing this, without outside assistance, is to ask the Device Manager/Update driver process to find better drivers on the web. Since my existing USB2 drivers are Microsoft, it seems probable that newer ones would be found on the web.

As long as I don't turn my PC into a vegetable, I can always use System restore to get back to where I was at 06:00 today - my system takes a restore point every day.

I keep daily Macrium Reflect images of my C drive (on my internal D drive). I'd better make sure I can find the standalone Macrium boot CD.
My System SpecsSystem Spec
10 Jan 2015   #17
maxie

windows 7 home 64bit
 
 

Go to the Motherboard Website and Download the Chipset Driver ...


There is no point looking at the Intel Website for the Driver ..


No support there for Series 7 ....
My System SpecsSystem Spec
10 Jan 2015   #18
swiftie

Windows 7 Ultimate x64
 
 

I've been to the ASUS website, and it's too impenetrable for me.

Since I end up with a working setup by the simple act of throwing my USB3 powered hub out, that's the solution I'm going to use.

I don't need so many USB3 ports as long as the Drobo 5D is working. I've taken two 2Tb external USB drives (in caddies) and copied their data to directories in the 5D. I then turned off the caddies. Once I'm convinced that the 5D is stable, I'll take the 2Tb drives out of the caddies and add them into the Drobo 5D array. I'll get 5.44Tb of space, even with dual disk recovery (no data loss even when 2 disks fail).
My System SpecsSystem Spec
10 Jan 2015   #19
maxie

windows 7 home 64bit
 
 

That should work
My System SpecsSystem Spec
Reply

 Updating USB3 controller driver




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ASUS M4A89GTD Pro/USB3: USB3 driver issues
Hello and thanks for any help you can provide. I have been having issues with my ASUS motherbord, I recently cleaned and re-formatted my main HDD, after doing this i re installed windows and all my normal drivers, motherboard, cpu, gpu, etc. But for some reason every time I install my USB3...
Drivers
Missing some driver: SM Bus Controller, PCI Device, Network Controller
Hey I just recently switch my hard drive ( 320gb HDD 5400 rpm ) to a Samsung 840 EVO 250 Gb. I'm currently missing some files and I can't seem to find those drivers help? Btw it's a laptop here the model if you wanted to know : Asus X401A Network Controller ...
Drivers
why does USB3 driver need to reinstall after restart?
Please Pay attention to image, I got this pic from Device Manager. Two driver is signed with yellow color and every time I install them ,after restart the problem is there and USB ports don’t work . i have dell n5110 , I don’t remember when this is happened. I follow 2 solutions but problem...
Drivers
AKE USB3 Express Card Adaptor Driver Problem
I cannot get an AKE 3-port USB3 express card adaptor to work in my HP Elitebook 8530w. The adaptor came without drivers when I bought it, which didn't worry me at first because I assumed Windows 7 would support it. Wrong! I have identified the NEC and Renesas drivers as appropriate (although I...
Drivers
Bsod caused by USB3 driver
I have a weird problem with USB 3 drivers I think. This is my configuration: Motherboard: Gigabyte GA-B75M-D3V Cpu : Intel Core i5 3470 Ram : 8 Gb Corsair 1333 Mhz Video: Gigabyte GeForce GTX 660 2048MB DDR5 OC version Hdd : Western Digital 640 GB 7200 Rpm Case: Segotep SG-Z2
BSOD Help and Support
Installed USB3 driver on Win7 - monitor goes blank
I installed a Sabrent 2-port PCIX-USB3 "black" card into my HP P6228 desktop PC running Win7 Home Premium 64bit. I installed a driver from their web site, and everything continued to work OK, except the USB3 appeared to run only a bit faster than USB2. I opened a problem case with Sabrent and they...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App