Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sapphire hd 5450 not recognized, HELP

01 Feb 2015   #11
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

One adjustment to what I mentioned above...

When you boot to safe mode, Device Manager -> Display adapter shows the identical name as it shows when you boot normally. Doesn't matter if you're in safe mode or not, the Display Adapter name will be the same.

So if the Catalyst drivers have been successfully and properly installed, the name shown will ALWAYS be "AMD Radeon HD5450", safe mode or not. This confirms that the video drivers for the HD5450 WERE INSTALLED SUCCESSFULLY.

However if the Catalyst drivers have not been properly or successfully installed, the name shown will ALWAYS be "standard VGA adapter" or similar, no matter whether you're running in safe mode or normal mode.

So if you currently show "standard VGA adapter" in Device Manager when you boot to safe mode, that tells us you do NOT have the Catalyst driver installed. It either didn't install successfully, or you've uninstalled it.

And that means you must also be once again using the original MS-provided vanilla generic VGA video driver, as you were right after the 64-Bit Win7 install completed and before you installed Catalyst (which runs in SVGA mode) and got into trouble with the black screen.

Are you now operating successfully this way, with "standard VGA adapter" showing?

Unless you replace the SMS19A100 with a newer higher-resolution monitor that can run in SVGA mode, I'm going to suggest you uninstall the Catalyst driver. The MS vanilla VGA driver is just as acceptable for your 64-bit Win7 as it was with your 32-bit Win7, which is what I suspect you were using in your previous 32-bit Windows setup.


I'm still wanting to know if you had Catalyst installed in your previous 32-bit Win7 environment.


My System SpecsSystem Spec
.
01 Feb 2015   #12
mahir

Windows 7 ultimate 64 bit
 
 

Bro
I buyed all the stuffs but i didnt install. A well known person did it for me.
My System SpecsSystem Spec
01 Feb 2015   #13
mahir

Windows 7 ultimate 64 bit
 
 

I installed amd catalyst in 32 bit
My System SpecsSystem Spec
.

01 Feb 2015   #14
mahir

Windows 7 ultimate 64 bit
 
 

And yes it is running perfect with VGA standard monitor.
My System SpecsSystem Spec
01 Feb 2015   #15
mahir

Windows 7 ultimate 64 bit
 
 

So you want to say is that my only way is to upgrade to a better monitor, right?
My System SpecsSystem Spec
02 Feb 2015   #16
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Quote   Quote: Originally Posted by mahir View Post
Bro
I buyed all the stuffs but i didnt install. A well known person did it for me.
Did the builder also install 32-bit Windows for you? Or did he just do the hardware construction and you did the Windows install yourself?

You also didn't say if this machine included the HD5450 in its initial purchase configuration, or if you added the HD5450 after the machine was delivered to you. Did the HD5450 come in the machine from the builder, or did you add it yourself after it was delivered?

Quote:
I installed amd catalyst in 32 bit
Again, was this done by you AFTER the initial machine was delivered to you?

Does that mean you added the HD5450 yourself to the delivered machine that didn't have the HD5450 in it originally, and then realized you also had to install Catalyst?

Or was it because the original machine DID have the HD5450 in it but came from the builder without Windows installed yet, and since you installed Windows yourself you also were installing drivers for all hardware in the machine, including the HD5450?

Now, are you sure you installed Catalyst successfully in your previous 32-bit Windows environment? Remember, if it DID install successfully then Device Manager would show it as "AMD Radeon HD5450". If it DID NOT install successfully then Device Manager would show "standard VGA adpater".


Quote:
And yes it is running perfect with VGA standard monitor.
I'd like to see the specifics of your current 64-bit environment.

(a) Right-click on desktop, select "screen resolution". What is shown as resolution?

(b) Device Manager -> display adapter, right-click on "standard VGA adapter" and select Properties, select "Driver" tab. What is shown as driver provider, date, and version?

(c) Right-click on desktop. Does "AMD Catalyst Control Center" appear at the top of the popup menu or not?


Quote:
So you want to say is that my only way is to upgrade to a better monitor, right?
I'm still not sure, but your machine is a real puzzle.

The specifics of your previous 32-bit environment need to be clarified. It's not clear if you were actually using 32-bit Catalyst successfully or not with your monitor running at 1366x768. If so, it's honestly a mystery why 64-bit Catalyst would not also work at 1366x768. The monitor hardware should report its native/recommended resolution of 1366x768 to the drivers at boot time, no matter whether you're running 32-bit Catalyst or 64-bit Catalyst.

But if you actually were still running with the MS generic VGA drivers in your 32-bit environment because Catalyst didn't actually install successfully (with Device Manager still showing "standard VGA adapter"), then your 64-bit results would appear to be the same as your 32-bit environment, with successful operation only when staying with the MS-provided generic VGA driver.

So yes, it really would be informative if you had access to a newer, larger monitor with resolution of at least 1600x900 or 1920x768, and then try to install 64-bit Catalyst 14.12 again.
My System SpecsSystem Spec
Reply

 Sapphire hd 5450 not recognized, HELP




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
hard drive NOT recognized in computer but IS recognized in disk mgmnt.
I just rebuilt an old system using Windows 7 Home Premium after using WinXP pro for many years. The primary hard drive is WDC 150 Mg and Win7 is installed and updated to current with SP1. I dropped a second WDC hard drive in, formatted and was going to use it for a 2nd backup unit. Both of these...
Hardware & Devices
Ati Radeon HD 5450 1gb good for this???
my system specs: Intel Pentium G620 (dual core) 4gb DDR3 1333mhz ram ASROCK H61M-VS do you think these games will run fine on hd 5450 (about 20-30fps) GTA 4 dirt 3 nfs the run the upcoming most wanted 2012
Graphic Cards
Geforce GT 210 or Radeon HD 5450..better in gaming??
Dear All, Need a quick suggestion before i seal the deal. I intend to buy the Radeon HD 5450. It has PCI-e 2.1 x16 bus interface. My motherboard model is Foxconn WinFast NF4K8MC. It has PCI-e 1 x16 graphics slot. My query is- will the graphics card work with this motherboard or not?
Graphic Cards
XFX 5450 Windows 7 Hibernate problem
I have an extremely annoying problem on my PC which seems to be graphics related. I am running Windows 7 with the following setup : Motherboard : Asus P5QL EPU MOBO Graphics card : XFX HD 5450 1GB SDDR3 HDMI DV Memory : 4Gb DDR2 RAM PSU : 700W PSU Corsair When the PC hibernates,...
Graphic Cards
gt220 vs ati hd 5450
i m undecided about using an gt220 or an ati hd 5450 on a board asus m4a78-em, with an amd cpu phenom II 955, 3.2. with 6gb ddr2. both graphics are 1gb ddr3. which one is better? thanks
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App