Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Base System Device - drivers not installed

07 Nov 2009   #1
seekinsp

WIndows 7 Home Premium
 
 
Base System Device - drivers not installed

Hi, I recently installed Windows 7 Home Premium and I have the Base System Device error on 3 devices. I am having a problem attaching multiple USB drives simultaneously so I want to make sure that these driver problems are not contributing to the problem. Here are the hardware ID's from device manager if somebody could help please;

Device 1
Base System Device
PCI\VEN_1180&DEV_0843&SUBSYS_30D6103C&REV_12
PCI\VEN_1180&DEV_0843&SUBSYS_30D6103C
PCI\VEN_1180&DEV_0843&CC_088000
PCI\VEN_1180&DEV_0843&CC_0880

Device 2
Base System Device
PCI\VEN_1180&DEV_0592&SUBSYS_30D6103C&REV_12
PCI\VEN_1180&DEV_0592&SUBSYS_30D6103C
PCI\VEN_1180&DEV_0592&CC_088000
PCI\VEN_1180&DEV_0592&CC_0880

Device 3
Coprocessor
PCI\VEN_10DE&DEV_0543&SUBSYS_30D6103C&REV_A2
PCI\VEN_10DE&DEV_0543&SUBSYS_30D6103C
PCI\VEN_10DE&DEV_0543&CC_0B4000
PCI\VEN_10DE&DEV_0543&CC_0B40

Thanks for any assistance you can give me. I have tried to google these ID's without any results.

- Paul


My System SpecsSystem Spec
.
07 Nov 2009   #2
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Device 1

0x0843
Chip Number: R5C853
Chip Description: Ricoh SD/MMC Host Controller
Notes: ftp://ftp.hp.com/pub/softpaq/sp36001-36500/sp36254.exe
My System SpecsSystem Spec
07 Nov 2009   #3
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Device 2

0x0592
Chip Number: 13171043
Chip Description: Ricoh Memory Stick Host Controller
Notes: http://ftp.us.dell.com/chipset/R141246.EXE
My System SpecsSystem Spec
.

07 Nov 2009   #4
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Device 3

Seems to be a nVidia graphics card?

What laptop do you have?
My System SpecsSystem Spec
07 Nov 2009   #5
kegobeer

Windows 7 Ultimate x64 SP1
 
 

Go to HP and download the Ricoh drivers for your laptop. After you install them, check for any devices that are still left that need drivers.
My System SpecsSystem Spec
08 Nov 2009   #6
seekinsp

WIndows 7 Home Premium
 
 

Quote   Quote: Originally Posted by gilbo View Post
Device 1

0x0843
Chip Number: R5C853
Chip Description: Ricoh SD/MMC Host Controller
Notes: ftp://ftp.hp.com/pub/softpaq/sp36001-36500/sp36254.exe
Thanks, but this sp did not yield any results. I still have the same error. Also, I am showing an SD Standard Compliant SD Host Controller as already installed. Plus, the SD card reader seems to working fine. Should I even worry about this one?


Quote   Quote: Originally Posted by gilbo View Post
Device 2

0x0592
Chip Number: 13171043
Chip Description: Ricoh Memory Stick Host Controller
Notes: http://ftp.us.dell.com/chipset/R141246.EXE
This looks like a Dell driver and will not install on my system. Is this related to device 1? If so, should I worry about it if the SD card reader is working?

Quote   Quote: Originally Posted by gilbo View Post
Device 3

Seems to be a nVidia graphics card?

What laptop do you have?
I have a HP DV2945se with a NVIDIA GeForce Go 7150M graphics card. Device Manager shows that the right drivers are installed for the graphics card, so not sure why this would be showing up.

BTW, thanks for your timely response on this. Everything seems to be functioning correctly (bar the USB issues, but I have a workaround from MSFT on that). So I am not sure that I should even be concerned with these.

- Paul
My System SpecsSystem Spec
08 Nov 2009   #7
seekinsp

WIndows 7 Home Premium
 
 

Quote   Quote: Originally Posted by kegobeer View Post
Go to HP and download the Ricoh drivers for your laptop. After you install them, check for any devices that are still left that need drivers.
Yep, did that and all 3 are still showing up.
My System SpecsSystem Spec
08 Nov 2009   #8
gilbo

Windows 7 Professional 64-bit / Vista 32-bit Home Premium Dual Boot
 
 

Quote   Quote: Originally Posted by seekinsp View Post
Quote   Quote: Originally Posted by kegobeer View Post
Go to HP and download the Ricoh drivers for your laptop. After you install them, check for any devices that are still left that need drivers.
Yep, did that and all 3 are still showing up.
It seems HP have not added any W7 drivers yet.

http://h10025.www1.hp.com/ewfrf/wc/d...oduct=3747194#

Continue checking periodically for updates or try running in Vista Compatability mode.
My System SpecsSystem Spec
08 Nov 2009   #9
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Just in case you need to know how to install in compatibility mode. Compatibility Mode
My System SpecsSystem Spec
21 Nov 2009   #10
oblivious

Windows 7, Windows Vista
 
 

Hi,

Just had the same driver issue with the Ricoh R5C853 device. I used the Windows Vista x64 driver instead and it works fine. I am running a HP Compaq 6910P with Windows 7 Ultimate x64.

Good luck!

Eric.
My System SpecsSystem Spec
Reply

 Base System Device - drivers not installed




Thread Tools




Similar help and support threads
Thread Forum
Base System Device Drivers
Hi Sony VAIO VGN-FW31E Laptop Just did clean install from Vista to Windows 7 Professional. Amongst several problems that I am working through the latest one is this. Error in Device Manager: Base System Device PCI\VEN_1180&DEV_0592&SUBSYS_9035104D&REV_12
Drivers
Another Base System Device driver not installed!
Sorry folks but would really appreciate anyone helping on this, just installed 7 on my Dell XPS M1330 and playing around saw this: Problem with PnP devicesDetected res://sdiageng.dll/warning.pngThere are problems with some PnP devices. Windows will take additional steps to further troubleshoot...
Drivers
Base System Device drivers error - unable to find drivers
Hi there, I have an HP Pavilion DV7 2185dx laptop running a freshly installed windows 7 upgrade from windows Vista. Ever since the upgrade my CPU is constantly running at 98-100% all the time meaning I cannot do anything on my PC. After researching a bit online it could possibly be the driver...
Drivers
Base system device/Modem driver not installed
My Laptop is sony VAIO VGN-NW11S I recently installed windows 7 32 bit ultimate. After installing OS & Drivers and using sony vaio update s/w installed max driver updates. But still i have two drivers not installed properly. i cant identify them. cant get drivers for the same. pasting screenshot...
Drivers
Base System Device Drivers
Hi, I'm having trouble with my laptop and I can't figure it out...I'm having the Base System Device Driver error and my computer won't recognize one of my external drives, I'm on a Dell Studio 17 and any help would be much appreciated, thanks.
Drivers
Base System Device driver not installed
"The driver for Base System Device is not installed. Install the latest driver for the device." This is message I'm getting. I can find 3 "Base System Device" in Device Manager, but I have no idea what devices they are so I can't search for drivers. Here are the Hardware Ids if that's any...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App