Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Driver Install Problem

20 Apr 2015   #41
groze

W7 32 bit, Linux Mint Xfce 18 64 bit
 
 

Quote   Quote: Originally Posted by defenderjim View Post
ICIT2LOL,

I really don't think this is a virus / malware problem. Just something isn't right in the configuration and needs to be fixed. Just can't figure out what. This used to work, don't know what has changed.

What was the last program or driver that was installed before your issue popped up?
What was the last program or driver removed before your issue popped up?

Avg may be causing the issue. AVG | Download tools and utilities
Try Avg remover program. You might need to run the AVG Identity Protection Remover as well as the Avg remover.


My System SpecsSystem Spec
.
20 Apr 2015   #42
defenderjim

Windows 7, 32 Bit
 
 

Groze,

Quote:
What was the last program or driver that was installed before your issue popped up?
I just can't answer that. We don't use the scanner that much. Too much time has elapsed. I don't really install or change too many things. Seven months can pass without using the scanner. What did I change? Install TurboTax? Over such a long time I don't know what has changed.
My System SpecsSystem Spec
20 Apr 2015   #43
groze

W7 32 bit, Linux Mint Xfce 18 64 bit
 
 

Quote   Quote: Originally Posted by defenderjim View Post
Groze,

Quote:
What was the last program or driver that was installed before your issue popped up?
I just can't answer that. We don't use the scanner that much. Too much time has elapsed. I don't really install or change too many things. Seven months can pass without using the scanner. What did I change? Install TurboTax? Over such a long time I don't know what has changed.
You still might want to try the avg removal tool

Quote   Quote: Originally Posted by defenderjim View Post
Groze,

I happen to have bitdefender. I switched over a few weeks ago from avg. I have the free version of bd. I am able to disable it from the sys tray.

There are a few methods you might want to try.

1. Run the avg cleanup tools I mentioned in my previous post. Then install your scanner using the file you downloaded. If it ask you to allow connection through a firewall say yes.


2. Remove free bit defender, reinstall free avg (use major geeks not cnet) Install only the virus protection nothing else. Then install your scanner using the file you downloaded. If it ask you to allow connection through a firewall say yes.


3. If you still have the dvd/cd setup disk, insert the cd, cancel setup if it starts. Go to device manager again, look for your scanner. This time choose browse your computer, select the dvd/cd drive and looks for the location of the driver. If it ask you to allow connection through a firewall say yes.

After trying all that. If you still get the error, try running windows update after a reboot. See if there is an update to your driver list in important or optional. The install that. Reboot if doesn't ask you to reboot. Then try your scanner. You might want to try this after doing each suggestion, that if you want to.
My System SpecsSystem Spec
.

20 Apr 2015   #44
defenderjim

Windows 7, 32 Bit
 
 

Groze,

Quote:
1. Run the avg cleanup tools I mentioned in my previous post.
Did that.

Quote:
2. Remove free bit defender, reinstall free avg (use major geeks not cnet) Install only the virus protection nothing else. Then install your scanner using the file you downloaded. If it ask you to allow connection through a firewall say yes.
I have tried installing with BD disabled.
Interesting you mention downloading AVG from MG and not CNET. Is that to avoid their "Download Manager" ?

uninstalled BD.

Quote:
3. If you still have the dvd/cd setup disk, insert the cd, cancel setup if it starts. Go to device manager again, look for your scanner. This time choose browse your computer, select the dvd/cd drive and looks for the location of the driver. If it ask you to allow connection through a firewall say yes.
Ok, I tried that. The setup CD is for Win2K. When browsing the Device Manager program says that the disk does not contain any pertinent files.

Quote:
After trying all that. If you still get the error, try running windows update after a reboot.
Tried doing update, but my computer is up to date. Automatic Updates is turned on.


Still no love.
My System SpecsSystem Spec
23 Apr 2015   #45
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

If the problem is at the device level we might get lucky with a look at the device manager trace log file

1. Delete C:\WINDOWS\inf\setupapi.dev.log
2. Copy/paste the following into notepad. Save the file, name it x.reg. Double click the file to apply the change to the registry
Code:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup]
"LogLevel"=dword:08007070
3. Reboot your machine. Attempt to do the install/uninstall again. Still get the "file missing" error message?
4. Upload C:\WINDOWS\inf\setupapi.dev.log and attach to your next post. Will see if anything helpful appears
My System SpecsSystem Spec
24 Apr 2015   #46
groze

W7 32 bit, Linux Mint Xfce 18 64 bit
 
 

defenderjim, I didn't mean the install cd/dvd for the operating system. I meant the install cd/dvd for the scanner.
My System SpecsSystem Spec
24 Apr 2015   #47
defenderjim

Windows 7, 32 Bit
 
 

Groze,

Quote:
I didn't mean the install cd/dvd for the operating system. I meant the install cd/dvd for the scanner.
Yes, I understood that. Sorry for my poor wording. What I meant is that the Install CD for the scanner is meant for Win2K and crashed when I tried to use it. Is that clearer?

ComputerGeek,

Quote:
"LogLevel"=dword:08007070
From looking at the Microsoft website on LogLevel, I assume that this value is hex?

I modified the registry to the above value. I performed the usual install and now Windows is no longer creating the log file. Wisely, I did not write down the original value.

I have attached the log file from before I made the above change.


Attached Files
File Type: log setupapi.dev.log (103.4 KB, 1 views)
My System SpecsSystem Spec
24 Apr 2015   #48
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Quote   Quote: Originally Posted by defenderjim View Post
Groze,[B]
ComputerGeek,

Quote:
"LogLevel"=dword:08007070
From looking at the Microsoft website on LogLevel, I assume that this value is hex?

I modified the registry to the above value. I performed the usual install and now Windows is no longer creating the log file. Wisely, I did not write down the original value.

I have attached the log file from before I made the above change.
1. Yes. That's a hex value

2. To go back to original: You can set LogLevel=0 or simply delete the key. LogLevel doesn't exist (by default). When LogLevel doesn't exist it's equivalent to a value of 0

Will get back to you about results. (p.s. That hex value a "Verbose" log. Strange if it's not creating one at all - but will look through what you have attached)
My System SpecsSystem Spec
24 Apr 2015   #49
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Understanding windows drivers is a "black art". At best, my knowledge is a "lighter shade of grey".
So don't take everything I say as gospel - but it's my best understanding based on what i've read, tried and played with to date.

Drivers first get loaded into the DriverStore. Windows only installs drivers from the Store. It seems the driver package in the Store for your scanner is corrupt. The driver package for your scanner is in C:\windows\System32\DriverStore\FileRepository\es1dn.inf_x86_neutral_1bf0cd02788b219b

1. Upload a copy of the INF file
Code:
C:\windows\System32\DriverStore\FileRepository\es1dn.inf_x86_neutral_1bf0cd02788b219b\es1dn.inf
2. From a command prompt run the following. Attach the output file C:\output.txt to your next post
Code:
pnputil -e > C:\output.txt
3. Can you give me the link to where you found the driver you're using?
My System SpecsSystem Spec
24 Apr 2015   #50
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

I can't remember if I mentioned it before but if you look in the registry HKEYs CURRENT USER and LOCAL MACHINE under Software/s you may find traces of entries for AVG I have done this before and just deleted the whole entry for it and it is a good way of getting rid of Norton and that wretched Askbar stuff.

You will of course need admin rights to do that

See my pic and if you feel unsure of this method then you can back up the reg before you do it use this
Registry - Backup and Restore


Attached Thumbnails
USB Driver Install Problem-hkeys.png  
My System SpecsSystem Spec
Reply

 USB Driver Install Problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Can't boot Windows after driver install, diagnosed problem, can't fix
My Windows won't boot. Here is a summary of what happened so far: I was playing a game when it suddenly started stuttering for a few seconds and black-screened. I rebooted and I saw no problems, but when I booted a game again and the dedicated GPU started working, about 3-4 minutes into the game...
General Discussion
Driver install problem - USB stick and USB Ext HD
Hi, I've got problems installing USB external hard driver and USB memory stick driver on windows 7 pro 64 bit. The computer is a Lenovo t410s, intel chipset. The external disc drive is a Western Digital Elements SE 1 TB and the USB memory stick is of the brand TwinMos. At first I could not...
Drivers
Driver Install Problem
Hello, Running the 64 bit vers. of W7. Have a program that installs the main application in the normal Program Files(x86), and the Driver for the program in System32\Drivers. All seems normal,and everything seems to be where it should be. Very confident that the Driver is O.K., and not...
Drivers
RADEON™ HD 5770 driver install problem
have a (virtually) brand new pc with windows 7 64 bit. The graphics card is 1GB ATI RADEON™ HD 5770 After switching my pc on today and trying to play a dvd i get this error message 'Windows media player cannot play this DVD because there is a problem with digital copy protection between...
Drivers
Clean Install - VAIO Driver = Problem with battery
I made a clean install for VAIO (with a lot of problems) but everything seemed to be working fine and dandy. I was happy but then the screens' brighter and darker switches weren't working, so I decided to download some Utilities drivers from the Sony VAIO official website. I downloaded a couple...
Installation & Setup
Problem install Bluetooth driver....
Guys,i have problem install Bluetooth driver.B4 this,(in XP),i x have any problem install the driver without bluetooth device.but now,it say must enable device to install.can some1 give me advice how to install it successfully without enable device?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App