Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Xerox Printer Driver install issue


08 Nov 2009   #1

Windows 7 Home Premium
 
 
Xerox Printer Driver install issue

I have attempted to install my 8560 printer on my laptop I am having issues. I went to Xerox and downloaded and attempted to install the printer and received the same issue.

It wants to install as a network printer and is requesting me to connect to a network. I do not have a network. When I go to view my devices and printers I see my Xerox printer there which seems strange. I tried to print something from word and it only printed in black and with from the bypass tray. I then went to check my printer preferences and found i had only the very basics options which all seemed to be fine except for the color and tray selection.

Its weird because on my XP and Vista computers, I do note have this issue and they are also laptops. I checked my security and I have rights to everything. I simply want to install the printer and us it with a USB connection.

I am also having an issue with two other devises using the USB port connection.

My System SpecsSystem Spec
.

16 Nov 2009   #2

All OS's
 
 

Did you happen to download and install the Xerox Global Print Driver?

If so, the Global print driver does not support USB connections for the SNMP Device Discovery and therefore will revert to "Basic" Print only. You can go into the drivers advanced setting and choose the printer from the list and this will restore all printing features.

If you are using the "Native" print driver and still unable to resolve, Please call 1-800-835-6100 and follow the prompts for Support. (I work in 2nd Level Software Support)
My System SpecsSystem Spec
16 Nov 2009   #3

Windows 7 Home Premium
 
 

No, I did not install the global driver, the I downloaded the driver that was recommended. I first tried to install from the install CD and got the same results. It is looking for a network, or request me to use the walk up feature. Recommended:> Web-based PostScript Print Driver InstallerVersion: 5.58.10 Date: 3/27/2008 Size: 2.8MBLanguage: English (US)Web-based PostScript driver installer for the Phaser 8560. Microsoft WHQL Certified. Citrix Ready.
My System SpecsSystem Spec
.


17 Nov 2009   #4

All OS's
 
 

Is your Windows 7 32bit or 64bit?

If it is 32bit, then go to the Drivers download page and do not select the web based installer. Select the PCL or Postscript listed lower on the page.
After you extract the driver files, simple unplug the USB cable from your PC and then plug it back in. If you get prompted for the drivers, then browse to the extracted location. By default they are extracted to c:\xerox\[your printer].

If the OS is 64bit, you can use the Vista x64 driver (again, dont choose the Web Based installer) as the Vista driver is the same.

If you using a laptop, please make sure that you are connecting the printer directly into the laptop and not a docking station or port replicator.
My System SpecsSystem Spec
17 Nov 2009   #5

Windows 7 Home Premium
 
 

Thank you. I will try what you have suggested and let you know what happens.
My System SpecsSystem Spec
22 Nov 2009   #6
EdC

vista
 
 

I am having the same problem with my Vista 32 sp2. Have spent upwards of 3 weeks searching the net trying to find a solution. Tried the web based installed and it would not even get past the first screen. Tried the pcl and got a liuttle further but am still gettting that it is unable to install and geves an error code of 0x000003eb. There are no other printers installed on this machine, The printer is an 8400. Hope someone can help.
My System SpecsSystem Spec
23 Nov 2009   #7

Windows 7 Home Premium
 
 

I attempted to download the post script driver as XRXGuy suggested. I am able to extract the file, and then I connect the USB directly to the computer. Windows 7 automatically starts a download and install essentially installing 2 drivers. I continue to with my install and it will ask for my model, then ask me if I want to share the printer with others on my network. Again...I am not on a network. I continue and select no. I then attempt to print a page and receive an error message. below is the driver I am installing.

> PostScript Driver
Version: 5.58.10 Date: 3/27/2008 Size: 5.5MB Language: English (US)
Win2000/XP/03/08/Vista/Windows 7 PostScript driver. This driver uses the Add Printer Wizard and offers full support of the printer specific features for the Xerox Phaser 8560. Microsoft WHQL Certified.
My System SpecsSystem Spec
11 Jan 2010   #8

Windows 7
 
 
FIXED

Just had a conversation with Xerox on how to get any Xerox printer working with their Windows 7 Global Driver.

Right Click on the Printer and go to Printer Properties.

Then Click on the "Options" tab

Expand Device Options

There should be an option called "Configuration" drop that down and select your printer.

Then click apply.

I then had to go back in and select "Vivid Color" to get the 8400 to print in color. This can be done by going back into Printer and Devices and double clicking on your printer. Double click on "Adjust Print Options" Click on Color options tab and select Vivid Color.
My System SpecsSystem Spec
24 Aug 2010   #9

Windows 7 Ultimate x64
 
 

I have Xerox Phaser 8560DN. I have the same problem as first guy in post. What's up with that? Can't XRXGuy put together better service description that details exactly what to do.

I believe we all have same issue. Xerox needs to support Windows 7 and not jack us around. I went from Vista with Office 2007 to Windows 7 with Office 2010. I am not stupid or ignorant, but have 30+ computer years experience. All we ask is that it works the same way. No color, always has to print from access tray - what's up with that crap! No I don't follow unhelpful advise from XRXGuy. And I don't have an 8400, so that post is non-applicable. I now have to keep 3 year old laptop operational and use USB stick to transfer files to get correct printout. - UUUGGGHHH! Already casued me 4+ hours of additional work. Who is kidding who?
My System SpecsSystem Spec
24 Aug 2010   #10

Windows 7 Ultimate x64
 
 

Well now, after 3 more tries, finally got the Options tab under Printer Preferences to show a drop down Configuration box. Yes I selected "8560dn" but that hasn't fixed anything other than it now duplexes and selects from Tray 2 correctly. Still no COLOR!!! and the output is expanded 50%!!!!!!. You call this progress in USA?
My System SpecsSystem Spec
Reply

 Xerox Printer Driver install issue




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33