Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Screen goes black after installing graphic drivers

21 Jul 2015   #1
Phrosen

Windows 7 Professional x64
 
 
Screen goes black after installing graphic drivers

Hello.
I'm helping my friend with his laptop.
I'm currently trying to install graphic drivers.

The laptop is an ASUS A52J. There's a sticker saying there's an Radeon HD 6370M inside.
I went to Radeon's website and downloaded the latest drivers. When I install them the driver asks me to reboot. After rebooting the screen turns black after the "Starting Windows" screen (just before the login screen.) I hear the sound of being logged in, but I can't see anything.
I am forced to restart Windows in failsafe mode to see anything - then I can uninstall the drivers and run on the "default drivers" that Windows install.

Anyone know how to fix this problem?


My System SpecsSystem Spec
.
21 Jul 2015   #2
BugMeister

Windows10 Pro - 64Bit vs.10547
 
 

presumably, you downloaded the 15.7 driver..?

it should run ok..
- did you run the installation as administrator?
- also, did you opt for the (full) express install?
My System SpecsSystem Spec
21 Jul 2015   #3
carwiz

Windows 7 Pro-x64
 
 

That's not the standard video hardware for that model of laptop. You might check via Device Manager and see what it is reporting for Display Adapters. I wouldn't rely on a sticker.
My System SpecsSystem Spec
.

22 Jul 2015   #4
Phrosen

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by BugMeister View Post
presumably, you downloaded the 15.7 driver..?

it should run ok..
- did you run the installation as administrator?
- also, did you opt for the (full) express install?
I downloaded the latest version. I believe it was 15.7, yes.
-I did run as admin.
-I tried installing it many times, with different combinations. Yes.


Quote   Quote: Originally Posted by carwiz View Post
That's not the standard video hardware for that model of laptop. You might check via Device Manager and see what it is reporting for Display Adapters. I wouldn't rely on a sticker.
When I check DevMan it says:
PCI\VEN_1002&DEV_68E4&SUBSYS_1C921043&REV_00
When I google for it various different pages comes up saying "AMD Radeon HD 6370M"


I was thinking maybe I have the wrong version of the driver - that I need an older version, but I can't find where to download them.
My System SpecsSystem Spec
22 Jul 2015   #5
carwiz

Windows 7 Pro-x64
 
 

It would be an "AMD Radeon HD 6370M" if the DEV was 68E4 but it's not. You're showing 6&E4. That's not a valid device type. I asked what is showing under Device Adapters. Windows will read the device as "6" and I suspect can't identify it.

Did your friend install the module? You might try reseating it and check for damaged/dirty contacts. Also, clear CMOS memory and let Windows rediscover hardware.
My System SpecsSystem Spec
22 Jul 2015   #6
Phrosen

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by carwiz View Post
It would be an "AMD Radeon HD 6370M" if the DEV was 68E4 but it's not. You're showing 6&E4. That's not a valid device type. I asked what is showing under Device Adapters. Windows will read the device as "6" and I suspect can't identify it.

Did your friend install the module? You might try reseating it and check for damaged/dirty contacts. Also, clear CMOS memory and let Windows rediscover hardware.
That was me misreading '&' instead of '8', as you can see I edited my last post when I realized my mistake.

EDIT: Problem solved. I googled around and finally found a driver that works.
Solution: What I did wrong was googling for "asus a52j", the top result displayed "asus a52jC". I clicked it and was surprised to find there's only nvidia and intel vga drivers. That's when I went directly to AMD's website for drivers; drivers which didn't work.
After trying about everything I went back to "step 1" and googled for "asus a52j" again. This time I noticed that there's a52jU and a52jE as well. I have no idea what the difference between these models are, but I tried one randomly (they both had ATI vga drivers) and to my surprised it worked.
I need to pay more attention to what I'm doing I guess.
My System SpecsSystem Spec
22 Jul 2015   #7
carwiz

Windows 7 Pro-x64
 
 

OK, good deal! Glad you got it going.
My System SpecsSystem Spec
Reply

 Screen goes black after installing graphic drivers




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Black screen after installing graphics drivers
I did a clean install of windows 7, then i installed firefox, avast and utorrent. I then downloaded the newest graphics drivers from nvidia, I have a GeForce 7300, and installed. After I rebooted the screen went completely black after the "starting windows..." screen. And the monitor goes into...
Graphic Cards
while i installing ati drivers my screen goes black
hey guys, i have a problem with my ati graphic card nearly for two months. two months earlier i was playing crysis 2 and suddenly screen had freeze and then restarted itself. so i had discover the ati driver had crash and stopped working. (i have two graphic cards- Ati radeon 5470 and intel hd...
Graphic Cards
Fix for black screen after graphic drivers reinstalled
Hi I want to update my graphic card for gaming but the drivers are given by vaio there are not giving graphic drivers updates regularly so i uninstall given by sony and installed new graphic drivers from intel website but after restart i was getting black screen Problem 2: :confused:so i...
Drivers
Big black bar on side of screen after installing geforce drivers
I just started up my new computer and everything was fine. The monitor i'm using that's getting this problem is a Wacom Cintiq 21ux drawing tablet, and the video card i'm using is Asus GeForce GTX 780 Ti. Everything was fine until I installed the latest Asus drivers, and after I restarted my...
Graphic Cards
Bad GPU? Freezing, black screen, and graphic artifacts.
Hello. Recently my hp pavilion dm4 with switchable radeon 5000 series gpu has started acting funny. It started months ago with poor performance in streaming videos online when the radeon was activated (dubbed "hi performance" in the OS.) This problem seemed to get better after reinstalling...
Graphic Cards
Black Screen after installing ATI Catalyst Drivers
Hi, the first time I installed Windows 7 Professional (clean install, not upgrade) and installed the catalyst drivers for my HD5750 video card (http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/windows-7-64bit), everything worked fine. I ended up formatting my hard drive and doing a...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App