Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Display Adapters errors staying even after updates

13 Aug 2015   #1
brandough

Windows 7 64 bit
 
 
Display Adapters errors staying even after updates

I can't figure out how I can get the error symbol on these drivers to go away and get the drivers to work properly.
For my AMD Radeon HD 79000 Series I went here and downloaded the autodetect tool. When I ran it, it displayed all the correct information and it proceeded to download the drivers. I do everything it says and reboot the computer, but the error symbol is still there. I'm not sure what went wrong there.
For the Intel(R) HD Graphics 4000 I went here and followed all the directions the same way I did with the AMD Radeon and it didn't take that update either with the error code still being present.

I'm not sure why my computer isn't taking these updates and letting it work properly.

In the attachments I have included my dxdiag and a screenshot of the drivers in my device managers.

Thank you for any help!




Attached Images
Display Adapters errors staying even after updates-display.png 
Attached Files
File Type: txt DxDiag.txt (22.8 KB, 7 views)
My System SpecsSystem Spec
.
15 Aug 2015   #2
Pebble

Windows 7 64-bit
 
 

Desktop

Which motherboard make/model do you have?
My System SpecsSystem Spec
10 Nov 2015   #3
brandough

Windows 7 64 bit
 
 

Sorry I took so long to get back to this. I ended up trying a few things at the time, but they all ended up failing and nothing was resolved. All these months later I'm still in the same situation.

I tried a clean install with Display Driver Uninstaller and then trying to reload the drivers with AMD Catalyst Control Center, but that didn't do anything either. The Control Center seemed to download the drivers, but then I'll still back to where I am in the opening post. I did that like 9 hours ago. Now when I try to open the AMD Catalyst Control Center I get "AMD Catalyst Control Center cannot be started. There are currently no settings that can be configured using AMD Catalyst Control Center." It's possible I did something wrong, but I don't know.


Any help would be very appreciated. Thank you!

Quote   Quote: Originally Posted by Pebble View Post
Desktop

Which motherboard make/model do you have?
My motherboard is ASRock Z77 Extreme6.
My System SpecsSystem Spec
.

10 Nov 2015   #4
Pebble

Windows 7 64-bit
 
 

Download the catalyst drivers Desktop
uninstall the old drivers, Then reinstall the drivers only from the catalyst, No control centre etc...

The HD graphics is not showing in my display adapters, Cant remember but i think i might have disabled/removed it,
And only installed display drivers for the GFX card.
My System SpecsSystem Spec
10 Nov 2015   #5
brandough

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by Pebble View Post
Download the catalyst drivers Desktop
uninstall the old drivers, Then reinstall the drivers only from the catalyst, No control centre etc...
Tried it and it still looks the same like it does in the original post.
Just to make sure I actually did it twice. Clean uninstall and then install the drivers and nothing else.
My System SpecsSystem Spec
11 Nov 2015   #6
brandough

Windows 7 64 bit
 
 

Sorry for the double post, but found out something interesting.

Best Buy said I could return a graphics driver within 2 weeks even if opened, so I went and bought one to test out how my computer would handle a different one. Plugged it in correctly and ran the provided disc to install the drivers... and it looks exactly like the other driver did.



Now I'm really confused as to what the problem is. Maybe the motherboard? Any suggestions? :\
My System SpecsSystem Spec
11 Nov 2015   #7
Pebble

Windows 7 64-bit
 
 

Just checked your DXDiag.txt (should have done that earlier) and there is no card being detected. After trying 2 card's,
I suspect it is the PCI-E port that's faulty.
Your probably right, And need a new mobo.
My System SpecsSystem Spec
11 Nov 2015   #8
brandough

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by Pebble View Post
Just checked your DXDiag.txt (should have done that earlier) and there is no card being detected. After trying 2 card's,
I suspect it is the PCI-E port that's faulty.
Your probably right, And need a new mobo.
Now that I think about it, it probably really is the motherboard.
Sometimes when I have windows updates the computer has problems upon the reboot. Like, it gets stuck on the loading windows screen or asks me to repair windows upon the restart.
Do you think that's also because of a faulty motherboard?
Would you recommend getting a new one?
My System SpecsSystem Spec
12 Nov 2015   #9
derekimo

Microsoft Community Contributor Award Recipient

 
 

Is this a new install of windows?

I would at least try installing/reinstalling the chipset drivers for your mobo before writing it off,

Display Adapters errors staying even after updates-2015-11-11_21h50_02.png

ASRock > Z77 Extreme6


My System SpecsSystem Spec
12 Nov 2015   #10
brandough

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by derekimo View Post
Is this a new install of windows?

I would at least try installing/reinstalling the chipset drivers for your mobo before writing it off,

Attachment 375675

ASRock > Z77 Extreme6
Nope. This is the same Windows installation I've had since around March 2013.
Heading to bed now, but I'll try that in the morning. Thanks!
My System SpecsSystem Spec
Reply

 Display Adapters errors staying even after updates




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
display adapters drivers not working
trouble started with my laptop not booting on normal mode but works fine in safe mode, tried disabling display adapters, then it boots fine in normal mode. but when display adapters where enabled, laptop freezes. been trying to update and download drivers, laptop ends up having those yellow...
Drivers
AMD Catalyst Display Adapters
Okay this has been driving me nuts. Why aren't the other panel thingies like the Display Driver, Sound, Video, Gaming, Performance and all those stuff aren't showing up on? Here's how it SHOULD look http://i1232.photobucket.com/albums/ff365/AmazingAura01/wat_zpsa32e8ce5.png and this is how my...
Graphic Cards
Microsoft 6 to 4 adapters & ISATAP adapters
Okay, so I recently uninstalled all of my wireless network devices, these were a simple Wireless Card which was in a PCI slot and a wireless USB adapter, I uninstalled them from the device manager, and now under "Network Devices" I have about 32 'Microsoft 6to4 adapters' all with the yellow...
Drivers
Graphics card not showing in Display adapters
1) My graphics card was working perfectly 2) I turned off my pc and turned it on the next day. 3) I found my pc very weird with big icons and everything etc. 4) It installed Standard VGA graphics adapter. 5) I went to "device manager" and clicked "display properties" and i found my graphics...
Graphic Cards
Updating Display Adapters
I'm not entirely sure how to update drivers, so I want to double check. I have an ATI Radeon X1200 Display Adapter and I go to the ATI site and on the list of drivers to update X1200 isn't on it. Does that mean that the driver isn't updatable at all or no updates at the moment?
Graphic Cards
Help with 2 display adapters...
I have main display adapter from mainboard ( Biostar GF8100 M2 TE GeForce 8100 Socket AM2 ) and I buyed new GeForce 8500GT video card. Can I connect to computer 2 monitors using 2 different graphics card (1 main card and card I buyed ) ?
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App