Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unknown device in USB controllers

18 Nov 2009   #21

7600.20510 x86

I just reviewed the thread.

That is unusual for it to show up in USB if it's a PCI card. In this case, I don't really know what you can do.
If your chipset drivers are the latest, then probably nothing is my guess. (Maybe bios update?)

It's difficult to fix things like this if it's even possible, without physical access to the machine, unfortunately.

Quote   Quote: Originally Posted by Monsta View Post
Tried the tv card in another pc and it works just fine.
In the other PC, does it show up in the Sound, Video and Game Controller section of the device manager when it works well?

My System SpecsSystem Spec
19 Nov 2009   #22

windows 7 home premium

Hi torrentg. Yes the card works fine in my old machine and it appears in the sound video and game controller section. I appreciate it is almost impossible to fix something that you cant see or emulate but I appreciate all the time and effort that yourself and other members have spent attempting to find a solution.

I tried to change to card again last night to a different pci slot. The usb error has gone now but the card still can not be found. Just out of interest I was reading up the specs on the card and it appears that it is 2 usb digital tv card receivers soldered on to one pci card. Maybe thats why it shows up in the usb section eh?

Again, thanks for you help. I will let you know when I fond a solution. It's only a matter of time.
My System SpecsSystem Spec
19 Nov 2009   #23

7600.20510 x86

Maybe if you clean the slot on the motherboard after card is removed with compressed air or something, it will show up correctly. Worth a try.
My System SpecsSystem Spec

19 Nov 2009   #24


Sometimes these cards must not be introduced to the system before you load the drivers, the reason being the OS will attempt to implement the usage of incorrect generic drivers.

Not every piece of hardware works under W7 either.

Did you run the upgrade advisor with this card installed, before ploughing into the W7 install?
My System SpecsSystem Spec
19 Nov 2009   #25

windows 7 home premium

OK folks. Here's the deal. I took my pc along with the tv card back to the shop today and informed my friend who is the owner of the shop that the card may be faulty. He took the card and put it into his windows 7 home premium machine to try it. The card was picked up straight away as the correct card and asked for the driver. The driver was installed and hey presto, digital tv in full working order. I then tried to put it back into my machine and got the same old error. (unknown usb device) To be thorough I took an identicle card from the shelf and put that into my pc. This was the result....

Unknown device in USB controllers-capture.jpg

I'm at a loss for words. My original card works in his pc with no problems. However it does not work in mine whatever I do. The identical card works in mine no problem. Don't understand how this is possible but hey, they new one works so he has swapped it for me. Just happy to have one that works.

Thanks for all the suggestions and help that has been offered by all the members here. Don't understand it. If anyone has any idea how this is possible please let me know.

Once again....thanks for all the help.


My System SpecsSystem Spec
20 Nov 2009   #26

Windows 7 Ultimate x86

Glad you got it sorted out Monsta! I have seen some strange things in my 30 years working with computers, but that is one of the strangest set of circumstances I have ever seen. The only thing that I can think of, is maybe the first card was just a bit abnormal and wouldn't seat well in the pci slot with the combination of your motherboard and case. I have had that happen with a couple of old graphics cards, but they would just show up as unknown device.
My System SpecsSystem Spec
22 Nov 2009   #27

windows 7 home premium
back to normal

Anyone who has prviously read this post is not going to believe this. I cant believe it myself.

The new tv card which has worked for the last few days has now got the same error that the first one had and no longer works.

Any ideas anyone, PLEASE!!!
My System SpecsSystem Spec
18 Feb 2010   #28

Windows 7

It's probably a bit late to reply now but, I've come accross this site, via google search regarding a very similar issue, same issue except with the Peak USB Dual Tuner Stick, im sure it'll help someone if not the OP as it seems to be an issue for quite a few people.

I went through device manager and found out where the driver that is already installed was, i did this by going to device manager and to the USB DVBT device and then i went into the properties by right clicking it and then clicking properties, then i clicked on the Driver tab and in there clicked Driver Details, in there it mentions the folder location of the current driver that is installed it was in folder "C:\Windows\System32\drivers", i then went to the location and Deleted the file "AF15BDA.sys", then i went to back to device manager and Uinstalled the related DVBT device to the driver, and then i ran Scan for Hardware Changes, it failed to find a driver, i then chose to manually install the driver and browsed for the inf file and it then installed correctly and now it works fine.

1. Find out the location the current driver that is installed for the device via device manager driver details for that device.
2. Go to the folder and delete that driver file.
3. Uninstall the DVBT device in device manager.
4. Scan for hardware changes.
5. Manually install the driver downloaded from the website for your device via Device Manager.

If it happens again after this, you just have to repeat the same process, it seems to be an issue with the way the driver is automatically installed either with the driver setup file from the driver from the peak site or with the way windows automatically installs drivers.

That worked for me, Good Luck to anyone else with this kind of issue!
My System SpecsSystem Spec
07 Apr 2010   #29

Windows 7

Sorry to ressurect an old thread, but I'm having the exact same problem. Did you ever find a solution the second time round monsta?

In my case the card worked in the computer when I first upgraded to Win 7. Identified as an af9015 bda device, and i was able to install the original driver cd from there.

Then after a few days windows update decided it wanted to install a new driver for the card. I foolishly let it, and it then showed up in device manager as another brand of tv tuner (gold bda tuner dongle?????) or something vaguely similar. The card then wouldn't work - didn't pick up any channels, and only seemed to think it had one tuner.

I system restored to a point before the update, and the card then would only show up as an unknown device, and the drivers wont install as they say the hardware is not detected.

No amount of re-installing, blocking auto updates, playing with bios PnP settings, swearing, crying or shouting will now make it show up as anything other than a unknown device.

Anyone any ideas??


My System SpecsSystem Spec
08 Apr 2010   #30

windows 7 home premium

Unfortunately I never did get the card to work so I gave up on it. Sorry I can't help.
My System SpecsSystem Spec

 Unknown device in USB controllers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Unknown device in device manager after Bios default settings are
applied. Sorry that last word didn't get in the subject line. So: These two values are: USB\VID_0CF3&PID_3000&REV_0200 USB\VID_0CF3&PID_3000
Sound, Video and game Controllers in device manager is missing,
no sound,(there is a white x surrounded by red color next to volume icon) troubleshooting results in message reading "hardware changes might not have been detected". Sound, Video and game Controllers in device manager is also missing, please help ! Model L655D-S5116 (toshiba satellite) I...
Sound & Audio
Unknown Device in Device Manager/Show Hidden Devices
I have a Toshiba laptop, model L505-ES5018. I had Windows 7 Home Premium 64 bit installed on here, but decided to reformat my hard drive using Windows 7 Ultimate 64 bit. After the reformat was finished, I ran Windows Update and it found several items to download and install for me. I noticed...
base system device, video controller and unknown device missing
hie i have just installed window 7 and this devices are missing, any help will be very much appreciated. base system device device id PCI\VEN_1217&DEV_7110&SUBSYS_117C10&PEV_00 PCI\VEN_1217&DEV_7110&SUBSYS_117C10CF PCI\VEN_1217&DEV_7110&CC_088000 PCI\VEN_1217&DEV_7110&CC_0880 UNKNOWN...
Marvel not showing up in device man- storage controllers?
thanks for the help. I tried to delete this thread the site will not let me.
Hardware & Devices
Device Manager reports Unknown Device & explorer crash
How do i figure out what driver or even component windows wants software for when in the device manager under other devices it lists an unknown device and windows update cannot find anything. Oh and is it appropriate for me to use this topic to ask another question regarding explorer.exe as...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:18.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App