Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Drivers being deleted by something in Windows 7

24 Sep 2015   #11
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Just curious.
From you post #9
Quote:
I have Languard doing my windows update.
Why don't you just download and install Windows 7 Updates using the normal Windows 7 Update method.
You don't need a 3rd party program messing with Windows 7 Updates.

Of course this is just my opinion.


My System SpecsSystem Spec
.
24 Sep 2015   #12
superzeeman

Win 7 home premium 32 bit
 
 

I do it for PCI compliance that states that you must have a way of updating all software affecting the credit card environment. I have 50 terminals that need updating and believe it or not, Windows miss updates sometimes especially a new build that needs updates. I do let windows process most updates but for a network I find it much easier to have LanGuard do it. Plus it updates about 100 programs that Windows does not touch. It keeps my systems as secure as possible.
My System SpecsSystem Spec
24 Sep 2015   #13
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Well you post #12 puts a whole different meaning on your problem compared to your post #1.
Glad you added the extra information.

I will just go back to watching and leave you alone.
My System SpecsSystem Spec
.

24 Sep 2015   #14
superzeeman

Win 7 home premium 32 bit
 
 

No sweat. I can fix many things but this has me stumped. Oh well, if all else fails, do a fresh install but I hate to do it.
My System SpecsSystem Spec
27 Sep 2015   #15
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 
Group policy

OK,
lets try this

Use method 2 see KB 2500967.

Roy
My System SpecsSystem Spec
28 Sep 2015   #16
superzeeman

Win 7 home premium 32 bit
 
 

Yea, thought about doing that but I think I will follow your advice and do it tomorrow. I will post back what happens. Thanks again.
My System SpecsSystem Spec
28 Sep 2015   #17
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

I don't know if this will help but might add a clue.. Windows traces Device Manager install and uninstalls when they occur. The device is (probably) being uninstalled so am hoping for a trace. That would give you a date/time stamp to check against the LanGuard log to see if it's doing something at that time

It'll be a large file. Let's save current data. Rename C:\Windows\inf\setupapi.dev.log to setupapi.dev.log.old. Wait for the problem to happen again. Windows will write a new file. Look in the log for the word Uninstall. And post the new log file

fyi.. When I manually un-install the Generic monitor driver, I have an uninstall trace log entry as shown below. Hope you have a similar entry that starts Device Uninstall for your monitor device driver.
Code:
>>>  [Device Uninstall (Device Manager) - DISPLAY\SAM0945\5&2814FC75&0&UID1048849]
>>>  Section start 2015/09/28 20:02:55.678
      20:02:55.678 cmd: "C:\Windows\system32\mmc.exe" "C:\Windows\system32\compmgmt.msc" /s
     dvi: 20:02:55.679 {DIF_REMOVE}
     dvi: 20:02:55.680      Looking for class installer for 'Generic PnP Monitor'...
     dvi: 20:02:55.681      Using exported function 'MonitorClassInstaller' in module 'C:\Windows\system32\Montr_CI.dll'.
     dvi: 20:02:55.682      Class installer == Montr_CI.dll,MonitorClassInstaller
     dvi: 20:02:55.682      Looking for co-installer modules for 'Generic PnP Monitor'.
     dvi: 20:02:55.683      No CoInstallers found
     dvi: 20:02:55.683      Class installer: Enter
     dvi: 20:02:55.684      Class installer: Exit
     dvi: 20:02:55.685      Default installer: Enter
     dvi: 20:02:55.685           {Remove DEVICE}
     dvi: 20:02:55.686                InstanceID = 'DISPLAY\SAM0945\5&2814FC75&0&UID1048849'
     dvi: 20:02:55.686                Devnode Status = 0x0180600a
     dvi: 20:02:55.698                CM_Query_And_Remove_Subtree_Ex returns 0x00000000
     dvi: 20:02:55.701                Devnode Status after CM_Query_And_Remove_Subtree_Ex = 0x01806400
     dvi: 20:02:55.701                Query-and-Remove succeeded
     dvi: 20:02:55.702                {Delete DEVICE}
     dvi: 20:02:55.717                     Device Instance uninstalled.
     dvi: 20:02:55.718                {Delete DEVICE exit (0x00000000)}
     dvi: 20:02:55.719           {Remove DEVICE exit (0x00000000)}
     dvi: 20:02:55.720      Default installer: Exit
     dvi: 20:02:55.720 {DIF_REMOVE - exit(0x00000000)}
<<<  Section end 2015/09/28 20:02:55.720
<<<  [Exit status: SUCCESS]
My System SpecsSystem Spec
29 Sep 2015   #18
superzeeman

Win 7 home premium 32 bit
 
 

I will get those logs and post as soon as I have them thanks!
My System SpecsSystem Spec
01 Oct 2015   #19
superzeeman

Win 7 home premium 32 bit
 
 

OK I am forgetting to get that log before the employee comes in and I will write myself a note and do it tomorrow. Anyway, I have new wrinkle. The person came in and and the driver was uninstalled. I went to install the driver again and it told me access denied. I used an admin account so I should not be blocked out. There are no group policies preventing me from installing drivers. So it would not install so I rebooted the computer and the driver was back in place and the monitor was working correctly. Any thoughts on that one? It's starting to get annoying.
My System SpecsSystem Spec
01 Oct 2015   #20
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Did you rename the old log file? Zip a copy of the old log you renamed as well as the current C:\Windows\inf\setupapi.dev.log. Don't know that the log files will have the answers but is worth a look to see if anything jumps out
My System SpecsSystem Spec
Reply

 Drivers being deleted by something in Windows 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Dell XPS L502X had an aneurysm and self-deleted some drivers
I've got Dell XPS L502X that somehow deleted its network card and USBs drivers, went over to Dell and put all the specs into their littler product service helper and it brought up a list of factory-state drivers for the machine. I downloaded these drivers to a DVD (since the USBs and web don't...
Drivers
boot time scan may have deleted graphics drivers?
I ran a full system scan using avast, when complete it told me to run a boot time scan, so I did. Tower boots up fine, but it's not recognizing monitor. I believe it deleted my graphics card drivers. The tower boots up, it even recognizes my external Wi-Fi. But it's not recognizing my monitor. Is...
Graphic Cards
Asus DVD-Rom Drivers Deleted, Now Won't Boot
As per the ASUS form, when my DVD-rom would not read and cd/DVD, I deleted the drivers in the properties, deleted the drive in Device Manager and attempted to reboot. Now it will not reboot even in SAFE MODE. I tried my Windows 7 install disc to do a repair and it won't let me do that either. It...
Drivers
Deleted bad USB drivers, now on startup, USB keyboard and mouse inop
I recently have been experiencing BSOD with BUGCODE USB error. Machine freezes on startup, then sometimes automatically reboots. Sometimes freezes on startup at different points and has to be unplgged for about an hour before it restarts properly. I read on several threads to uninstall the USB...
Drivers
Unable to connect to internet, virus deleted my drivers
Hi everyone! My laptop, Lenovo T420, got infected by a nasty virus. Though I've deleted the virus, but it already deleted several drivers for my computer: ethernet controller, biometric coprocessor, and video controller (which I checked through 'Device Manager' saying: "No drivers are installed for...
Network & Sharing
Drivers deleted or corrupted
Hey everyone about a few months ago I was trying to update my iphone and was having problems doing so and i restarted my computer with the phone still hooked up like I have done many times before but when windows came up I had no usb drivers, sound drivers, network drivers. so now the only way...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App