Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sony VAIO Ethernet controller (code 28)

23 Nov 2015   #11
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

I found drivers for your computer on https://us.driverscollection.com/
> The site has a good reputation
> I've used it before and
> Have checked its driver files before both by inspection and with VirusTotal. They've proved safe

Lets start and first prove ethernet works. Can then follow-up with the others. Look in Control Panel->Programs and Features. If an ethernet driver is installed there, uninstall it.
> Go to their website.
> On their first window, click their search box and search SVE14A1V1EB 7.51.116.2012 to get the driver file. Click the download bar (snapshot below)
> 2nd window: Verify you're not a robot then click a download bar again
> 3rd window: Click the download bar again to start the download (they REALLY make sure you're not a robot nor can simply give away download links)

Let's see if this gives you an ethernet connection. If it does, you can also try right clicking the other devices->Update Driver. See if Windows finds it for the drivers online. Otherwise we'll look back at driverscollection




Attached Thumbnails
Sony VAIO Ethernet controller (code 28)-2015-11-23_154927.jpg   Sony VAIO Ethernet controller (code 28)-2015-11-23_195545.jpg  
My System SpecsSystem Spec
.
01 Dec 2015   #12
timmetje21

Windows 7 Proffesional 64 bits
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
I found drivers for your computer on https://us.driverscollection.com/
> The site has a good reputation
> I've used it before and
> Have checked its driver files before both by inspection and with VirusTotal. They've proved safe

Lets start and first prove ethernet works. Can then follow-up with the others. Look in Control Panel->Programs and Features. If an ethernet driver is installed there, uninstall it.
> Go to their website.
> On their first window, click their search box and search SVE14A1V1EB 7.51.116.2012 to get the driver file. Click the download bar (snapshot below)
> 2nd window: Verify you're not a robot then click a download bar again
> 3rd window: Click the download bar again to start the download (they REALLY make sure you're not a robot nor can simply give away download links)

Let's see if this gives you an ethernet connection. If it does, you can also try right clicking the other devices->Update Driver. See if Windows finds it for the drivers online. Otherwise we'll look back at driverscollection
thanks for answering, its really appreciated.
If im correct this is the same driver as from the sony driver website.

The weird thing is that the installation proces is instant done, so by pressing the 'instal now' button it finishes right after. It does say installation completes, and then my laptop gives me a sign that the software was installed incorrect :s..
Then when restarting it is stil giving the same thing at the drivers
My System SpecsSystem Spec
01 Dec 2015   #13
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Zip the file C:\WINDOWS\inf\setupapi.dev.log and upload to your next post

/* EDIT */
Also please run a Problem Device Report. Save the output to a flash drive so you can post from a different computer as I need to see all the information it reports
  • Click the Start Orb, type msinfo32 in the search box. Hit Enter
  • Click the + sign next to Components to expand it
  • Click Problem Devices. Anything appear?
  • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  • On the other hand, if no devices are listed, tell me so
My System SpecsSystem Spec
.

03 Dec 2015   #14
timmetje21

Windows 7 Proffesional 64 bits
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
Zip the file C:\WINDOWS\inf\setupapi.dev.log and upload to your next post

/* EDIT */

Also please run a Problem Device Report. Save the output to a flash drive so you can post from a different computer as I need to see all the information it reports
  • Click the Start Orb, type msinfo32 in the search box. Hit Enter
  • Click the + sign next to Components to expand it
  • Click Problem Devices. Anything appear?
  • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  • On the other hand, if no devices are listed, tell me so
Ethernet-controller PCI\VEN_10EC&DEV_8168&SUBSYS_9095104D&REV_07\4&30200ACB&0&00E2 De stuurprogramma's voor dit apparaat zijn niet geďnstalleerd.(means drivers are not installed)

SM-buscontroller PCI\VEN_8086&DEV_1E22&SUBSYS_9095104D&REV_04\3&11583659&0&FB De stuurprogramma's voor dit apparaat zijn niet geďnstalleerd.

setupapi.dev.zip


My System SpecsSystem Spec
03 Dec 2015   #15
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

It appears the Sony installation file isn't doing its job.

The log file you provided seems to affirm exactly what you're seeing: Even after the Sony installer runs, Windows still can't find any suitable driver for the ethernet controller.

So let's try this
> Click to go the Realtek download site
> Click on the download for Win7 and Server 2008 R2 Auto Installation Program (SID:1779116)
> Unzip to a folder on your Desktop. Open the folder, skim down to find setup.exe. Double click to run it

Any better luck?
My System SpecsSystem Spec
03 Dec 2015   #16
oscer1

win 7 64 bit
 
 

hi if still no luck with the link ComputerGeek gave you to the realtek site. I would make a restore point and try the drivers on the sony page it's not your exact model computer off by one doesn't have the last letter in it. i would try the intel chipset driver then the ethernet driver on this page. https://www.sony.co.uk/support/en/co...VE14A1V1E/list
My System SpecsSystem Spec
Reply

 Sony VAIO Ethernet controller (code 28)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Ethernet Controller - PCI bus 4 (Code 28)
Hello, I've bought a TP-Link USB Wireless Adapter (Model: TL-WN722N) and I can't seem to make it work. I have updated every driver on the pc except that Ethernet Controller - PCI bus 4, that i can't seem to figure out what it is. At this point I'm not even sure what the problem really is,...
Network & Sharing
Mass storage controller sony vaio
Nearly completed a clean install thanks to Greg's tutorial; however, device manager shows the mass storage controller with a yellow sign. I cannot update driver via online option, and I cannot find on the pci database. Any help will be much appreciated. Sony vaio fz38m Todd
Hardware & Devices
Problem with my Windows 7 Sony Vaio DVD Drive (Code 19)
I have an issue with my Windows 7 Sony Vaio DVD Drive. I had the DVD Drive replaced by Sony last fortnight which worked fine up until a couple of days ago. I've tried everything I can think of to get it to work but to no result. The message I’m seeing is ‘Windows cannot start this hardware device...
Hardware & Devices
Code (38) ethernet controller driver issue.
First post here. ~~So I recently dealt with a virus, and I reformatted my PC. Everything is working fine, however I cannot connect to the internet via direct connected through cable to my router. Manufacturer: Cyberpower Inc. Processor: AMD FX(tm)-4100 Quad-Core Processor 3.60 GHz RAM:...
Drivers
Ethernet drivers sony vaio
hey i installed windows 7 32 bit on my sony vaio model # VPCEE21FX and i cannot get the ethernet drivers, i need it really bad because usb is not working to good please help me out.
Drivers
Ethernet Controller (code 28) is missing
I really need help, i have a wireless card i use interent wirelessly(sry for my english) , i reinstalled windows 7 these are my specs: AMD athalon 64/Opeteron HT Hub Processor: AMD Sempron(tm_ Processor 3200+ 1.80GHz Mainboard:Asus M2n
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App