Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Issue with USB Driver Z97-A

05 Dec 2015   #1
dew1

windows 7
 
 
Issue with USB Driver Z97-A

Hello everyone,

I have installed windows 7 Pro 64bit and after installed USB driver USB port doesn't work ! however I have deleted driver by safe mode and now port working but still driver not installed so what can I do ?

Motherboard: Asus Z97-A


My System SpecsSystem Spec
.
05 Dec 2015   #2
georgeks

Windows 10 Pro x64
 
 

dew1 maybe the driver you try to install is older than the version you have after Windows installation?

Before you try installing the drivers, is Device Manager showing any exclamation marks?
If not, why bother.
My System SpecsSystem Spec
05 Dec 2015   #3
dew1

windows 7
 
 

Hi georgeks.

Actually, windows not installed driver for USB and I have installed last version of driver from ASUS website, check the below pic


Attached Thumbnails
Issue with USB Driver Z97-A-capture.png  
My System SpecsSystem Spec
.

05 Dec 2015   #4
georgeks

Windows 10 Pro x64
 
 

Have you try updating Windows first? If that does not work, can you try this method for finding/downloading the driver for your device? (actually works for all hardware) PC Help Forum
My System SpecsSystem Spec
05 Dec 2015   #5
dew1

windows 7
 
 

Quote   Quote: Originally Posted by georgeks View Post
Have you try updating Windows first? If that does not work, can you try this method for finding/downloading the driver for your device? (actually works for all hardware) PC Help Forum
I have tried by windows update but not found, However I have check the above link but DEV not found in website ! I have only found VEN is that enough?


Attached Thumbnails
Issue with USB Driver Z97-A-capture.png  
My System SpecsSystem Spec
05 Dec 2015   #6
dew1

windows 7
 
 

I have installed driver by driverlookup.com but got the seam issue.
My System SpecsSystem Spec
05 Dec 2015   #7
georgeks

Windows 10 Pro x64
 
 

My System SpecsSystem Spec
05 Dec 2015   #8
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Did you use the z97 mobo disk to install the drivers all would be on it usb2 & 3 plus all other necessary drivers probably some crapware too but all other good stuff too
My System SpecsSystem Spec
05 Dec 2015   #9
dew1

windows 7
 
 

Quote   Quote: Originally Posted by georgeks View Post
The same issue

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
Did you use the z97 mobo disk to install the drivers all would be on it usb2 & 3 plus all other necessary drivers probably some crapware too but all other good stuff too
I will try now
My System SpecsSystem Spec
05 Dec 2015   #10
dew1

windows 7
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
Did you use the z97 mobo disk to install the drivers all would be on it usb2 & 3 plus all other necessary drivers probably some crapware too but all other good stuff too
Thank you very much, I tried by CD and I install it successfully without any issue. But why I can't install it by ASUS website and got the above issue ?

thank you again
My System SpecsSystem Spec
Reply

 Issue with USB Driver Z97-A




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Driver Issue! Please Help!
Im probably just missing something small here but my computer was running very slow so i decided to wipe the hdd clean and install a fresh copy of windows 7 64bit. I formatted it through the cd at boot and installed windows 7. Went smoothly until i logged in and noticed i had no drivers at all. My...
Drivers
Possible driver issue
I am getting this error "Name resolution for the name dns.msftncsi.com timed out after none of the configured DNS servers responded". I found this thread from your forum http://www.sevenforums.com/network-sharing/3861-repair-default-gateway-every-5-min-getting-old-2.html It sounds like...
Drivers
2 new NIC's driver issue
Hi, Older system, upgraded from XP to Win7 (32bit) a while back - has been working fine. Have been having issues with internet "dropping out" fairly regularly. ISP says problem on my end, so decided to install a new NIC. Disabled onboard NIC and pop'd in new PCI NIC. Windows 7 sees the new...
Hardware & Devices
LAN driver issue...
For some reason, every time I unplug/plug in an Ethernet cable to my laptop, I have to reinstall my Realtek LAN driver in order for my computer to recognize being plugged in and connect to the wired network. Any ideas on why this may be? I'm doing some research on it and I'm not finding anything...
Drivers
Win 7 HP Driver issue HELP!
Ok this is strange, if ANYONE can help with this it would save me heart ache! I am running Win 7 Home 64 bit on 4 computers! ( 3 Laptops 1 Desktop ) I purchased a HP Color Laserjet 2025 DN printer. Installed it on the network and when I go to ADD Printers in control panel it finds the HP installs...
Drivers
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App