Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Issue Finding SM Bus and PCI Driver: Realtek?

24 Jan 2016   #1
G Force

Windows 7 Professional x64
 
 
Issue Finding SM Bus and PCI Driver: Realtek?

The special codes we are looking for is:

PCI Device PCI\VEN_10EC&DEV_5229&SUBSYS_1818103C&REV_01\4&5CFE19B&0&00E2

I am also missing this...

SM Bus Controller PCI\VEN_8086&DEV_1E22&SUBSYS_1818103C&REV_04\3&11583659&0&FB

I am running Windows 7 Professional x64. I figured the PCI device has something to do with Raeltek but I cannot figure it out further as I don't see anything matching on this webpage.

PCI Vendor and Device Lists

The SM Bus controller, I am absolutely clueless.

Windows Update did not find anything.

PCI Vendor and Device Lists

I was hoping someone from 7Forums can crack this. I cannot even crack it. I usually fix issues on my own.

Please do lend a hand! Thanks!


My System SpecsSystem Spec
.
24 Jan 2016   #2
derekimo

Microsoft Community Contributor Award Recipient

 
 

Welcome to the forum,

The top one is the card reader from Realtek.

The SM Bus controller should be fixed with the chipset driver.

If you give us the full model of the laptop we can link the drivers from HP.
My System SpecsSystem Spec
25 Jan 2016   #3
G Force

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by derekimo View Post
Welcome to the forum,

The top one is the card reader from Realtek.

The SM Bus controller should be fixed with the chipset driver.

If you give us the full model of the laptop we can link the drivers from HP.
HP Pavilion dv6t-7000

Thank you for the help. I appreciate it. I tried looking there for drivers on the HP page too. It's slightly confusing to me for whatever reason with the CTO edition I believe?

Thanks for the welcome!
My System SpecsSystem Spec
.

25 Jan 2016   #4
derekimo

Microsoft Community Contributor Award Recipient

 
 

You're welcome, I wouldn't worry too much about the CTO edition, it looks they all are,

Issue Finding SM Bus and PCI Driver: Realtek?-2016-01-24_21h14_49.png

I see the same drivers listed on each page, at least the ones you need,

Contact HP Customer Support | HP® Customer Support

Under chipset, I would install both of these,

Issue Finding SM Bus and PCI Driver: Realtek?-2016-01-24_21h08_37.png

The card reader is under storage,

Issue Finding SM Bus and PCI Driver: Realtek?-2016-01-24_21h10_37.png

I would suggest not using the download manager, just tick this first,

Issue Finding SM Bus and PCI Driver: Realtek?-2016-01-24_21h24_01.png


My System SpecsSystem Spec
25 Jan 2016   #5
G Force

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by derekimo View Post
You're welcome, I wouldn't worry too much about the CTO edition, it looks they all are,

Attachment 380459

I see the same drivers listed on each page, at least the ones you need,

Contact HP Customer Support | HP® Customer Support

Under chipset, I would install both of these,

Attachment 380460

The card reader is under storage,

Attachment 380461

I would suggest not using the download manager, just tick this first,

Attachment 380462
Thanks a bunch. I feel so challenged. This is me having a brain fart, I do device drivers for other people's computer's just fine. I'm so weird.

I will update after I update. Lol.



I can't seem to wrap my head around this one. I seem to have already had the MEI installed (oops) and uninstalled it because it threw this error, and now I rebooted and it's still returning this error from the installer I got. Windows does this all the time, and I don't know why. I will try clearing out my temporary files through a script I have made, see if that changes something.

Any ideas? Looks like vcedistx86 is the issue.

EDIT 3: No luck. I'm pretty swamped. Apparently I just found this out after some playing with Windows.


I uninstalled the "NEWER" C++ x64 package, only x86 remains. I will attempt to install this older one.
My System SpecsSystem Spec
25 Jan 2016   #6
derekimo

Microsoft Community Contributor Award Recipient

 
 

Forget that one for now, I was just covering both by recommending it.

Why did you uninstall it?

For that matter how did you come to need those two drivers in your first post?

I figured you had done a new install but it doesn't sound that way.
My System SpecsSystem Spec
25 Jan 2016   #7
G Force

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by derekimo View Post
Forget that one for now, I was just covering both by recommending it.

Why did you uninstall it?

For that matter how did you come to need those two drivers in your first post?

I figured you had done a new install but it doesn't sound that way.
I figured the new attempt to overwrite the previous install may have interfered with the one already installed.

Good question!

I performed a fresh install of my laptop and had obtained all drivers except the ones you found for me.

Is it safe to ignore the new error? I guess I wont have IME on my laptop any longer.
My System SpecsSystem Spec
25 Jan 2016   #8
derekimo

Microsoft Community Contributor Award Recipient

 
 

OK, I figured you did, those drivers are only needed after a clean install.

For now, just leave that and we'll see if you need it.

How did you uninstall it anyway?
My System SpecsSystem Spec
25 Jan 2016   #9
G Force

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by derekimo View Post
OK, I figured you did, those drivers are only needed after a clean install.

For now, just leave that and we'll see if you need it.

How did you uninstall it anyway?
Through Control Panel. The second time I did it through Revo Uninstaller Pro, and no difference.

Currently, I am trying this:

https://downloadcenter.intel.com/dow...cation-Utility

EDIT:

I am calling it a day.

Thanks for all the help. Greatly appreciated.

My System SpecsSystem Spec
Reply

 Issue Finding SM Bus and PCI Driver: Realtek?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Need help finding a driver
Hi I live in the UK and recently bought a Hype SD/Sim Card Reader Optical USB Computer Mouse I got it from tx max and unfortunately the only two the shop had the driver cds were cracked. Its for my dad and he likes the feel of the mouse. So any help would be appreciated thanks!
Drivers
Need help finding my ethernet driver.
I recently downloaded Windows 7 Ultimate (64bit) on my computer. Everything went fine until I saw the internet icon on my bar had not internet connection. I was surprised since it was looking for a wireless connection and it was not automatically connected to the internet with my ethernet cable. I...
Drivers
ASUS/Realtek, Latest Realtek versus default W7 Audio driver
I installed the Realtek HD audio driver from the ASUS download site (P8Z68-V Pro MB) and all was well until I installed an MSI 560TI video card and let it install the Nvidia HD Audio drivers. The problem I have been chasing ever since was the Realtek HD Audio Manager popping up after the system...
Sound & Audio
Issue finding driver for Canon IP1900
lve been looking high and low for a printer drivers for the printer mentioned in the title.. while l have found a 32bit driver l cannot find a 64bit one and the installation program keeps on telling me when l try the 32bit driver lve found that its not for 64bit OSs, and all the compatable...
Drivers
Problem Finding Driver
Trying to install Windows7 and I need to install a driver before it will recognise my Hard Drive but I can't find the driver for my Gigabyte GA-MA770T-UD3 motherboard. I've checked the CD that came with it but none of the drivers in the BootDrv folder work. Help please?
Installation & Setup
Driver finding software
Hi, Does anyone use one of the driver finding programs? for example Driver Detective Are they any good?
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App