Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SM Bus Controller Drivers needed and audio issue

21 Feb 2016   #1
Arzo82

Windows 7 Ultimate 64 bit
 
 
SM Bus Controller Drivers needed and audio issue

I recently had to replace my motherboard and after doing so, I now have the following problems that I can't figure out how to fix. I'm hoping someone can give me some advice on what to try next:

1. The front speaker ports on my computer no longer are working. I've checked the connection on the motherboard to ensure I have it connected properly. When looking at the pins I see only one way it could be plugged in so I don't think I have it backwards or anything like that. However, when I plug speakers into that audio port, nothing comes out. On my old motherboard, when I plugged them in, the audio automatically switched channels but it doesn't do that now. I've swapped speakers with known good ones and tried a headset as well. Not sure it helps but audio ports on the back of the computer seem to work fine.

2. While digging into the audio issue, I noticed that Device Manager doesn't have drivers for SM Bus Controller. Would that be causing the audio issue? Regardless, I can't seem to find drivers for this. I have the setup CD that came with the motherboard. I don't see any specific options to install this driver when I run that. I've had Device Manager try to find the drivers off that CD and it doesn't find any. I've also tried searching my Win7 OS CD and same issue. Any advice on how to get these drivers?


My System SpecsSystem Spec
.
21 Feb 2016   #2
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Hi and welcome,

Install the chipset drivers for your motherboard to get the SM Bis controller drivers.

What case do you have? Some older cases may not be compatible with all audio connections.

What motherboard did you have previously?
My System SpecsSystem Spec
22 Feb 2016   #3
Arzo82

Windows 7 Ultimate 64 bit
 
 

Any ideas on where I can look for the chipset drivers? I have the disk that came with the motherboard and it doesn't find them.

No idea on the case. It's a generic one that I bought a few years back. I know it's a mid-tower but no idea beyond that. I don't know what you mean about not compatible with the audio connections. I can see the ports available on the back panel.

The old motherboard was a EVGA 111-CD-E630. Whatever damaged the motherboard took out my processor and some memory as well so I've replaced all of that with what I've listed in my profile.
My System SpecsSystem Spec
.

22 Feb 2016   #4
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Go here and get the Intel INF Installation drivers. You could also look on the disk that came with your motherboard for the same driver..

GIGABYTE - Motherboard - Socket 1150 - GA-Z97-HD3 (rev. 2.1)

EDIT: Look at page 15 of your motherboard manual and see if you can recognize any names from your case front panel audio connector.
My System SpecsSystem Spec
22 Feb 2016   #5
Arzo82

Windows 7 Ultimate 64 bit
 
 

Thank you so much. That resolved the driver issue for the SM Bus controller.

Any advice on the audio issue? Device Manager no longer shows any exclamation points or question marks so all the drivers seem to be installed properly. On the old motherboard, I'd get a popup when I plugged something into those front ports stating that I plugged in a device and what did I want to do with it. I don't get that now so it makes me wonder if the ports just aren't active in some manner. I've tried plugging in multiple headsets and speakers but nothing happens with any.
My System SpecsSystem Spec
22 Feb 2016   #6
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Did you look at your manual on page 15, to see if the connections match?
My System SpecsSystem Spec
Reply

 SM Bus Controller Drivers needed and audio issue




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Help needed in HD Audio and installing Realtek drivers.
Ok so lets get started. This is my first post.Below described is my PC's rig AMD FX6300 Gigabyte GA-78LMT-USB3 Galaxy NVIDIA 630 2gb ddr3 4 gb ram and 500gb hdd my problem is that I hear only one sided audio from my headphones when I connect the HD Audio pin on the board. And when I insert...
Sound & Audio
ASUS P5S - MX SE Multimedia Audio Controller drivers
I formatted my computer, which has an Asus motherboard, the P5S - SE, and i installed Windows 7 32. I have managed to install all the drivers except the Multimedia Audio Controller drivers. I searched the official site of Asus but it does not give any Win7 drivers. I tried the ones for Vista...
Drivers
SM Bus Controller drivers issue Windows7 professional 64bit
SM Bus Controller drivers issue Windows7 professional 64bit Dell inspiron N5520 i7 The drivers for this device are not installed. (Code 28) When i do update on internet its unable to find and cant find these specifix driver solution in this regard
Drivers
issue i can disable a douple Controller High Definition Audio
Hi i update my ati drivers and the realtek high definition drivers i have 2 Controller High Definition Audio and i can not disable one one is for realtek the other is of the video card
Hardware & Devices
Audio drivers needed
Hi, everyone. I've recently installed Win7 on my ASUS A8V-VM-SE mobo. Win7 has found every driver except for the sound... Well, actually it has found a driver but it's showing (S/PDIF) for some reason not AC'97. I need an AC'97 driver but cannot find one that works with this mobo. I've tried...
Sound & Audio
Multimedia audio controller Drivers
please Help i installed Creative Sound Blaster PCI128 now i see in the device manager other devices --> Multimedia audio controller i downloaded the drivers to win2K from creative site but the installer is start then crash with a blank messege i check in the installer and there is no...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App